rsync -a to disk image file doesn't preserve file ownership info

Discussion in 'Apple' started by Christopher Woodfield, Nov 13, 2003.

  1. Hello,

    I've been attmempting to back up a remote Linux filesystem via "rsync
    -a" to my 10.3 machine. The -a is for "archive", which preserves file
    attributes such as owner/group, file permissions, etc.

    What I've noticed is that when the rsync destination is a directory,
    everything works as planned. However, when the destination is a mounted
    disk image, the owner/group attribute of the files are not preserved;
    they are replaced with my login UID and GID "unknown".

    Is this a known issue, and is there a workaround?

    -Chris
     
    Christopher Woodfield, Nov 13, 2003
    #1
    1. Advertisements

  2. Christopher Woodfield

    Tom Stiller Guest

    Does the mounted disk image have the "ignore ownership on this volume"
    box checked in the GetInfo dialog?
     
    Tom Stiller, Nov 13, 2003
    #2
    1. Advertisements

  3. You need to mount the disk image with the "-owners on" flag. Either
    use 'hdiutil attach image_name.dmg -owners on' (if you're using the
    command line to mount) or go into the Finder, do a 'Get Info' on the
    disk image, and deselect "ignore ownership on this volume"
     
    Matthew Russotto, Nov 14, 2003
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.