1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Running a 144 floppy disk on ancient computer ??

Discussion in 'PC Hardware' started by Vince m1bnl, May 31, 2004.

  1. Vince m1bnl

    Vince m1bnl Guest

    Hi all

    I'm trying to get a 1.44 floppy to work with
    an old compaq 286 computer. the computer
    sees it as a 1.2m 5 1/4 disk and wont see all the
    sectors. Dos 5 is installed. the dos5 book says
    "Device =driver.sys /d:1 /f:7" would add driver
    for 144 floppy, msd even reports a drive D which is
    144, I can see a dir but anything else fails!!

    Any suggestions????


    Vince
     
    Vince m1bnl, May 31, 2004
    #1
    1. Advertisements

  2. Vince m1bnl

    CJT Guest

    I suggest you use a new computer instead.
     
    CJT, May 31, 2004
    #2
    1. Advertisements

  3. Vince m1bnl

    Pen Guest

    Pen, May 31, 2004
    #3
  4. Vince m1bnl

    Vince m1bnl Guest

    The drivparm does much the same as device=driver I think
    ( - It's quite a surprise to go back to computers as they used to be )

    Vince
     
    Vince m1bnl, Jun 1, 2004
    #4
  5. Vince m1bnl

    Greg Guest

    I have a little 2k utility (C144.COM) that we used back in the olden days to
    patch machines that did not support them. Email me and I will send it to you
     
    Greg, Jun 1, 2004
    #5
  6. Vince m1bnl

    reply Guest

    DOS 5 shouldn't need any driver for a normal floppy!

    Check your computer's CMOS settings for the drive, to make sure it is properly
    specified.

    On most computers you get there with the Del key at boot time, but some
    Compaq's used the F10 key

    Since built in floppies are A: and B: (if two), not sure what MSD is reporting
    about that drive D -- something sounds strange.
     
    reply, Jun 1, 2004
    #6
  7. Vince m1bnl

    Ajax® Guest

    Have you tried specifying the /s/h/t instead of using the /t argument?
    and are you trying to access it as a: or d:?

    Another option would be a HD floppy controller with it's own bios rom
    onboard.
     
    Ajax®, Jun 1, 2004
    #7
  8. Vince m1bnl

    GEO Me Guest

    You don't need to change anything on your configuration files, but
    instead you should be changing the BIOS using the setup disks provided
    by COMPAQ; they are still available from the old web site -now part of
    H-P. COMPAQ did not have an on board setup, but the setup was done
    using the supplied programs.

    Try SP1743: ALL Compaq platforms running DOS 6.x
    (Supersedes SP1248, SP0957)

    http://h18007.www1.hp.com/support/files/

    Good luck.
    Geo
     
    GEO Me, Jun 1, 2004
    #8
  9. Vince m1bnl

    Ajax® Guest

    As long as it's supported in the pc's bios that is true.
    Many 286's didn't have native support for 1440k drives. Only 720k's.
    Using driver.sys or driveparm assigns a second drive letter to the
    drive for the device driver enabled format. Not strange at all, We had
    to do that to use 1440k diskettes on toshiba laptops most of the way
    through the 386 cpu series.
     
    Ajax®, Jun 1, 2004
    #9
  10. Vince m1bnl

    Ajax® Guest

    Again, if it's new 'nuff to have native 1440k support. Many did not.
     
    Ajax®, Jun 1, 2004
    #10
  11. Vince m1bnl

    Mike Dee Guest

    Maybe it's a 720k drive, not 144. Try placing tape over the cutout on the
    floppy [not the locking tab] and see if it accepts it.

    D.
     
    Mike Dee, Jun 1, 2004
    #11
  12. I have used 1.44M floppies on ancient IBM PC/ATs, including
    the original 6MHz AT. For such old machines, the BIOS needs
    a patch, to reset the BIOS diskette parameter information to
    reflect 18 sectors/track when accessing a 1.44M floppy. I
    ended up writing a little TSR to do this for me, and then
    use it together with the loadable floppy device driver.

    If you are interested, e-mail me. I will supply x86
    ASM source, as well as a .COM file.

    Sincerely
    Kevin

    Executable is supplied as FreeWare, source under any
    standard "free" license (GPL, LGPL, Artistic, BSD or
    other).
     
    Kevin G. Rhoads, Jun 1, 2004
    #12
  13. Vince m1bnl

    Vince m1bnl Guest

    Good point, but MSD.EXE is showing a drive D with 144M C-80 H-2 S-16
    so it should be OK.

    I see a "dir" on D but it reports sector lost when I try to read a file.
    I have tried two 144 floppy drives so I dont think the drive is a
    problem.
     
    Vince m1bnl, Jun 1, 2004
    #13
  14. Vince m1bnl

    Vince m1bnl Guest

    Thanks - I have some setup disks - V 8.0 rev B not sure what the SP
    number
    was - they seem to automatically report it as a 1.2M 5.25 inch and wont
    let me change it - i'll look at compaq - oops! HP.com

    Vince
     
    Vince m1bnl, Jun 1, 2004
    #14
  15. Vince m1bnl

    Ajax® Guest

    i don't think the drive is the problen either. I do think that your
    best otion will prolly be to take Kevin Rhodes suggestion that he
    posted down in this thread. I used the same solution years ago but
    will prolly not be able to find my bios extender fast enough to be
    useful. If'n he has his handy prolly be a good idea to take him up on
    his offer. As you have already found out, the m$ solutions leave alot
    to be desired.
     
    Ajax®, Jun 1, 2004
    #15
  16. Hello Ajax,

    once upon a time (pre CD) m$ invented a special floppy format DMF, so
    they did need less distribution floppy's. Of course this format wasn't
    pubished at that time. So Christian Hochstätter wrote a small tsr called
    fdread.exe to allow enhanced formatting. IIRC that also changed the
    standard bios settings. Even if difficult to find, it might be worth a
    try.
     
    Matthias Tacke, Jun 1, 2004
    #16
  17. Vince m1bnl

    Vince m1bnl Guest

    Just an update - no luck.

    C144.com and others can change the CMOS settings but
    the BIOS seems to stop me reading more than the 15 sectors on
    a 1.2M ( There are 18 sectors on a 144 ). It can't be a hardware problem
    cos I can read everything on a 720 floppy, and I can read a DIR
    on 144 ( so I can read some sectors, and I have got a 144 disk drive ! )
    ..
    The compaq SP did not help either.

    Vince
     
    Vince m1bnl, Jun 2, 2004
    #17
  18. but
    Right. DOS and the BIOS together are being "helpful", the
    drive is marked as 1.2M, which only has 15 sectors, so
    between them, DOS and the BIOS that is, they are "forcing"
    the drive to see no more than 15 sectors by resetting the
    sectors/track info in low core.

    You will only be able to read/write 1.44M floppies with
    a BIOS patch. There are several out there. Or you can
    use mine, if you want it.
     
    Kevin G. Rhoads, Jun 2, 2004
    #18
  19. Vince m1bnl

    Greg Guest

    Disable the onboard controller and put a card in.
     
    Greg, Jun 3, 2004
    #19
  20. Vince m1bnl

    Ajax® Guest

    Which is what I suggested in another post since you prolly have it
    handy and you offered. :)
     
    Ajax®, Jun 3, 2004
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.