Running memtest86 on a P4C800 Deluxe

Discussion in 'Asus' started by John G. Shaw, Nov 23, 2003.

  1. John G. Shaw

    John G. Shaw Guest

    I recently obtained a system consisting of:

    Asus P4C800 Deluxe mobo,
    Antec 1080i case (with 430W powersupply, 3 case fans),
    Intel P4-300(H) GHx (boxed with heatsink),
    Corsair TwinX512-LLPT memory,
    FX5900 ("normal" version, 128 MB, 256-bit bus)
    .... disks ...

    Bios is version 1011-007 (lastest stable version).
    All mobo settings are "default" (no explicit overclocking).

    The vendor was supposed to burn in the mobo/CPU/memory before shipment.

    When I run "memtest86" (version 3.0), it hangs somewhat randomly
    after a few minutes (~3 - 5) of operation. It never reports a memory error,
    it
    just hangs. There are two places where it typically stops (but it has failed
    in
    other tests a well, apparently randomly):

    1) in test 4 at the 55/61% point; or
    2) in test 6 at the 97/40% point.

    It is ALWAYS testing the very low memory section (0K - 632K), and
    I expect that memtest is just at the point of relocating itself when the
    hang occurs. (???)
    If I run tests individually (say 4 and 6 over and over again), it does not
    hang
    or find any errors. I have tried loading memtest a couple of different ways
    (via
    GRUB from the hard disk, or via a floppy). I have also tried this with
    various
    mobo settings, such as with or without hyperthreading. There is no
    difference.

    Memtest has not been updated in a very long time (18 months?) .
    I have seen threads relating to memtest failures before, so its not clear
    this is a
    mobo/memory/CPU problem or not. WinXP/SP1 and SuSE-8.2 Linux (with
    a 2.4.21 kernel upgrade to properly support SMP operation) apparentl
    are stable and work well. There have been reports of memtest failing with
    certain BIOS versions, and running with others.

    Has anyone else seen this problem?

    tnx ... jgs
     
    John G. Shaw, Nov 23, 2003
    #1
    1. Advertisements

  2. John G. Shaw

    Bitsbucket Guest

    Are you sure it is hanging?????? When it does the test without the cache, it
    is VERY slow. I am running a machine with 1 gig of memory at 200 MHz FSB and
    it "seems" to hang when in all actuality it's just VERY slow....
    Bitsbucket
     
    Bitsbucket, Nov 23, 2003
    #2
    1. Advertisements

  3. John G. Shaw

    Cliff Guest

    I also had the same problem (freezing). Found that disabling legacy USB
    support (in BIOS) and also unplugging all USB devices (if you can) fixed the
    problem.

    HTH, Cliff
     
    Cliff, Nov 23, 2003
    #3
  4. John G. Shaw

    John G. Shaw Guest

    Problem solved! Thanks to those who responded.

    1. I determined that Memtest-86 was definitely hanging. The "WallTime" was
    not changing for several minutes and the keyboard was completely locked up
    (esc or c did not work).

    2. I traced the problem to a single USB connection that was causing the
    problem; in my case it was from an Energizer 450VA UPS (only $10 after
    rebates). I left the USB legacy setting at "Auto"; and the other connections
    (a Canon scanner and an HP laser printer) had no effect. This UPS has a very
    poor design. It resents itself as a "HID" (Human Interface Device) that is
    interpreted as a USB keyboard (or game controller) to both Windows and
    Linux. Furthermore, it asyncronously sends out ASCII data at one second
    intervals. This has caused other problems, such as certain applications
    receiving random input data, so I have pulled the (USB) plug on it
    permanently. It still can function as a "dump" UPS to filter out short
    transients.

    The computer can now run Memtest-86 thourgh ALL tests without error (it
    takes about 30 minutes to complete all 13 tests).

    tnx ... jgs
     
    John G. Shaw, Nov 23, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.