S-ATA on Asus P4PE Promise Fastrack controller :-(

Discussion in 'Asus' started by Lars-Erik Østerud, Oct 27, 2004.

  1. I bought a new 80GB S-ATA disk to use with my P4PE onboard Promise
    Fastrack S-ATA controller, but I'm not gettings things to work :-(

    The Promise flashes a "no array defined" error messages at boot and
    the drive is not visible from Win 98se (drivers installed) or FDISK
    (I plan to upgrade to WinXP as soon as I have the new drive working)

    If I define a STRIPED array from the Promise BIOS setup the disk is
    visible from Win98se or FDISK, but the size is only 12GB's :-((((((

    (when creating a STRIP array I must choose STRIPE block size, what is
    this, with only one disk it sin't really a STRIPED array, is it :)

    So, HOW do I use the Promise Fastrack S-ATA controller as a regular
    S-ATA controller with only one S-ATA disk connected? Please help!!
     
    Lars-Erik Østerud, Oct 27, 2004
    #1
    1. Advertisements

  2. Lars-Erik Østerud

    tk Guest

    Did you install the promise 378 ATA driver? I had 1 Seagate
    160 SATA drive on the promise controller and it worked fine
    until I bought another. Switched to Raid driver and changed to raid in bios
    and has
    worked like a charm in Windows XP SP2.
     
    tk, Oct 27, 2004
    #2
    1. Advertisements

  3. tk skrev:
    Got it working. Used another FDISK-like utilty to partition it.
    Seem to work OK (old P-ATA 11MB/sec, new S-ATA 40 MB/sec :)
     
    Lars-Erik Østerud, Oct 27, 2004
    #3
  4. Now even if I got the S-ATA drive visible from DOS and Win98 (used
    Ranish Partition Manager to make an active PRI FAT-32 partition) I can
    boot from the S-ATA drive. I have formatted it from a floppy disk and
    from WIn98se with system. And everything look OK, but when I set the
    S-ATA as boot drive (I think I have set the options for the P4PE
    right, but if anyone could brief me, plese do) no boot happends. That
    is no "Starting Win98..." prompt. Just doesn't happend anything :-(

    Now what is the problem? Why doesn't the bootloader start at all?
    Is there something about the MBR and/or partitioning from Ranish?

    The drive is visible (and useful) at full speed from Win98se (if I
    boot from the old P-ATA disk that is), but not boot from S-ATA :-(
     
    Lars-Erik Østerud, Oct 27, 2004
    #4
  5. Lars-Erik Østerud skrev:
    OK, something with the MBR, I ran an FDISK /mbr on the new disk,
    and after that it booted as it should (allthough some programs, like
    Zonelarm and Avast, lost all configuration, even though the new disk
    is a true copy of the old, why didn't the config survive the copy?)
     
    Lars-Erik Østerud, Oct 27, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.