SATA Raid 1 Data Corruption - A7N8X / RocketRaid 1520

Discussion in 'Asus' started by ice, Dec 14, 2005.

  1. ice

    ice Guest

    Hi There

    I have 2 x 250 SATA 150 Seagate drives. Attached them to the MOBO SATA
    connections and the Promise BIOS never saw them. Spend 4 weeks with
    tech support and eventually gave up and bought a Highpoint Rocketraid
    1520. Connected everything up and the drives were found.

    Initialised & formatted the HDD with Windows XP SP disktools, set up a
    RAID 1 array and then copied over my data. Only to find it was mostly
    corrupted.

    Tried reinstalling and reformatting, but had the same corruption
    problems. So uninstalled, and started again, but this time set up a
    RAID 0 array, and all data copied over was fine. So uninstalled and
    retried with RAID 1 only to find the same corruption problem.

    Can any one provide a solution to this data corruption problem? Tech
    support so far has been somewhat poor :(

    TIA
    Ice70
     
    ice, Dec 14, 2005
    #1
    1. Advertisements

  2. ice

    lam9068 Guest

    a week ago i had same confusion as you. and i gave up, too.
    but yesterday i've saw some tech. through tom's and now i think
    raid must at least with 3 hdd then raid work !!

    good luck &
    merry christmas
     
    lam9068, Dec 14, 2005
    #2
    1. Advertisements

  3. No.
    There are a lot of different forms of 'RAID'. RAID3, and RAID5, require
    three drives or more (which is what the 'reference' you are seeing is
    about). RAID0, should never have been called RAID at all (it does not give
    any 'redundancy', and given that the 'R' in 'RAID', stands for
    'redundant', it is naughty, that it is included as a form of 'RAID' -
    however this has happened, since used in combination with RAID1, as
    'RAID1+0', or 'RAID10', it is one of the simplest/fastest forms of RAID).
    However 'RAID1', gives redundancy, and works perfectly with many
    controllers. It is more commonly called 'mirroring', and is 'borderline'
    on whether it should be included with the normal RAID forms (which
    normally have parity calculations involved), but it most certainly
    _should_ work. The 'higher' RAID forms, all need three or more drives, but
    RAID1, is perfectly legitimate.
    So, RAID1, is perfectly possible, and can work. The downside of it is that
    you lose 50% of your storage capacity. Now the original poster has the
    very strange situation, that the form that should provide redundancy
    (RAID1), is giving data corruption, while the form that doesn't (RAID0),
    doesn't. I'd have to say that this sounds like a controller problem, or
    some borderline I/O problem with the drives, which is showing up in the
    RAID1 configuration. Now there have been a lot of data I/O problems with
    SATA150, and some manufacturers ship their SATA150 drives, set to wake up
    using SATA133 for this reason (Hitachi do this, and offer a software tool
    to switch the interface speed up, if you are confident that your hardware
    really will work - given that the only speed gain from 133 to 150, is
    basically immeasurable, except by benchmark programs, since the basic
    speeds of the drives themselves is still below 100MB/sec, this is a much
    safer way to go...).
    I'd suggest seeing if Seagate have a software tool to turn the interface
    speed down to SATA133, and seeing if both problems disappear (the
    inability for the motherboard controller to recognise the drives, could
    well come from the same source)...

    Best Wishes
     
    Roger Hamlett, Dec 14, 2005
    #3
  4. ice

    ice Guest

    Hi Roger

    thank you for the reply.

    Contacted Seagate who replied:

    "The controller is what determines the speed (SATA 133) of the drive.
    Try exchanging your cables also."

    These are the second set of cables I have tried. I would guess that if
    they work for RAID 0 they should really work for RAID 1?


    I have noticed that the rocketRAID card and my nvidia 6800 GT share
    the same IRQ (16) I don't really have any idea what that means, or if
    its meaningful. Or even what to do if it is...

    thank you

    Ice70
     
    ice, Dec 14, 2005
    #4
  5. I thought you said the drives were signalling at SATA150 rate?. The
    utility _is_ available from Seagate (but you have to get them to
    understand that you want to turn the rate _down_ from the maximum
    supported by the controller and drive). It changes one of the mode page
    settings in the drive, so the controller cannot use the faster rates.
    The problem is that if this is a really 'borderline' error, anything is
    possible,and the slight timing differences between the two modes might
    make a difference, but generally if the cable is reliable in one mode it
    ought to be OK in the other.

    It means I'd suggest moving the card to a different slot. While devices
    should be able to share IRQ's, the AGP display cards, are commonly one of
    the devices that has the most problems with this (remember at times there
    will be a lot of interrupts from an AGP card). If it is showing '16', then
    it suggests that one of the advanced interrupt controllers is present that
    supports interrupts above 15, and should avoid this happening. Normally
    the AGP shares with the top PCI slot, so a different sot may help.

    Best Wishes
     
    Roger Hamlett, Dec 14, 2005
    #5
  6. ice

    TomC Guest

    ice;

    A couple of years ago I had the same problem -- data corruption in Raid1
    with a RocketRaid card. In my case only files > 1 MB were corrupted. There
    were no error messages. I no longer use Highpoint cards.

    I've become a fan of 3ware RAID cards. They are easy to install, have good
    documentation, are easy to monitor, give high throughput (the card reduces
    the CPU load), and are Linux-friendly. 3ware RAID products are a bit more
    expensive than their competition, and are worth it. You might look at
    3ware's 8006-2LP, that will let you mirror your two SATA drives. It is about
    $120.

    http://www.provantage.com/buy-73WAR...a-raid-pci-controller-cables-kit-shopping.htm

    Good luck.

    TomC
     
    TomC, Dec 15, 2005
    #6
  7. ice

    ice Guest

    Hi TomC

    I think I will try and return the card... especially when you get this
    kind of response form the 'tech support'

     
    ice, Dec 15, 2005
    #7
  8. ice

    TomC Guest

    I think I will try and return the card... especially when you get this
    I was so disgusted with having wasted over a dozen hours trying to get that
    little POS to work that I didn't even return it, I trashed it. The data
    corruption, which was reproducible for large files, was NOT related to a
    hard disk. It was caused by their card or their driver, since everything
    else remained in place for the 3ware RAID card, which has worked perfectly
    since.

    TomC

     
    TomC, Dec 17, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.