1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

SB Live platinum and AC3 DD via SPDIF

Discussion in 'Soundblaster Live' started by Careco, Jul 5, 2003.

  1. Careco

    Careco Guest

    Platform XP, SBLive (pre 5.1)
    On a clean install of XP I can get Dolby Digital via SPdif to output to
    DTT2500 speakers no prob (using the generic XP drivers) however when I
    install the apps and new drivers (Livedrivepac from creative website )I can
    no longer get the DD via SPdif to work, only analogue out works (using Power
    DVD).

    I have installed newest drivers and the XP patch to no avail.
    I want to use the appz that come with the drivers.
    How come I lose DD everytime???

    Answers and suggestions anyone?
     
    Careco, Jul 5, 2003
    #1
    1. Advertisements

  2. Careco

    Bendit Guest

    Just a thought here. Did you check the digital output checkbox in
    audioHQ ?

    (either way, PowerDVD should be set to SPDIF-OUT mode)

    do you even see that checkbox ? (trying to see if the drivers are even
    offering you that feature or if you have the 'value' edition drivers
    installed)

    what version of PowerDVD are you using?
     
    Bendit, Jul 7, 2003
    #2
    1. Advertisements

  3. Careco

    Careco Guest

    Everything was working fine with the generic XP drivers SPDIF output was
    lost when the Creative drivers were used

    4

    Enable SPDIF = deadly silence
    switch to 2 speaker mode = sound

    Solution?

    Creative, where are the drivers that work?
     
    Careco, Jul 8, 2003
    #3
  4. Careco

    Neil Deadman Guest

    Which version of these drivers?


     
    Neil Deadman, Jul 16, 2003
    #4
  5. Careco

    Careco Guest

    Thanks,

    Downloaded drivers from Fileplanet, now got AC3 back through SPDIF

    Creative support??? why bother.

    Brism
     
    Careco, Jul 19, 2003
    #5
  6. Careco

    chaferd Guest

    I have the exact same problem. I have a dual boot system with XP and 2000.
    With back to back boot-ups, SPDIF out works in 2000 but not in XP with the
    latest drivers from the creative site. I'm downloading the drivers from
    fileplanet now, hopefully they will fix this garbage.
     
    chaferd, Jul 20, 2003
    #6
  7. Careco

    chaferd Guest

    After installing the drivers off of fileplanet, SPDIF actually works for me
    in XP. I haven't experienced a reset while attempting to use PowerDVD.
    Make sure that you have digital output only and spdif bypass on. Other than
    that, all I can think of is to try re-installing some software....
     
    chaferd, Jul 21, 2003
    #7
  8. Careco

    Avidous Guest

    I was also having major problems with reboots, and n checking creatives site
    I found an obscure reference to a rather obvious problem.

    Since the newer mainboards do not have ISA slots, the BIOS is defaulted to
    having the IRQ's set for PCI PNP control. But since the Sound Blaster cards
    use IRQ 5 for legacy support, you have to change the BIOS IRQ 5 control to
    legacy.
     
    Avidous, Jul 24, 2003
    #8
  9. Hi,

    I just realised that my DD5:1/AC3 output has stopped working under WinXP as
    well since using the 5MB (ish) patch from creative. Has anyone resolved this
    issue yet, maybe its related to the DVD software, I use InterVideo WinDVD
    Platinum. I will have to re-read the threads to find out more about a fix.
    ..

    Wayne ][
     
    Wayne Youngman, Jul 25, 2003
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.