Setting default printer won't take... where is this value actually stored?

Discussion in 'Apple' started by Viktor Haag, Jun 13, 2007.

  1. Viktor Haag

    Viktor Haag Guest

    Can anyone tell me where OSX actually stores the default printer
    setting?

    The Printer List dialog won't let me set a default printer - I select
    a printer, and click Make Default, and no joy -- ergo, my default
    printer is determined by the order I installed them in. Not optimal.

    I'd like to figure out why this is happening, and my best guess is
    some weird permissions conflict...
     
    Viktor Haag, Jun 13, 2007
    #1
    1. Advertisements

  2. Viktor Haag

    Viktor Haag Guest

    Another oddity -- in the Printing preferences dialog I cannot select
    anything /but/ "last printer used" as the one to choose by default.
    And despite the "last printer used" setting, what it really seems to
    choose by default is the last printer driver installed.
     
    Viktor Haag, Jun 13, 2007
    #2
    1. Advertisements

  3. Viktor Haag

    Viktor Haag Guest


    Thanks very much for the pointer; I tried this tool, but it doesn't
    seem to solve the problem... 8P
     
    Viktor Haag, Jun 25, 2007
    #3
  4. try a shell and 'man lpadmin' and 'man lpstsat' and 'man lpoptions'

    Cups is built on top of the System V type printer subsystem IIRC..it is
    on Linux anyway.

    I think the configs are in /etc/cups/lpoptions

    It should say Default <your printername>

    On MacOS is may be different..hang on.. yes..on my wifes machine there
    is no system wide default..just on a user basis and thats in the users
    home directory in the file .lpoptions

    You wont see that from the X-window environment tho..need a shell to
    look it up.
     
    The Natural Philosopher, Jun 25, 2007
    #4
  5. I haven't seen this thread from the beginning, so this may not be
    on target...

    Anyway, your default printer should be recorded in ~/.lpotions

    Hope this helps,
     
    Ettore Aldrovandi, Jun 25, 2007
    #5
  6. Viktor Haag

    Tom Stiller Guest

    On my system it's stored in ~/.cups/lpoptions.
     
    Tom Stiller, Jun 25, 2007
    #6
  7. Interesting. I wonder why.
     
    Ettore Aldrovandi, Jun 26, 2007
    #7
  8. Viktor Haag

    Viktor Haag Guest

    I have a ~/.lpoptions file, with a printer listed in there. If I
    select a printer and choose Make Default in the printer list, then the
    value in this file is changed accordingly.

    However, in the *printer list* itself no printer is bolded to indicate
    a default, and it appears that applications always present the first
    printer in that list as the "default printer" no matter what
    my .lpoptions says.

    Also, I'm unable in the printing preferences to select any printer as
    the one to choose by default: it always switches to "last selected".
     
    Viktor Haag, Jun 27, 2007
    #8
  9. Very odd.

    Might be a permissions problem?
     
    The Natural Philosopher, Jun 28, 2007
    #9
  10. Viktor Haag

    Viktor Haag Guest

    "Selected Printer in Print Dialog" is listed as "Last Printer Used".
    No matter what printer I attempt to select for this list selector, it
    always bumps back to "Last Printer Used".
     
    Viktor Haag, Jun 28, 2007
    #10
  11. Viktor Haag

    Viktor Haag Guest

    This was also my assumption, but short of knowing where this
    information is actually stored, I can't check the permissions.

    I have had this problem for a /long/ time, and none of my attempts to
    "Fix Permissions" on the startup volume have solved the problem.

    One thing that might be a factor is that all my printers are networked
    lpd or socket printer queues -- there are no printers that are either
    (a) directly attached to the computer, or (b) attached through
    AppleTalk.

    I didn't think this should matter, as it certainly doesn't with the
    underlying CUPS system. I think the problem is almost certainly with
    the OSX GUI build on top of the underlying print system, but I have no
    idea where to look or what to tweak to fix the problem.
     
    Viktor Haag, Jun 28, 2007
    #11
  12. well we have such, and it doesn't behave that way.

    the APPLICATIONS sometimes use 'last printer selected' and store that,
    but not the OS..

     
    The Natural Philosopher, Jun 29, 2007
    #12
  13. Viktor Haag

    Viktor Haag Guest

    Yup -- thought of that; the ownership is Me:MyGroup and they are rw by
    me and that's it. Seems like that's right (considering it's the same
    with nearly all the other preference plists).
     
    Viktor Haag, Jun 29, 2007
    #13
  14. Viktor Haag

    Sara Kirk Guest

    It could be that there's something corrupted in one of the plists - I
    couldn't switch FUS because of a similar prob. Try moving them to the
    desktop so that new ones are created and see if you can make changes
    stick then.
     
    Sara Kirk, Jun 29, 2007
    #14
  15. Viktor Haag

    Viktor Haag Guest

    That's a good suggestion, Sara; I think I already tried that. However,
    just to be sure, I did it again; and it didn't help. 8(
     
    Viktor Haag, Jul 3, 2007
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.