Showing that lookupd -flushcache has done its job

Discussion in 'Apple' started by mark, Aug 19, 2007.

  1. mark

    mark Guest

    I have a small, but annoyingly growing, list of websites that I can't
    access - the connection just times out - on this machine running OS
    10.4.10.

    The standard response from various places on the web is to clear by
    cache using lookupd -flushcache (or variants of it including sudo) -
    but that's not worked. Is there any way to actually view the size of
    the cache to make sure it has cleared.

    If that's not it, where can the problem actually lie, and where is it
    most likely to be? My router? My ISP?

    Thanks,
    Mark
     
    mark, Aug 19, 2007
    #1
    1. Advertisements

  2. mark

    mark Guest

    Of the three that I currently can't get onto, two of them time out on
    a traceroute when they get to the hosts (rackspace.net and
    theplanet.com). I've just checked a third site that I've not been
    able to connect to in the last few days and the traceroute connects
    fine to that, so that may be a different issue.

    Mark
     
    mark, Aug 19, 2007
    #2
    1. Advertisements

  3. mark

    hashmac Guest

    i tried sending a message did it post?


    I tried posting a reply -- it's not showing up -- WTF google?

    here is what I replied to you:



    there are KNOWN unresolved lookupd bugs in OSX that apple refuses to
    acknowledge and has failed to fix.

    currently there are temporary workarounds that eventually stop working
    because it's a BUG.

    However, here are some resources that have 'temporarily' worked for
    many, incl. me and they always stop working and have to be re-
    implemented.

    do a search for lookupd and you will see ALL THE FRIGGIN CRAP
    PROBLEMS of this bug that has existed since the beginning of OS X.

    to see the current lookupd configuration type this in the terminal:
    lookupd -configuration

    To fix it: In the Terminal (/Applications/Utilities/Terminal), do this
    (from the admin account):

    sudo mkdir /etc/lookupd
    sudo sh -c "echo TimeToLive 300 > /etc/lookupd/hosts"
    sudo sh -c "echo ValidateCache NO >> /etc/lookupd/hosts"


    You check to see if settings changed from time to time by:
    lookupd -configuration

    To partially fix the page load problem for safari, do this:
    defaults write com.apple.Safari WebKitInitialTimedLayoutDelay -float
    0.25

    to see if settings of .25 are staying: enter this in terminal
    defaults read com.apple.Safari | grep WebKitInitialTimedLayoutDelay


    links/resources proof that is it a long-time bug and ongoing problem
    for both users & even in os x servers:
    http://www.dreamlight.com/insights/bugs/Apple/lookupd.html (also
    has numerous links at the bottom of that page)
    http://www.google.com/search?num=100&hl=en&client=safari&rls=en&q=lookupd+bug&btnG=Search
    http://www.hmug.org/man/8/lookupd.php
    http://www.inertramblings.com/2004/05/11/mac-os-x-clearing-dns-cache
    http://www.macgeekery.com/gspot/2006-09/flushing_the_dns_cache
    http://www.afp548.com/search.php?query=lookupd&type=all&mode=search
    http://forums.worldofwarcraft.com/t...9AAE5EFBE55427618F734?topicId=106666602&sid=1
    http://forums.worldofwarcraft.com/t...B0B?topicId=108215128&postId=1080866034&sid=1
    http://www.afp548.com/forum/viewtopic.php?showtopic=5668
    http://www.macfixit.com/article.php?story=20061016103520346
    http://www.omnigroup.com/mailman/archive/macosx-admin/2004-December.txt
    http://www.openldap.org/lists/openldap-software/200605/msg00075.html
    http://groups.google.com/group/Google-Firefox-Extensions/browse_thread/thread/25f81ed28d8eb6d2
    http://forums.techguy.org/69-apple-macintosh/
    http://www.google.com/search?num=10...=change+safari+page+load+settings&btnG=Search
    http://www.google.com/search?num=100&hl=en&client=safari&rls=en&q=os+x+drops+connection&btnG=Search
    http://www.google.com/search?num=100&hl=en&client=safari&rls=en&q=os+x+failed+connection&btnG=Search

    still apple has failed to resolve fix explain or give a flying crap.
     
    hashmac, Aug 23, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.