Shuttle ST61 Dead?

Discussion in 'Shuttle' started by lieb2101, Oct 11, 2009.

  1. lieb2101


    Oct 11, 2009
    Likes Received:
    I've got an older Shuttle XPC ST61G4 system that just up and died on me. Actually, I believe the motherboard is an FT61. I'm guessing the board is shot but I figured I'd try here to see if anyone has any ideas...

    On power up, I get fans, lights, and power but no video, CMOS boot, HDD boot, or anything. I've tried removing everything, memory, HDD, but no difference. I replaced the CMOS battery and also reset the jumper. No difference.

    Anyone have any other ideas? All the caps look fine...
    Last edited: Oct 11, 2009
    lieb2101, Oct 11, 2009
  2. lieb2101


    Oct 27, 2009
    Likes Received:
    Sorry, but I don't know the answer to your problem, but the reason I've found your post, and this forum, is because I have exactly the same problems you describe with my son's ST61G4 system.

    I have tried a different processor, different memory, removing the graphics card, and the wireless g card, disconnecting everything, resetting the CMOS, removing the battery (didn't have a spare - but looks like you've covered that base!)

    Damned annoying, and I've already replaced the system, but would love to get this little box up and running again.

    So hopefully someone will suggest something - again, all the CAPs appear fine.

    Let's wish ourselves luck! ;)
    Mudmover, Oct 27, 2009
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.