SLOW copying From Mac to PC, Fast from PC to Mac?

Discussion in 'Apple' started by Noozer, Jan 13, 2005.

  1. Noozer

    Noozer Guest

    Mac is an older slot load G3 running Mac OS 10.3. PC is running Windows 2003
    Server as part of a Workgroup (no domain controller).

    I have files shared on the PC. When I copy them from the PC to the Mac it
    takes 3 minutes or so. When I copy the same files from the Mac to the PC it
    takes over an hour.

    Can anyone explain why this could be happening?

    Thanks!
     
    Noozer, Jan 13, 2005
    #1
    1. Advertisements

  2. Check the speed and duplex settings on both NICs. I've seen ridiculously
    slow transfers in one direction when one side is set explicitly and the
    other is auto.

    G
     
    Gregory Weston, Jan 14, 2005
    #2
    1. Advertisements

  3. Noozer

    Noozer Guest

    ....and just for clarification. It's closer to 4 hours to copy 650 megabytes
    (about two dozen files). My post was at 3:41pm and it's STILL copying to the
    server. Currently at 600meg of 650.

    *sigh*
     
    Noozer, Jan 14, 2005
    #3
  4. Noozer

    Noozer Guest

    There is a switch between the machines (A Netgear router, actually).
    Something I will check though... Not sure how to go about checking it on the
    iMac though.

    Thanks!
     
    Noozer, Jan 14, 2005
    #4
  5. I've seen it through both hubs and switches within the last month. I
    haven't used a direct connection in a few years; for all I know it may
    not manifest in that configuration. The weird part is that it happens
    even when the autoconfig chooses the same settings that are explicitly
    set on the other side.

    System Preferences. Network panel. Show: (the NIC you care about).
    Ethernet tab.
     
    Gregory Weston, Jan 14, 2005
    #5
  6. Noozer

    Noozer Guest

    SMB. I do have Apple File Services installed on the Windows box, but I'm not
    familiar with Apple networks so I haven't set any of it up.

    I did figure out the problem. It was the switch in the Netgear router. Once
    that was out of the equation I hit about 7MByte/second from Mac to PC. Much
    better than the 40KByte/sec I was seeing previously.

    Gave me a chance to get my 802.11a WAP into the network anyhow.

    Thanks all!
     
    Noozer, Jan 14, 2005
    #6
  7. Noozer

    Bob Harris Guest

    If you have not tried this, see about changing the Ethernet MTU setting
    from 1500 to 1492.

    System Preferences -> Network -> Built-in Ethernet -> Ethernet Tab ->
    Configure: Manually (Advanced) -> Maximum Packet MTU Size: -> Custom:
    1492

    It is worth a try anyway.

    Bob Harris
     
    Bob Harris, Jan 14, 2005
    #7
  8. Noozer

    Noozer Guest

    Definately will do... Thanks!
     
    Noozer, Jan 15, 2005
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.