1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Solaris 10 install on Sunfire 280R-Can't open boot device

Discussion in 'Sun Hardware' started by chilecayenne, Aug 16, 2008.

  1. chilecayenne

    chilecayenne Guest

    Hello all,

    I hope this is the correct forum to post this...!!

    I've played on Solaris as a DBA, and I've got Linux boxes at home, but
    this is my first try at a real Sun box using Solaris, to try to learn
    some admin skills.

    First, I bought a Sunfire 280R off ebay. It had no drives, I bought 2
    clean drives and installed.

    I have purchased the official Solaris 10 dvd set from Sun (I have also
    tried downloading and burning both dvd and cds too on this install)

    I have seen posts around that the Toshiba dvd drive at firmware
    version 1007 has trouble booting from dvd, but, it appears my dvd
    already is at firmware revision 1009...and should work?

    Anyway, here's my problem:

    I try to boot from either power off...or from openboot:

    boot cdrom

    Boot device: /[email protected],700000/[email protected]/[email protected],0:f File and args:

    Can't open boot device.

    Ok, from openboot, I do a probe-scsi-all:

    /[email protected],600000/SUNW,[email protected]
    Lid HA LUN ---Port WWN --- ---- Disk description -----
    0 0 0 2100002037c90093 SEAGATE ST336704SUN36G 042D
    1 1 0 21000004cf62f2f2 SEAGATE ST336605FSUN36G

    /[email protected],700000/[email protected],1

    /[email protected],700000/[email protected]
    Target 6
    Unit 0 Removable Read Only device TOSHIBA DVD-ROM SD-M14011009

    {0} ok

    I've gone through and did a setenv-defaults, to try to clear out any
    weirdness that might have been on there from former owners.

    I was trying to look into a network install, but, from what I
    understand, you have to use another Sun box to do that, and this is
    the only one I have right now. I have some linux boxes on the network,
    is there a way I could set it up to do a network install on this box?

    I don't know all the commands to show everything, but, if you have
    some that would display more information, I'll do that and post it

    It seems to me that it can 'see' the DVD drive...the lights blink on
    it when it is probed and when it tries to boot from it. I have setenv
    boot-device to cdrom. But for some reason, it doesn't seem to want
    to boot from any media in it...cd or dvd.

    I'm really stuck, and would like to get this box up and running. Any
    and all suggestions greatly appreciated!!

    chilecayenne, Aug 16, 2008
    1. Advertisements

  2. chilecayenne

    DoN. Nichols Guest

    Which of them? I see two here, and I've followed up to both,
    over the complaints of my newsreader. :) Comp.sys.sun.hardware is a good
    choice for this.

    [ ... ]
    O.K. You picked a noisy system, and it has an additional
    complication in there called a RSC (Remote System Control) card, which
    proably has a password set in it. The system (with the exception of the
    RSC card, and the lack of the UPA bus framebufer options) is very
    similar to the Sun Blade 1000 and 2000. The RSC is there because
    people don't like sitting next to a computer with fans that loud (these
    don't go quiet even when the OS is booted, unlike an SB-1000 with the
    same system board and CPU modules.

    Also -- while the SB-1000 and SB-2000 will accept 1.6" high FC
    drives, the SF-280R will not -- thanks to needing access from the front
    to hot-swap drives.
    O.K. Occasionally they offer the DVD set along with the
    development system for free -- they happily ship them to you -- three
    DVDs -- SPARC version, X86 version, and the development set.
    It should, indeed. You may need to clean accumulated dust from
    the laser LED lens however, depending on where and how long it has been
    O.K. Two 36 GB Fibre channel drives, which should work for
    this. I've even installed Solaris 10 on one of these on a bunch of 9GB
    SCA drives in a MultiPack before I got my first Fibre Channel drives.
    Noting on the external SCSI bus -- yet.
    O.K. There is your DVD-ROM drive (which yes is called "cdrom" in
    the boot commands., and it does appear to have the firmware patch in it
    to take it up to 1401 1009.
    Good -- but the RSC may be taking over from your commands. Try
    pulling it while you get the OS first installed. It is a long card with
    three connectors on the backstrap -- an ethernet card, a serial port,
    and a modem port -- all using various sizes of RJ connectors, two
    RJ-45s, and (IIRC) a RJ-11 for the modem (which is a PCMCIA modem
    plugged into a PCMCIA socket on the RSC card.

    Anyway -- to remove it, first be *sure* to unplug both power
    cords. It gets power even when the computer is turned off.

    Then remove it, and put a blanking panel in the bracket strap
    slot. Set it aside on an insulating surface -- or ideally an antistatic
    pink foam rubber. You may want to use it later, to control the computer
    from another, which *can* be a Windows system, after you have the OS
    installed and can reset the password on the RSC card.
    Proably -- but you'll get a quicker install from the DVD in the
    system, I think.
    Your probe-scsi-all is a start.
    You *don't* want the "boot-device" set to "cdrom". This may
    make it try to install onto the CD-ROM from which it is reading, which
    it can't do, of course.. :)

    Leave "boot-device" set to "disk". It will proably wind up
    adding the WWN (World Wide Number) from the disk (2100002037c90093 from
    your first disk -- bottom most in the cage) when you finish the install.
    When it boots from DVD, it needs to have a disk into which it
    can write the boot image -- usually into the swap space. It may be that
    your disks were from an EMC RAID array, which uses a non-standard
    blocksize, and it is a trick getting booted system to fix this to allow
    you to use it. I'm not sure *how* you would do this from a DVD-ROM,
    especially when you can't boot it. Hmm ... do you have some Ultra-SCSI
    drives (68 pin or SCA 80 pin in a box which will use the 68-pin bus? If
    so, hang those (one or more) on the SCSI bus out the back, and you can
    install a minimal system on this first.
    I've suggested some things in the above. The main ones are
    clean the DVD-ROM's laser LED and lens, and try installing on external
    SCSI disks if the internal ones won't work yet. If you find that you
    still can't get to the internal ones, post again here and I'll repeat
    what I learned with a purchase of twenty 73GB FC drives from an EMC RAID
    array for use in external arrays connected to my SF-280R (which is why I
    know the machine).

    But another possible option is to pick up another SCSI DVD drive
    and put it in an external housing and boot from it. I've done that,
    too, playing with SB-1000s (which again are mostly the same). Because
    it *is* possible that the DVD-ROM drive is bad. Hmm ... have you
    checked that both ends of the internal SCSI cable are firmly seated?
    That can sometimes be the problem. If the LED is flashing, then the
    power is connected, and at least some of the SCSI cable. I was helping a
    friend (at long distance) with a SB-2000 and a problem with the internal
    SCSI DVD-ROM not working -- but it worked when moved to an external bus
    and booted from that. You can use a "devalias" command from the OBP
    (the "ok" prompt) like this:

    devalias cdrom1 /[email protected],700000/[email protected],1/[email protected],0:f

    except that your bus would be a different one, probably:

    devalias cdrom1 /[email protected],700000/[email protected],1/[email protected],0:f

    Note that this will go away every time you reset, so if you want it to
    stick around, set the following in the EEPROM settings:


    nvramrc=devalias cdrom1 /[email protected],700000/[email protected],1/[email protected],0:f



    so it will be reset every time the system reboots.

    If you plug the DVD drive into the external SCSI cable but keep the SCSI
    ID set to 6. Then try "boot cdrom1" and see what happens. If that
    works, and it does not in the system, you have a problem similar to what
    my friend had, apparently one of the pins of the internal SCSI
    controller was zapped -- and the only fix for that is swapping out the
    system board (most would call it the motherboard). Or -- you can simply
    live without the internal SCSI bus at all, if you don't need to hang a
    lot of other things on the external SCSI bus.

    Good Luck,
    DoN. Nichols, Aug 16, 2008
    1. Advertisements

  3. chilecayenne

    chilecayenne Guest

    Hi Don,

    THANK you for the great reply!! I'm trying what you said....I did a
    setenv boot-device to disk.

    I removed the RSC card (after unplugging the box first).

    When I am at the 'ok' prompt....and try boot cdrom, I get the same
    errors as listed above.

    But, for experimenting further...I tried an experiment.
    When I try boot cdrom, I get it saying can't open boot device at:
    /[email protected],700000/[email protected]/[email protected]/[email protected],0:f

    Just for fun, I tried boot install, and got:
    /boot device: /[email protected],600000/SUNW,[email protected]/[email protected],0/[email protected],0 File and args:
    Bad magic numver in disk label
    Can't open disk label package

    Can't open boot device.

    Ok, I'm guessing that boot install is trying to hit the 'blank'
    internal harddrive(s), and failing here.

    Now, just to do a little experimenting...I did a cd to

    cd /[email protected],700000/[email protected]/
    {0} ok
    f00a9e9c tape
    f00a930c disk

    I did a cd to disk

    {0} ok cd disk
    {0} ok

    I then did a pwd and go this???

    /[email protected],600000/SUNW,[email protected]/[email protected],0/disk

    Now...how did I get there?? I was cd'ing to the directory where my
    cdrom is supposed to be, however, when I get to the disk
    directory....it is seemingly linked not to the cdrom, but, to the
    internal harddrives???

    Is this what I'm seeing? If so...somehow it appears that when it tries
    reading from the disk, that it is in fact reading from the unformatted
    internal drives?

    If this is not the case...please let me know what is happening
    here...or, if this is a goof in linking, is there a way I can fix and
    remap this so that cdrom is what is looked at when I try 'boot cdrom'.

    I'm going to try also to get some compressed air in a can and blow out
    the dvd drive. I'll also once again, try to unseat and reseat the scsi
    cable to the dvd drive....just to make double sure on that. I do not
    have any external scsi cables or other scsi dvd drives. I do have a
    USB dvd drive...

    I do also have a StoreEdge T3, loaded with drives, and the card and
    optical cable to try to hook to the 280R...but, it is not hooked
    up...I figured I'd try to install the OS on the internal
    drives....mirror those to each other, and then do all my work on the
    T3 array after everything else was working and installed.....should I
    maybe try to hook that up and install the OS to it??

    Again, thank you for the time and thoughtful reply to my post, very
    instructive so far.....and they say USENET is "dead as a medium for
    serious information and work".

    chilecayenne, Aug 16, 2008
  4. chilecayenne

    DoN. Nichols Guest

    I'm setting the "Followup-To: " to only comp.sys.sun.hardware (which is
    where I am reading it), and doing one final followup to both just in
    case you are following this in the comp.sys.sun.admin instead.

    [ ... ]

    [ ... ]
    I'll leave this above quoted for future reference.

    Also -- remove both power cords when you re-install the RSC card
    as well. (I probably don't need to say that, but just in case. :)

    [ ... ]

    [ ... ]

    [ ... ]
    Perhaps even type "set-defaults" at the "ok" prompt. That will
    assure that you are starting with reasonable settings.

    Are there any other PCI cards in the system? (Probably a
    framebuffer at least).
    Good -- that keeps it from changing the eeprom settings behind
    your back. :)
    O.K. That matches where the DVD-ROM was found based on your
    That tried to boot from the default disk and tried to boot a
    file named install instead of the default kernel.
    Reasonable results, since you don't have a file called 'install"
    on the disk, let alone one which is bootable. :)
    Yes -- and looking for a file named "install".
    Well ... don't depend on it looking like a true filesystem tree.
    Yes -- trying to at least.
    I've never played around with "cd" and "pwd" at the "ok" prompt,
    and I can't do it now without shutting down the system on which I am
    composing this message.
    O.K. I hope that works.
    I don't think that it will boot from the USB port -- and that is
    USB 1.1 not 2.0, so it would take forever anyway.

    Your USB DVD drive is almost certainly really an IDE drive in a
    box with the USB converter logic. It is possible to boot from the raw
    DVD drive inside it with an Acard brand "bridge card", but that will be
    fairly expensive. I would try moving the DVD drive outside of the box
    and connecting it to the external SCSI just to be sure. You can pick up
    the Toshiba drives fairly affordably from eBay -- or at least I have in
    the past.

    A quick search turned up an auction for two drives currently at
    $18.95. (auction #360078757112)

    They were pulled from Sun machines according to the description.
    Depending on how old they are, you may need to patch the firmware.

    An example of a UniPack can be seen in auction #150112189504
    It has a tape drive which you would probably toss and it seems too
    expensive to me, but you can see photos of what both ends look like, in
    case you stumble across one at a hamfest or other flea market.

    Note that there are two styles of UniPacks -- the closed front
    ones which will only accept disk drives -- and mostly the SCA 80-pin
    SCSI drives, and the open front ones like this which will accept a tape
    drive or a DVD drive (or other things depending on your needs -- 5-1/4"
    or smaller).

    One of the particular advantages of the UniPacks, the MultiPacks
    (which can hold up to six 1.6" SCA disk drives, or up to twelve 1" SCA
    disk drives depending on the model), and the FlexiPacks, (which are
    relatively rare, and can hold two devices) is that they all
    automatically terminate the SCSI bus at the last one connected, or if
    you have the second connector on the *Pack connected with a cable which
    is 68 pins on one end and 50 pins on the other end, it will terminate
    the upper half of the SCSI bus, and you will still have to terminate the
    lower half at whatever is at the end of the cable.

    The open-front Unipacks and FlexiPacks may have internal 50-pin
    (most common) or 68-pin (rare) connectors. You would want the 50-pin
    style for the DVD drive.

    Given the lack of suitably priced UniPacks on eBay at the
    moment, you need something else. Looking at auction #280253848521,
    there is a Sun 411 housing with an old (cartridge style) CD-ROM drive
    which could be pulled and tossed -- or saved for something. Still at
    the opening price of $4.99, and only about two hours to go. Interesting
    pair of latches on the sides of the case. If you get one of these,
    check with me and I'll tell you how to open them to swap drives.
    Anyway, with this, you would need a 68-pin to 50-pin cable, and a 50-pin
    high density terminator. But it should work well with your DVD drive if
    it has to be run on an external bus. (Or just for tests.) I've got one
    of these drives in just such a box at the moment. They are useful for
    testing and for installing on systems which don't come with a CD-ROM or
    DVD-ROM drive --or ones like here where there may be a problem with the
    drive or the internal SCSI controller. There is nothing else sharing
    that controller, unless someone has installed a tape drive in the front
    of the box too.
    Reasonable to minimize the number of things involved before you
    get the computer end working properly.

    Hmm ... "optical" cable? The FC-AL on the back of the Sun Fire
    280R is a *copper* FC-AL interface. If you are using true optical
    cables, you'll need an extra card in the SF-280R to accept it. I see
    the FEH (which is just barely new enough to cover the T3) mentions both
    "DB-9 interconnect cables" and "Fibre Optical Cable" so it could be
    Those who are saying that it is dead are those who see it as
    something that they can't make money off of, so they *want* it to die.
    I've found both this newsgroup and one other which I regularly visit
    which are worthwhile -- though the other does have a bit too much
    political arguments, so I have a very active killfile there. :)

    So -- let me know whether cleaning the drive made the
    difference. And you will want to boot from the DVD labeled "SPARC", not
    the one labeled "x86". And you certainly can't boot from the one
    labeled "Software Companion" (if you have it).

    If you want thorough diagnostics, unplug the keyboard (if you
    have one), plug in a terminal to the TTYA serial port, then:

    setenv diag-level min
    setenv diag-switch? false

    (yes, that question mark is part of the variable name -- it means that
    its value should be either "true" or "false".

    Then reset and expect it to take about an hour or two to complete.

    BTW -- if you ever pull the CPU modules, be sure to read the
    instructions in the envelope above it, and to use the dayglow green
    torque screwdriver for the installation.

    Good Luck,

    BTW Where are you located? Soemtimes someone in the same area can
    offer things to help with the test.
    DoN. Nichols, Aug 17, 2008
  5. chilecayenne


    Feb 22, 2014
    Likes Received:
    If you can't boot from dvd, maybe it needs boot -r


    ok boot -r

    stuff about scsi should appear

    ok boot cdrom
    hanabal, Feb 22, 2014
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.