1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Solaris 8 long-haul FTP performance problem

Discussion in 'Sun Hardware' started by Bill Wyatt, Dec 31, 2003.

  1. Bill Wyatt

    Bill Wyatt Guest

    Note: I have asked this question on the wu-ftpd list with several
    responses to no useful result. I am now suspecting some sort of Solaris 8
    problem.

    I have been using wu-ftp to routinely transfer files (mostly data) for
    some years now from our remote mountain telescope computers (linked via
    the University of Arizona) to Cambridge, Mass. This link, via Internet 2,
    has about a 68 millsec latency and 14 hops.

    Starting some months ago now, there has been a degradation of throughput,
    to the point where I get only about 280 kilobytes/sec, instead of the 4 to
    8 MB/sec the link bandwidth would predict (given the slowest link is 100
    Mbit/sec).

    The slowdown seems to have been coincident with an upgrade to Solaris 8 on
    the originating machines (one Ultra 60, two Ultra 2's). We have used
    Solaris 8's route command to make the send and receive windows 1 MB when
    sending/receiving to/from the remote networks. Perusing the netstat output
    during a transfer shows that larger window size is in use.

    Prior to the upgrade, the Ultra 60 was at Solaris 2.6, and the Ultra 2's
    were at Solaris 2.5.1. I know that 2.5.1 didn't support TCP large window
    size, which we needed to cover the ~68 ms latency. The 2.6 machine was
    adjusted to use a large window, and that worked, giving the high
    throughput. The 2.5.1 machines still gave about 800-900 kB/sec, almost 3x
    better than at present.

    The ftp client used is Sun's Solaris 8, and the servers are all WU-ftpd
    2.6.2. Grasping at straws, I tried ncftp with no change in throughput.

    I know the bandwidth is there, as I have a simple socket-to-socket copying
    program that gives throughput in the 4-8 MB/sec range, as expected. It's
    too clumsy to use as a substitute for ftp, however (but I'm getting
    desperate!).

    I have set the various /dev/tcp parameters to sensible values (and tried
    not sensible ones) to no avail:

    tcp_max_buf 1048576
    tcp_cwnd_max 1048676
    tcp_xmit_hiwat 1048576
    tcp_xmit_lowat 1040000
    tcp_recv_hiwat 1048576
    tcp_tstamp_if_wscale 1
    tcp_deferred_acks_max 16
    tcp_naglim_def 1

    We've had lots of network people at the UofArizona end and at our end
    puzzling over this with no change. It doesn't seem to be a firewall issue,
    or my socket copies wouldn't have worked (plus the network people say the
    ports used are open between the two sites).

    Running ftp with the -d flag shows nothing untoward. I don't know of any
    diagnostics to try in the server, though.

    The I2 people say there's no throttle on Internet2 for ftp packets.

    I'm led to conclude there's a bug in 2.6.2 wu-ftpd under Solaris 8, or the
    TCP/IP module.

    So, does anyone have ideas or insights or fixes?
     
    Bill Wyatt, Dec 31, 2003
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.