Something accesses the hard disk every two sec (longish)

Discussion in 'Compaq' started by Leachim Sredna, May 27, 2004.

  1. Hi,
    I was given an old Compaq Deskpro with a 350Mhz PII and 6 G Maxtor hard
    drive, from which I removed the vestiges of NT4 and installed Win98.
    It worked well enough with 196 M of PC100 RAM
    But something regularly accesses the hard disk every two seconds or so,
    like a clock or heart beat. And I just dont know what it is. The previous
    user says it always did this, so I don't think it s anything acting thru
    the Windows OS which is causing it.
    I did not think this regular accessing of the disk mattered -- it simply
    meant a little clicking noise and a blink of the led. Or so I thought.
    Until after setting the puter up for a friend. I got into a bad series of
    install/uninstalls of dodgy bloatware. After which I wanted to clean things
    up a bit with Scandisk and Defragmenter.
    It then transpired that the disk acessing would not allow Scandisk or
    Defrag to get under way and complete.
    What could be accessing the disk? Could it be coming from the BIOS? (One
    of the first things I checked was that the MSWord feature FastFind was
    indeed disabled and closed, so I dont think its that.)
    I would be grateful for any thoughts on this one.
    Michael Anders
     
    Leachim Sredna, May 27, 2004
    #1
    1. Advertisements

  2. Leachim Sredna

    HH Guest

    Dunno about Deskpros, but on some Presarios of that era, Auto Insert
    Notification on the CD-ROM drive(s) could cause the HD LED to flicker once
    per second. Check in Device Manager in Windows and see if AIN is enabled.
    HH
     
    HH, May 27, 2004
    #2
    1. Advertisements

  3. I'm intrigued HH.
    Just what is AIM and how does one control/enable/disable it?
    FWIW, I changed the original CD drive for a burner, but the accessing of the
    HD has continued as before.
    Thanks,
    Leachim

    (snip)
    something regularly accesses the hard disk every two seconds or so,.....
    the disk acessing would not allow Scandisk or
     
    Leachim Sredna, May 28, 2004
    #3
  4. Leachim Sredna

    Frank346 Guest

    Do a Google search for diskact.zip which is an old PC Mag utility that
    identifies all disk activity. This was freeware but now PC Mag charges for
    everything. The search should turn up a free copy.
     
    Frank346, May 28, 2004
    #4
  5. Leachim Sredna

    HH Guest

    With AIN (AIM is an accronym for AOL Instant Messenger) enabled, the PC
    querries the drive once per second to see if a CD has been inserted. If
    memory serves, this enabled the auto-run feature when it first was
    introduced. On machines with it, you could enable/disable via Device Manager
    by checking/unchecking a box.
    It sometimes interferred with scandisk and/or defrag causing these utilities
    to start over, and over, and over, ad nauseum. The issue was mainly with
    Presarios made in late 1997 and early 1998, specifically, the 4800 and 4500
    series machines.
    HH
     
    HH, May 28, 2004
    #5
  6. Leachim Sredna

    HH Guest

    HH, May 28, 2004
    #6
  7. Thanks all the replies. Reckon I'll lick it now,
    Leachim
     
    Leachim Sredna, May 28, 2004
    #7
  8. Leachim Sredna

    Euclid Guest

    I've got that problem on my Compaq Presario S4020WM, Windows XP Home,
    purchased from Walmart last summer. It was the autoplay feature of the
    CD-ROM drive. When I turned that off, the problem stopped. So it appears to
    be an ongoing problem with Presario machines, independent of the op system.
    Here's the registry hack I discovered to fix it:

    to turn autoplay on...
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
    "AutoRun"=dword:00000001

    to turn autoplay off...
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
    "AutoRun"=dword:00000000

    In other words, just change the dword value.
    -E

    Thanks all the replies. Reckon I'll lick it now,
    Leachim
     
    Euclid, May 29, 2004
    #8
  9. Leachim Sredna

    Mark Guest

    "Auto Insert Notification" means that the operating system will
    regularly strobe the CD-ROM drive to see if a CD has been inserted. If
    so, it will "auto-run" whatever startup program it finds (if there is
    one) there. Besides the problem you may be having, I have it disabled
    it myself because I prefer to be in control of what software starts
    running and when it does so!

    Try Start; Settings; Control Panel; System; Device Manager; the "+"
    next to "CDROM"; double-click the CDROM drive listed there; select the
    "Settings" tab; un-check the "Auto insert notification" box if it's
    checked.

    "Fast Find" and "auto insert notification" are the usual culprits.
    Good luck!
     
    Mark, Jun 1, 2004
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.