1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Sound Blaster Platinum Software in Win XP?

Discussion in 'Soundblaster Live' started by John, Jan 14, 2004.

  1. John

    John Guest

    Hi.

    I have Windows XP and I have the Sound Blaster Platinum Card. It
    works okay and is detected by XP, however, the software doesn't seem
    to be very well.

    The Creative Launcher at the top seems very unstable and flickers a
    lot. So much so, that it is not usable. You can't click onto it and
    select anything.

    Is there anyone who had managed to download updated software that
    works? I would really like to have the launcher and software still,
    especially because I like the different sound effects, the mixer, and
    the ability to select the "what you hear" input as well as others all
    from the launcher.

    I only bought this a few years ago, and spent quite a few pounds on
    it, so if there is anyway to get the software working as well that
    would be fantastic.

    Thanks for any help

    John
     
    John, Jan 14, 2004
    #1
    1. Advertisements

  2. John

    Night_Seer Guest

    I have never used the software from the cards themselves for the
    same reason (though newer stuff is getting better). Especially the
    launch bar, which never worked right. The special features are great,
    but there is very little you can't do by pulling up that program
    specifically from the start menu. The launch bar uses up resources, and
    since your not always launching programs, is a waste to me. If you can
    live without that, it should work great, but if you really want the use
    of these things, I can only suggest to upgrade, as I have never been
    able to get the bar to work correctly, even on a fresh install.
     
    Night_Seer, Jan 14, 2004
    #2
    1. Advertisements

  3. John

    Adam Steiner Guest

    Try updating the drivers from Creative's site. I know they have an auto
    updater which will check for you. I was having a problem with my SB Audigy
    2 Platinum and that solved the problem.
     
    Adam Steiner, Jan 15, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.