Sound problem with GA-MA69GM-S2h MB

Discussion in 'Gigabyte' started by Jimbo, Nov 4, 2008.

  1. Jimbo

    Jimbo Guest

    System runs Ubuntu and Windows XP SP3. Sound is fine under Ubuntu but
    does not work at all under Windows. I have tried loading and reloading
    Windows drivers to no avail. At present, Device Manger shows:
    ATI Function Driver for HD Audio - ATI791A
    Audio Codecs
    Audio Device on HD Audio Bus
    etc.

    If I go to Control Panel, Sounds and Audio Devices: Properties, I get
    ATI HD Audio rear output. If I look at the driver details for this I
    see ATIHDMI.sys which suggests to me a HDMI connection rather than the
    stereo speakers I am using.

    Can anyone help with this, please?
     
    Jimbo, Nov 4, 2008
    #1
    1. Advertisements

  2. Jimbo

    Paul Guest

    http://www.anandtech.com/showdoc.aspx?i=2938&p=2

    "As for HDMI, the audio support is enabled through an interface in the
    RS690 Northbridge while the SB600 Southbridge handles the HD audio
    controller interface. The standard HD audio codec will come from
    Realtek who has developed a driver package that allows the user to
    control both the HDMI and HD audio interfaces from a single application.
    Having the HDMI audio hardware on-board means we aren't simply using
    a pass-through on the graphics card as we have seen in most
    implementations. This enables the user to have better control over
    audio adjustments through the integrated software package. We are
    still waiting for the full specifications of the HDMI audio capabilities
    but have tested our 5.1 setup with output set to 24-bits at 48kHz."

    Page 19 in the downloadable user manual, shows the interfaces for selecting one
    of the two chips, in some popular Windows OSes. The Vista control panel
    shows three options, corresponding to the following hardware.

    SB600 --- ALC889 ----- S/PDIF connector (PCI slot bracket?)
    ----- 7.1 analog via jacks (full 2x3 stack)

    690G ---------------- HDMI_Audio

    Since one driver supports all of that, if one of the interfaces seems
    to be working, the files should all have been installed. UAA should be
    part of the driver package, and UAA is needed to make HDAudio work.
    (I don't know the relationship to HDMI, but it could be similar.)
    Some people experience a problem, where a previously installed copy of
    UAA, seems to conflict with what the driver installer needs. There is
    a particular uninstall sequence, to fix it (if you can comprehend what
    the guy is saying).

    http://groups.google.ca/group/microsoft.public.windowsxp.general/msg/77024692fb903eb4?dmode=source

    You'd have to look under more than one entry in the Device Manager,
    to see what drivers are used. And the RealTek package used to install
    the drivers, may also give you some ideas as to what files it would
    have tried to install.

    Paul
     
    Paul, Nov 4, 2008
    #2
    1. Advertisements

  3. Jimbo

    Jimbo Guest

    Thanks.
    Solved the problem and now have sound under Windows XP. Didn't have
    time to check the Ubuntu this morning. Anyway, here's what I did:
    under Device Manager, System, I uninstalled one instance of UAA.
    Could not uninstall the second instance, so rebooted in Safe Mode and
    tried again. Still could not uninstall it but could first disable it
    and then was allowed to uninstall. Next I removed the Realtek audio
    package using Control Panel, Add or Remove Programs. Rebooted as
    requested to make sure everything was clean and then installed the
    latest rev of the Realtek drivers. Still no sound but the Realtek
    Audio icon appeared in the Task Bar Tray and allowed me to configure
    speaker arrangement etc. Shortly afterwards, I heard glorious
    sound :)
    This was a major PITA and the conflicts must have arisen from UAA on
    MB CD and a SP or Windows XP original CD's which are pre SP anything!
    My guess is that Realtek installs UAA and if UAA is already there, a
    conflict arises which doesn't allow Realtek to correctly install.
     
    Jimbo, Nov 5, 2008
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.