1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

SP2 TIP: new problem, keyboard option only

Discussion in 'Tablet PC' started by HarryX, Oct 21, 2004.

  1. HarryX

    HarryX Guest

    I've read many msgs ref. SP2's new input panel. I think I may have an
    undiscussed problem:

    when I open the TIP, the only option I have is the keyboard. When I move my
    cursor over the far left icons, the same balloon msg appears over both the
    "character pad" button and the "writing pad" button. The balloon msg is:

    "The xxx pad is not available for the input language you have selected"

    Background info:
    1. I have a Compaq TC1000
    2. I just downloaded and installed SP2; that's when this problem appeared.
    I never had this problem previously.
    3. I did not have virus protection SW active
    4. I checked "regional and language options" in the Control panel:
    verified lang. is english and keyboard is U.S. I have never changed any
    language setting
    5. I do not have the the "Tablet PC edition 2005 recognizer pack" installed.
    6. SP2 download was conducted after finally fixing a major win registry
    problem that was causing my PC to totally lock up, both in the logon screen
    (if you waited long enough) and after logging on.

    Any suggestions?
     
    HarryX, Oct 21, 2004
    #1
    1. Advertisements

  2. HarryX

    Chris H. Guest

    In your #4, by tapping the Details button on the Languages tab, you should
    have Advanced Text Services which includes Tablet PC Correction, Tablet PC
    Correction for Windows Journal and Tablet PC Text Insertion. (If you have
    Office 2003 installed you will also have a fourth entry.)

    If the above are correct, go to the Command Prompt (not Start/Run) and enter
    "regsvr32 inkobj.dll" without the quotation marks, then Enter and then
    "regsvr32 tpcps.dll" (without quotes) then Enter again. Restart your
    machine after finishing each of those two modifications to the Registry.
     
    Chris H., Oct 21, 2004
    #2
    1. Advertisements

  3. HarryX

    HarryX Guest

    Chris-

    In the advanced tab of text services, I have only 2 options to check:
    compatibility cofiguration ("extends support of advanced text services to all
    programs") & system configuration ("turn off advanced text services"). The
    "turn off advanced text services" box is checked; the other is grayed out.
    For kicks, I reversed the setting but that had no impact.

    Since I did not have all the options you listed, I did not run the regsvr32
    cmd.

    Additionally, I noticed I forgot a fact that may help: in the TIP options
    window, I only have 2 tabs ("general" and "settings"). I noticed in another
    MS article a screen shot of the options window for SP2 TIP & it had 4 tabs (I
    think).

    I appreciate your support! What should I try next? Should I run the cmd
    prompt cmd you originally suggested?

    Harry
     
    HarryX, Oct 21, 2004
    #3
  4. HarryX

    Chris H. Guest

    Did you try to Add the proper services on the Settings tab? It is to the
    right of the Installed service pane.
     
    Chris H., Oct 21, 2004
    #4
  5. HarryX

    shanks Guest

    It is not in the 'Advanced Tab' of the Text services. It should be in the
    'Settings Tab' of Text Services, in the white box under Installed Services.

    Shankar.
     
    shanks, Oct 21, 2004
    #5
  6. HarryX

    HarryX Guest

    Chris-

    Yes, I tried - no joy. Here's the details of what I did/saw:

    I went back to regional & input languages/languages/details/settings
    tab/installed services window. In that window, it listed "English (US)" and
    3 subcategories ("Advanced Text Services"; "Keyboard"; and "Speech
    Recognition". Under Advanced Text Services, there were 3 subcategories:
    "Tablet PC Correction"; "Tablet PC Connection for WIndows Journal"; and
    "Tablet PC Text Insertion". Under Keyboard, it listed "US-Dvorak"; "US
    Dvorak for right hand"; "US - International"; and "US". There were no
    subcategories under Speech Recognition.

    I tried highlighting every categorie and subcategorie in that window.
    Eveyone had the same options listed in the "Add Input Lang." window that pops
    up after you click "add". I can change the input language, and I can check
    the first box only ("Keyboard layout/IME") and change its setting. The other
    3 boxes (handwriting recognition; speech; more text services) are all grayed
    out.

    Thoughts?
    Harry X
     
    HarryX, Oct 22, 2004
    #6
  7. HarryX

    HarryX Guest

    Shankar-

    I sent the same reply below to Chris; I just wanted to ensure you got it
    too. See below... (FYI - thanks for the quantifying details...they got me to
    the right place to try Chris's suggestion). X

    Chris-

    Yes, I tried - no joy. Here's the details of what I did/saw:

    I went back to regional & input languages/languages/details/settings
    tab/installed services window. In that window, it listed "English (US)" and
    3 subcategories ("Advanced Text Services"; "Keyboard"; and "Speech
    Recognition". Under Advanced Text Services, there were 3 subcategories:
    "Tablet PC Correction"; "Tablet PC Connection for WIndows Journal"; and
    "Tablet PC Text Insertion". Under Keyboard, it listed "US-Dvorak"; "US
    Dvorak for right hand"; "US - International"; and "US". There were no
    subcategories under Speech Recognition.

    I tried highlighting every categorie and subcategorie in that window.
    Eveyone had the same options listed in the "Add Input Lang." window that pops
    up after you click "add". I can change the input language, and I can check
    the first box only ("Keyboard layout/IME") and change its setting. The other
    3 boxes (handwriting recognition; speech; more text services) are all grayed
    out.

    Thoughts?
    Harry X
     
    HarryX, Oct 22, 2004
    #7
  8. HarryX

    Andy Guest

    I had this issue too. You said you've tried this, but try it in this
    way. Open regional and language options, languages tabs, click on
    details. Click on the advanced tab and make sure "turn off advanced
    text services" is unchecked. It has no immediate effect, but restart
    your machine and writing pad input should be enabled again.

    Hope that helps,
    Andy.
     
    Andy, Oct 22, 2004
    #8
  9. HarryX

    Chris H. Guest

    You are using Dvorak? You are using "US -International"? Are you using the
    MUIRP on the system?
     
    Chris H., Oct 22, 2004
    #9
  10. HarryX

    HarryX Guest

    Chris-

    I am not familiar with MUIRP so I cannot answer your question.

    But let's look at it from this perspective: I speak/write English; I'm from
    the US. I have no special needs; I do not use the pc for anything unusual.
    I don't exactly know how those settings got there but if my settings are
    incorrect (ie - Dvorak, International) for me, then I'll change them to your
    recommendations immediately. What should they be?

    Having said that, I have changed them to some of the different settings
    subordinate to English and it's had no effect on fixing my problem (but I'm
    still interested in learning what the correct, regular English guy should
    have these settings at). What do you suggest next?

    Thank you-
    Harry
     
    HarryX, Oct 22, 2004
    #10
  11. HarryX

    Chris H. Guest

    Harry, if you are writing/speaking and using English (US) in the operating
    system and Tablet PC Edition 2005, that's what the settings should be all
    over the place. I don't know where, or if you intentionally selected the
    Dvorak keyboard or the US-International setting, but if you have no specific
    need for these settings, we can try to get it correct so everything matches.

    First, go into Control Panel/Regional and Language Options. On the Regional
    Options tab, make sure English (United States) is your selection showing.
    If it isn't, there is a little down arrow to the right of the listing which
    you can tap and then make the selection.

    Second, on the same Regional Options tab, make sure the Location setting is
    for United States.

    Third, go to the Languages tab, then tap the Details button and on the
    Settings tab of the new section which pops up, make sure English (United
    States - US) is the selection in the Default input language at the top.

    Fourth, in the Installed services section in the bottom half of the Settings
    tab page, note that you have EN English (United States) listed first, with
    the Advanced Text Services for Tablet PC Correction, Tablet PC Correction
    for Windows Journal and Tablet PC Text Insertion.

    Fifth, in the section under Keyboard (still in the Installed services
    section), the selection should be US. This, I believe, is where you have
    Dvorak listed, so highlight it and select Remove. Then highlight Keyboard,
    use the Add button, and make sure English (United States) is listed in the
    Input language rectangular screen at the top of the Add Input Language
    screen. Remove any other check marks which may be showing.

    Finally, OK or Apply followed by the OK button, you way out of Control Panel
    completely, and restart your computer. Hopefully, this will make everything
    match, and you should have no problems with the Tablet Input Panel.
     
    Chris H., Oct 22, 2004
    #11
  12. HarryX

    HarryX Guest

    Chris-

    I've verified all the settings are as you instructed below & rebooted. The
    original problem with the TIP has not been resolved. What can you suggest
    next?

    Thank you-
    Harry
     
    HarryX, Oct 23, 2004
    #12
  13. HarryX

    Chris H. Guest

    The other thing which may be indicated, because you've verified all the
    settings now match, is a hiccup in the Registry, Harry,

    This can be fixed by going to the Command Prompt (not Start/Run) and
    entering "regsvr32 inkobj.dll" without the quotation marks, then Enter and
    then "regsvr32 tpcps.dll" (without quotes) then Enter again.

    Restart your machine after finishing each of those two modifications to the
    Registry.
     
    Chris H., Oct 23, 2004
    #13
  14. HarryX

    HarryX Guest

    Chris-

    I followed your instructions below. Each time, I rcvd the same error msg:
    "loadlibrary ("inkobj.dll") failed - the specified module could not be found"
    and "loadlibrary ("tpcps.dll") failed - the specified module could not be
    found"

    Rebooted in between attempts just to be sure. No impact. What's next?

    Harry
     
    HarryX, Oct 24, 2004
    #14
  15. HarryX

    Chris H. Guest

    First, to double-check, Harry, you are at the Command Prompt, correct, not
    Start/Run? If you're at the Command Prompt (you can get there by doing
    "cmd" without the quotes from Start/Run), then would you open Windows
    Explorer and go to C:\Program Files\Common Files\Microsoft Shared\Ink and
    physically check those two files exist on your system?

    The files should be inkobj.dll (version 1.7.2600.2180, 1,312 KB in size) and
    tpcps.dll (version 1.0.2201.0, 47 KB). If they are there, try going to the
    Command Prompt again, make sure you're not running your anti-virus program,
    and navigate to the directory above to run the regsvr32 command on each.
     
    Chris H., Oct 24, 2004
    #15
  16. HarryX

    HarryX Guest

    Chris-

    I was at the cmd prompt; no virus protection installed (I'll do that and
    other things after I get this thing working properly again).

    Went to the exact path as you suggested and I did find those 2 files (that
    kinda worries me too)! Since I did find them as you suggested, I went ahead
    and executed the regsvr32 cmd for both files (rebooting in between) as you
    orig. instructed.

    Unfortunately, the orig problem is still there. What's next?

    FYI - as we've been doing this troubleshooting over the past few days, 2 new
    problems have appeared (keep in mind I have done no additional
    troubleshooting on my own; no reconfigs; no new apps loaded; etc during this
    process. The only thing I have done is what you've told me plus use MS Word,
    Excel, PowerPoint apps for work). The first is an error I now rcve after
    logging on to my profile. I get a program error box. It says verbatim:
    "Program error: CPQMCSRV.exe has generated errors and will be closed by
    Windows. You will need to restart the program. An error log is being
    created." I click OK and the PC appears to operate normally. Having said
    that, perhaps it's related to the second error I now have. The 2nd error is
    also during the logon process - in the middle of loading my profile, it
    changes the screen orientation from landscape to portrait automatically (it's
    never done that before). Since we began troubleshooting, I've always booted
    with the tablet in the landscape configuration so I can use the keyboard.

    Thanks-
    Harry
    PS - I checked out your website. Looks like some good tips, etc!

    Wanted you to be aware of these issues in the event they may be contributors
    to the TIP problem we've been working. If they have no bearing, disregard.
     
    HarryX, Oct 24, 2004
    #16
  17. HarryX

    Chris H. Guest

    Harry, in all honesty, I think you need to systematically run through your
    drivers, and reinstall all the latest Compaq versions even by using Safe
    Mode. The CPQMCSRV.exe file is an OEM file which is Compaq's Change Mode
    Service (rotates screen when the Tablet is docked). If it is corrupt, you
    might also have some other issues, and they may be fixed by Compaq's
    hotfixes. You may want to check the information here:
    http://welcome.hp.com/country/us/en/support.html When you get into the area
    of support for your particular Tablet, you'll see information on the
    hotfixes.
     
    Chris H., Oct 24, 2004
    #17
  18. HarryX

    HarryX Guest

    Chris-

    I fixed the cpqmcsrv by reloading that drvr as you suggested. Thank you.

    This had no impact on my original problem though. Any suggestions ref. the
    TIP problem?

    Harry
     
    HarryX, Oct 25, 2004
    #18
  19. HarryX

    Chris H. Guest

    You've got XP SP2 and the Tablet PC Edition 2005 on CD? If so, do a
    reinstall of the whole thing, right over what you've got. Do not format the
    drive, just install on top of what is there by starting your system in Safe
    Mode (F8) and then launch the installation from within Windows.
     
    Chris H., Oct 25, 2004
    #19
  20. Hello HarryX.
    I have the Recognizer Pack installed and still no Character Pad
    button....and I thought I was the only one.
    Looking forward to an answer that works.
     
    MichelleAYuzik, Nov 14, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.