1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Speed problem in IBM Lappy R50e

Discussion in 'Intel' started by ClueLess, Nov 29, 2011.

  1. ClueLess

    ClueLess Guest

    Hi Guys

    I hope some of you who read this maybe able to help me.

    I have an old IBM Thinkpad R50e (bought in 2005) . It has a processor
    that is rated to work at 1.7 gHz speed. Bus speed is 100 mHz and the
    multiplier is supposed to be 17.

    Unfortunately it is stuck at 6 that gives a low speed of 600 mHz.
    Using Intel Enhance Speed Step Control (part of Crystal CPUID) I
    changed the multiplier to 17 and the lappy froze and I had to remove
    the battery to close it. On re-starting it was surprisingly at 17
    with a speed of 1.7 gHz. Worked for two hours with no problem.

    In a subsequent re-start it went back to 6 again :-(

    It looks as though there is some error in auto setting the multiplier.
    Could it be a BIOS problem. The BIOS on the machine is 2.06 and
    version 2.10 is available at the Lenovo site.

    The question is (1) Will upgrading the BIOS to 2.10 solve the problem?

    That leads to question (2) There is no floppy drive so how do I
    upgrade the BIOS. Is there any way to upgrade using a bootable CD?

    Any help/suggestion will be greatly appreciated.
    ClueLess, Nov 29, 2011
    1. Advertisements

  2. ClueLess

    Paul Guest

    A question for you. Have you checked the clock speed, when
    a heavy computing problem is running ?

    The processor is likely to be using some flavor of EIST
    (Enhanced Intel SpeedStep). It could be, when the laptop
    is idle, it runs at x6. If you run a heavy computing process,
    it should then switch up to x17. It does this, to save power
    when sitting idle. It uses the high multiplier, when there
    is a load.

    Try running SuperPI and computing 1 million digits of PI with it.
    Then, watch the clock rate, to see if it responds to the request.
    It should switch up, for the minute or two the benchmark takes to run.


    The operating system, knows it's a laptop. The operating system
    knows the difference between "running from adapter" or "running
    from battery". Based on the knowledge, it can use different power
    schema. In the Power control panel, you have choices such as
    "Always On", which would normally be a higher power consuming
    schema. It's possible, by switching to "Always On" temporarily,
    the clock rate would stay at x17. The default choice for a power
    schema, on detecting battery operation, could switch back to x6.

    I don't remember the details now, but in the current day,
    multiplier values are programmable, up to the limit established
    by the manufacturer. But earlier versions of processors, while
    they used multipliers, controlled the choices with a single
    logic signal coming from the chipset. If you mixed a desktop
    chipset, with a mobile processor for example, the processor
    would stay "stuck" in the low multiplier. The signals
    used to communicate, were DPSLP and GHI. But the mechanism
    to control them, is still the OS, as it has to use some
    subsystem like ACPI or APM, to make changes to those
    signals. I think later processors, may have dispensed with
    that method, and moved to allowing the programming of the
    multipliers (up to the limit of the "lock"). For example,
    the computer sitting across from me, has x6, x7, x8, x9
    available to it, and tools like the Crystal tool or RMClock
    can be used to select any of those values. But because the
    processor is locked, I can't use values outside of those.

    So before reaching for any BIOS files and bricking the machine,
    do a few more tests.

    Paul, Nov 29, 2011
    1. Advertisements

  3. ClueLess

    ClueLess Guest

    Thanks for a detailed response.

    Actually this is my Daughter's machine which I had borrowed for a few
    days and I found the speed problem when I ran Crystal CPUID.

    I was also showing on the screen Wcpuclock showing the current speed
    of the clock, always showing 599 MHz.

    I was always using the machine on batteries and charging when I was
    not using the machine.

    As suggested by you I ran large programs and still there was no

    This morning when I was using the computer and the battery was very
    low, I was reading some report, I connected the mains and bingo! the
    speed jumped to 1699 mHz :)

    It seems this is a built in feature to conserve the battery.

    Then 600 mHz was too low and how to make it faster? I found Intel
    Enhanced Speed Step Control can generate a shortcut to get the desired
    multiplier so I created a shortcut for 10x giving me 1000 mHz (The
    shortcut was created using CrystalCPUID). When I click on the shortcut
    the speed jumps to 1000 mHz.

    As an afterthought I move the shortcut to the startup folder and now
    the machine starts with 1000 mHz speed and when I connect to the mains
    it jumps to the full speed of 1700 mHz.

    Problem solved. Battery will not last as long as with 600 mHz, then it
    was too low.

    And thanks again for your response.
    ClueLess, Dec 1, 2011
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.