SPOD following use of ftp site mounted via Safari --anyone elseseen this?

Discussion in 'Apple' started by Henry, Sep 28, 2003.

  1. Henry

    Henry Guest

    Folks:

    MacOS 10.2.8 (no problems attributable to the 10.2.8 update observed) G4
    450.


    File "xyzzy.pdf" and its friends are a pain to download one at a time from a
    page on a regular web site. I wonder if I can find and download them from
    the site's associated ftp server?

    Cool! When you type an ftp URL into Safari, instead of getting a browser
    window, you get a ftp "disk" mounted on the desktop, automagically, for
    sites allowing anonymous access. I can mount the "ftp disk". Can I do a
    Finder search on the mounted "ftp disk"? Sure!

    This seems to work, although it also seems very slow (for good reasons, I
    think) and I ended up canceling the search before anything was found.

    Not long afterwards, a couple of minutes, and with no particular warning,
    it's Spinning Pizza of Death (SPOD) time.

    The mouse works and I can change focus from app to app to the Finder, but I
    can't do anything in any app or the Finder. SPOD. Cmd-opt-esc does
    nothing. SPOD. The first time I tried to recover by opening a remote
    terminal session via an ssh login from another machine: silence, and SPOD.
    When I tried the second time, I already had "top" running on the remote
    terminal. At the time SPOD occurred, "top" stopped being updated, and the
    last display showed nothing unusual. SPOD.

    Had to reboot. Yecccccchhh!

    (Strangely, around the time the second SPOD was delivered, the target web
    site also went down --verified with the second machine-- which is probably a
    coincidence ... I sincerely hope. It's a State of California site, which
    _should_ be very stable. But then the governor's office should _also_ be
    stable. Sigh.)

    Although I've had Finder crashes before I've never had one that is so
    repeatable and so ... crashed. I guess the sort-term answer is to avoid
    mounting remote FTP sites, and definitely avoid searching them.

    Anyone else?

    Thanks,

    Henry


    remove 'zzz'
     
    Henry, Sep 28, 2003
    #1
    1. Advertisements

  2. Henry

    Lee Phillips Guest

    This has been written about several times here, by me and
    others; just a few days ago I posted a question asking if
    anyone knew how to break out of the problem without
    rebooting. Your conclusion is correct: do not mount ftp
    volumes, do not mount network volumes, and when you mount
    external (firewire, usb) disks, try to avoid doing anything
    with them through the Finder: use the shell instead. If a
    mounted volume, ftp or otherwise, is slow to respond or does
    anything that confuses the Finder, the GUI will crumble. I
    hope this is fixed in 10.3.
     
    Lee Phillips, Sep 29, 2003
    #2
    1. Advertisements

  3. Henry

    Henry Guest

    Lee Philips:

    Thanks for your reply to my post:

    That's good news...that my impression is confirmed, and bad news, too, for
    the same reason.

    Can you give me some keywords that you and others have used to describe this
    problem?

    Is there any "official" recognition of this problem from Apple?
    Interesting. I've not had problems with accessing other computers, even
    PC's on my LAN, but then I haven't done very much of this.

    Maybe the key phrase is "...slow to respond..." I would expect that a
    remote ftp volume would be many, many times slower than any other type of
    volume I can imagine, except maybe a floppy. This all may be due to some
    poorly chosen timeouts and awkward (faulty) recovery logic.

    Thanks,

    Henry

    remove 'zzz'
     
    Henry, Sep 29, 2003
    #3
  4. Henry

    Lee Phillips Guest

    Can you give me some keywords

    A recent thread has the subject "Restarting GUI".
     
    Lee Phillips, Sep 29, 2003
    #4
  5. Henry

    GDB Guest

    .. . . that's a bit paranoid. I have not had any problems with mounting
    network volumes or other external storage devices on any of the OSX
    machines around here. The FTP problem is genuine though, which is why I
    still recommend Fetch.

    Glenn
     
    GDB, Sep 29, 2003
    #5
  6. Henry

    Henry Guest

    Lee Phillips:

    Thanks for your response on this thread:

    Right. Well, there was a difference between what I saw there and my case, I
    think. I had a terminal session going during the second crash --a remote
    session, which should be as good as a local Terminal session-- and it was
    dead, too, so there was no way to restart anything.

    It looks like the "mounted FTP crash" is qualitatively different than some
    of the others, which (a) may be resolved by waiting ... a long time, and (b)
    seem to leave some key processes untouched.

    Thanks,

    Henry

    remove 'zzz'
     
    Henry, Sep 30, 2003
    #6
  7. Henry

    Henry Guest

    GDB:

    Thanks for your post on this thread:

    Neither have I.
    OK, so there's a "mounted FTP" bug. Other than what's been on this group,
    do you know of any other discussion or information about this bug?

    I simply use the command-line FTP. It reminds me of the good old days.

    Thanks,

    Henry

    remove 'zzz'
     
    Henry, Sep 30, 2003
    #7
  8. Henry

    GDB Guest

    .. . . no sorry. I only came across the FTP SPOD myself the other day.

    Glenn
     
    GDB, Sep 30, 2003
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.