1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

spoolsv.exe reach a high level of CPU usage, cause slow perfo

Discussion in 'Tablet PC' started by lasso, May 17, 2005.

  1. lasso

    lasso Guest

    environment:windows xp table pc with Service Pack 2 in English version,
    Office professinal 2003 in English version.
    sympton: the CPU usage of process of spoolsv.exe was extremely high almost
    at 90% continuously. This cause windows low performance and user can't do
    anything at that time. With further check, I foud that in this folder
    system\spool\printers, there are some temp file exist.The name of these files
    are 000002.SHD, 00002.SPL, 00003.SHD, 00003SPL, etc. First I stop the printer
    spooler service and delete thest temp file. and then restart the spool
    service. It seems I solved the problem. But after some time later, the temp
    file appears again, spoolsv.exe CPU usage also reach a high level. Slow
    performance come back again.
    Question: How to solve this problem, and what's the reason.
    Thank you very much.
     
    lasso, May 17, 2005
    #1
    1. Advertisements

  2. lasso

    Chris H. Guest

    Do you have a printer installed on the system, or perhaps some networked
    printers? Sounds like you've got activity going on for some reason.
     
    Chris H., May 17, 2005
    #2
    1. Advertisements

  3. lasso

    lasso Guest

    yes, there some network printer on these problem computer. Now I have 10
    table pc have this problem, they are same model, used same windows
    isntalltion. I want to solve this problem for user, they are waiting for my
    solution now. but til now I still have no any idea.

    “Chris H.â€ç¼–写:
     
    lasso, May 17, 2005
    #3
  4. lasso

    James Gockel Guest

    Dude, it sounds like you've got a bunch of stuff going on in the printer
    spool.
    Get rid of it all.
    If you have to remove all printer installations and reinstall them.
    That should clear up you problems.
    It sounds like your printers are communicating with all the comptuers that
    there is stuff ready to be spooled out, but its not printing.

    -James G.
     
    James Gockel, May 17, 2005
    #4
  5. lasso

    James Gockel Guest

    Also, since it's not you on the computers its some other users... sounds
    like they need someone watching over them a little closer.
    Seeing what they do with printing... sounds like they are doing somthing
    big, and overloading it all...
    also your printer settings may be set improperly for the environment... turn
    off background printing.
    -James
     
    James Gockel, May 17, 2005
    #5
  6. lasso

    Chris H. Guest

    This was an issue cited in Knowledge Base article 329234 but supposedly
    fixed in XP SP2. If you have contact with a Microsoft representative, or
    have a DirectAccess account, I would talk with the rep or post your
    information to the Windows XP newsgroup in the private newsgroup. You can
    also contact the support section at Microsoft referred to by the KB article
    here: http://support.microsoft.com/default.aspx?scid=fh;[ln];cntactms
    Make sure to tell them you are citing the specific KB article for the
    no-cost assistance.
     
    Chris H., May 17, 2005
    #6
  7. lasso

    Chris H. Guest

    That's not the issue, James.
     
    Chris H., May 17, 2005
    #7
  8. lasso

    lasso Guest

    Thanks Chris and James
    Firstly, I checked every problem PC, they are all run windows xp with SP2,
    and other PC not installed SP2 are no this problem occur. The difference
    between these systems is office, problem system installed office 2003, non
    problem system installed office 2002. They are all have serveral network
    pinters. I remember last time when I met this issue, I solved by deleting
    spool file in these system, but time I did the same action, but after a while
    spool problem came back again. Is any method can find out what's the real
    reason is it.
    thank you for your kindly support.

    “Chris H.â€ç¼–写:
     
    lasso, May 17, 2005
    #8
  9. lasso

    Chris H. Guest

    From research I've done, you may need to remove all the printer drivers
    installed, and then reinstall with the newest drivers for each printer on
    each of the machines.

    This can be done as follows:
    =====
    1. Log into the system as an administrator, click Start >> Run, input
    regedit and click OK to run regedit.exe.

    2. Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print, click
    Registry->Export Registry File on the menu, and export the current key to a
    REG file for backup. (Note: You may double click on the REG file in
    Windows Explorer to restore the original settings)

    3. Go to
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Environment\Window
    s NT x86\Drivers, and then remove both the Version-2 and/or Version-3 keys.


    4. Remove ALL SUB KEYS under
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Printers. (Note:
    DO NOT REMOVE THE PRINTERS KEY.)

    5. Go to
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Environment\Windows
    NT x86\PrintProcessors, delete any processor that is not the following:
    winprint

    6. Go to
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Providers, delete
    any provider that is not one of the following:
    Internet Print Provider
    LanMan Print Services

    7. Refer to
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Monitors], delete
    any monitor that is not one of the following:
    BJ Language Monitor
    Local Port
    PJL Language Monitor
    Standard TCP/IP Port
    USB Monitor
    Windows NT Fax Monitor
    AppleTalk Printing Devices
    LPR Port

    8. Exit the registry editor.

    9. Remove all files from the following directories:
    %windir%\system32\spool\drivers\w32x86\2 and/or
    %windir%\system32\spool\drivers\w32x86\3

    10. Reboot and install the latest printer driver.
    =====

    Make sure you are using the latest printer drivers from the manufacturers
    that you can get.
     
    Chris H., May 17, 2005
    #9
  10. lasso

    lasso Guest

    Thank you Chris.
    I will try with your suggestion.

    “Chris H.â€ç¼–写:
     
    lasso, May 18, 2005
    #10
  11. lasso

    Chris H. Guest

    Good luck with it. I think your best resource, since networking is also
    involved, may be either your Microsoft account representative or the
    DirectAccess private newsgroups - if you have access to those.



     
    Chris H., May 18, 2005
    #11
  12. lasso

    lasso Guest

    Thank you very much.
    could you tell me how can I access private newsgroup directly.

    “Chris H.â€ç¼–写:
     
    lasso, May 19, 2005
    #12
  13. lasso

    Peter Guest

    Hi,

    I have an ix104 with the Stowaway BT keyboard.

    It all works, but while the key *caps* on the BT keyboard are correct
    for the UK, the characters actually generated are as for a U.S.
    keyboard.

    However if I plug in a standard USB keyboard, that maps the keys fine.

    Is there some way I can change the key mapping for the bluetooth
    keyboard specifically?

    Stowaway offer no support, and their web user "support" forums suggest
    there is no solution, which would be pretty amazing since they must
    have spent a fortune moulding the European keytops differently.

    I realise it could be done with a little utility which remaps the
    keys, but that would probably remap the USB keyboard also.

    There is no config in the BT keyboard bluetooth icon for the locale.
    I've tried changing the windows locale to both UK and USA.


    Peter.
     
    Peter, May 19, 2005
    #13
  14. lasso

    Chris H. Guest

    If you or your company are members of the Microsoft Partners program, you
    can access the information for the private newsgroup after signing in here:
    https://partner.microsoft.com/global/30000104



     
    Chris H., May 19, 2005
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.