StartUp items not working after reinstall?

Discussion in 'Apple' started by Evan Platt, Jul 20, 2006.

  1. Evan Platt

    Evan Platt Guest

    Had to reinstall OS/X.... Now, as near as I can tell,
    /Library/StartUpItems isn't working.

    For example, I have a directory ipfw. In it, I have the ipfw binary,
    and a StartUpParamaters.plist. In it:


    Description = "ipfw firewall";
    Provides = ("Firewall");
    Requires = ("Super Server");
    OrderPreference = "None";
    Messages =
    {
    start = "Starting ipfw firewall";
    stop = "Stopping ipfw firewall";
    };
    }

    I have my /etc/ipfw.conf . Is it possibly a permissions issue?

    Right now the system boots into Aqua mode, but I'll probably switch it
    back to console mode (saves memory :) )

    Thanks.

    Evan
     
    Evan Platt, Jul 20, 2006
    #1
    1. Advertisements

  2. Evan Platt

    Király Guest

    Király, Jul 21, 2006
    #2
    1. Advertisements

  3. Evan Platt

    Evan Platt Guest

    Evan Platt, Jul 21, 2006
    #3
  4. Evan Platt

    D P Schreber Guest

    The ipfw binary? You can't really mean that. Is it maybe a shell
    script? Assumimg it is, does it check for any hostconfig values, and
    if so, did you set them in /etc/hostconfig?

    We need to see the script, assuming it is one. If it isn't, what is it
    and where did it come from? Did you make this startup item yourself, or
    download it from some random place?

    Permissions are also worth looking it, but since you didn't post them,
    we have no way to know. Typically the directories are 755 and owned by
    root:wheel, the script is likewise 755 root:wheel, and the plist is 655
    root:wheel. Whether any of this is required, I don't know.

    In general you're better off using a launchd item nowadays anyway.
     
    D P Schreber, Jul 21, 2006
    #4
  5. So what happens if you try telling the system to start/stop ipfw's
    startup item, but from the command line?

    This will run through startup as it should happen at boot time:

    sudo SystemStarter start ipfw

    This will shut it down:

    sudo SystemStarter stop ipfw

    Any messages at the command line when you do this? Anything in Console?
     
    Tom Harrington, Jul 21, 2006
    #5
  6. Evan Platt

    Evan Platt Guest

    nothing on the command line, no errors, ipfw list still shows nothing
    (well, except for the default.

    Based on DP's message, something has to be wrong. I don't recall where
    I found the instructions on a web site (likely macosxhints) telling me
    to copy a ipfw file from another directory to the
    /Library/StartupItems/ipfw. It definitely appears to be a binary
    file...

    I just found a page on macosxhints:

    http://www.macosxhints.com/article.php?story=20031101095946403&query=ipfw.conf+StartupItems
    That is NOT what I had in my ipfw file.

    Still no joy on rbeoot.

    all files in ipfw directory (/Library/StartupItems/ipfw) are chmod
    755.

    If I type sudo SystemStarter start ipfw, nothing.

    If I type /sbin/ipfw -q /etc/ipfw.conf , it works.

    On a side note, pasting text into Pico is INCREDIBLY slow.

    I mean we're talkin like 2400 baud slow - I can hit paste and see line
    by line.

    VI is much better - incredibly fast.

    I know this sounds vague, but that's about the best way to explain it.

    Is there some setting or buffer for pico? It's only on my system. I do
    some maintenance work for a friends hosted site, and when I use pico
    on his (hosted) server, it's fine in pico.

    Thanks.

    Evan
     
    Evan Platt, Jul 21, 2006
    #6
  7. Evan Platt

    D P Schreber Guest

    Must be /sbin/ipfw. It doesn't make sense to me to use that as a
    startup item, though it _would_ make sense to invoke it from a script.
    That's what I do. If you invoke /sbin/ipfw directly with the system
    starter arguments it won't do anything useful afaik.

    I don't see how this could ever have worked for you.

    This is essentially what I described above: invoking /sbin/ipfw from a
    script and passing it meaningful arguments. This particular script is
    too simple -- it doesn't even distinguish between stop and start. But
    it will work a lot a better than what you're doing now :)
     
    D P Schreber, Jul 21, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.