1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Sun cdrom issues

Discussion in 'Sun Hardware' started by Ryan Thoryk, Sep 10, 2003.

  1. Ryan Thoryk

    Ryan Thoryk Guest

    I've got an Sun Ultra 2 that I recently replaced it's old cdrom with a much
    newer Yamaha 8x8x24 cdrw drive (model CRW8824S). It used to have a Toshiba
    XM-5401B that was pulled from an old huge Dell Poweredge server (a monsterous
    dual pentium 100 box). I've been trying to get both of these drives to work
    normally on this Sun machine and an older one (a sparc5/170), but with
    problems. It's getting frustrating especially that the new drive is a cdrw,
    and it's screwing up some cds from this problem. I originally thought the old
    drive was bad, but thought wrong.

    The problem is basically a series of read errors and hardware errors that
    occur when only reading and writing CDR discs (and cdrw discs). Both of my
    Solaris 8 and 9 install cds have to be booted around 2 to 3 times before the
    install starts actually working. Both of my netbsd cds (sparc32 and sparc64)
    have problems too. A typical incident would be
    when I insert a cd, and then the drive would click around a lot, as if the cd's
    bad, even though it's fine. At random times read errors would pop up, and
    sometimes cds that are burning would either fail before or after the data copy
    (during the first init, or the fixation).

    Here's what I've checked:
    cd types affected: only cdr or cdrw media (cds work flawlessly on other machines)
    -both drives checked on both machines, with same results (both drives are
    50-pin scsi)
    -ultra2 has latest prom update
    -multiple scsi cables tested
    -multiple termination settings tested
    -hard drives placed onto the scsi buses, work fine
    -block size jumper on yamaha drive tested at both settings
    -a 512-byte block CD created, still has problems
    -vold not issue
    -cdrecord complains a lot (also latest scg driver installed, for sol9)
    -parity jumpers tested
    -cd size (650 vs 700mb) not an issue

    This is the weirdest thing...
    any suggestions?
     
    Ryan Thoryk, Sep 10, 2003
    #1
    1. Advertisements

  2. Ryan Thoryk

    Paul Gress Guest

    Try cleaning the CD Drive. Computer stores sell at least 3 different
    kinds of products that clean the lasers.

    Paul
     
    Paul Gress, Sep 11, 2003
    #2
    1. Advertisements

  3. Ryan Thoryk

    Ryan Thoryk Guest

    That's already been done. It has nothing to do with the drives (i've
    got 2 drives, both with the same problem). It has to do possibly with
    onboard firmware in the computer itself.
     
    Ryan Thoryk, Sep 11, 2003
    #3
  4. Ryan Thoryk

    Paul Gress Guest

    I have what I believe the same exact cdrw running on my Ultra 2 at work.
    It worked from when I first plugged it in, even without the latest
    OBP/Firmware. What SCSI I/D did you set it to? Have you tried putting
    the CD Drive into an external box and test it on the Ultra and another
    computer, maybe a PC. I seems you haven't determined if it's the CD
    Drive or the Computer yet. I know the two drives behave the same, but
    you should prove if the drives work correctly.

    Paul
     
    Paul Gress, Sep 12, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.