1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

SunFire 280R -- getting in

Discussion in 'Sun Hardware' started by DoN. Nichols, May 30, 2007.

  1. DoN. Nichols

    DoN. Nichols Guest

    I just this weekend picked up a SunFire 280R at a hamfest.

    4GB of RAM

    2 900 MHz Cu CPUs

    370-4362 framebuffer

    501-5406 quad hme nic

    375-3089 Crypto Accelerator

    *and*

    The RSC card. (Is this standard in all 280Rs or only by order?)

    And -- *no* disk drives.

    So -- I am encountering problems:

    1) With a USB keyboard plugged in and a monitor connected to the
    framebuffer, I get nothing -- in normal or in diagnostic
    keyswitch position. Yes, I know that it can take several
    minutes to complete tests and finally display something.

    2) With a serial terminal plugged into ttya (or even ttyb) I get
    nothing. This suggests that the OBP is set up to redirect
    I/O through the RSC card.

    3) With all of the other cards pulled except he RSC card, I get a
    series of diagnostics on the terminal when it is plugged into
    the serial port on the RSC card, culminating in a request to
    login. I tried "root", and was hoping that it had a null
    password. No luck there.

    So -- I apparently need to either clear the password (and other
    setup information in the RSC card, or to (perhaps) get a set of disks
    with an OS installed, so I can redirect the I/O back to the console or
    to ttya.

    So -- since the RSC card has two batteries -- a coin cell and a
    shrink-wrapped set of cells connected to the board with a two-pin
    connector, I find myself wondering whether I can clear all the settings
    in the RSC card by disconnecting both batteries with the card removed
    from the system (yes, I know to deprive the system of power when I do
    this, since it gets keep-alive power anyway).

    So -- if I do this, will I render the card unusable, or simply
    into an "as-new" state so I can access the system through it via the
    serial port to restore the eeprom settings to default. (I so far have
    not been able to find a PDF of documentation of the hardware of the RSC
    card -- just lots of versions of the software to run it in the system.)

    I have a friend with a Blade 2000, so he should be able to build
    a minimal OS for the purpose of accessing the eeprom settings if all
    else fails. After which I will see whether the system can be convinced
    to boot from an external MultiPack full of 9GB drives for an
    experimental install prior to getting a proper FC drive or two for
    inside the system.

    I don't really want to spend money on the FC drives on eBay
    until I am sure that I can make the system work. (And I am curious as
    to how much quieter it will be once the OS tells the fans to slow down a
    bit. :)

    The one configuration which I have not yet tried is the
    framebuffer installed and the crypto card removed to see whether that
    makes a difference in accessing the OBP via ttya or via a USB Sun
    keyboard and the framebuffer. (So far, nothing seems to initialize it,
    as the monitor maintains the amber LED of "no sync".

    Thanks,
    DoN.
     
    DoN. Nichols, May 30, 2007
    #1
    1. Advertisements

  2. Congratulations for the great find...
    Just pull the RSC card: this will force the output to go to ttya or
    graphics (if you connect a keyboard). I recently had the same problem,
    just removing the RSC and wait a while... When your OS is installed
    (Don't forget the SUNWrsc packages) you can reinsert the RSC and
    configure it from the OS.

    HTH,

    Martijn
     
    Martijn Pronk, May 30, 2007
    #2
    1. Advertisements

  3. DoN. Nichols

    SunnySideUp Guest

    SunnySideUp, May 30, 2007
    #3
  4. DoN. Nichols

    DoN. Nichols Guest

    Make that one *working* 900 MHz Cu CPU. :-(

    [ ... ]
    Thanks.

    [ ... ]
    I tried this before, both with the framebuffer/keyboard and with
    a terminal on ttya, and it did not work, and I was not sure whether it
    *should* work that way. Your assurance, and the other followup with the
    pointer to the web page told me that it *should* have, so I reduced the
    system to the two CPUs, and half of the memory (after making them to
    which bank each came from). Still no luck, so I pulled CPU 0 and
    switched CPU-1 into its place. Suddenly things worked, and I finally
    had a feeling for how long it really should take to show something on
    the screen. (I had been waiting as long as a half hour before, since I
    had simply been told that it would take longer than I was accustomed
    to, depending on how much there was to check.)

    So -- I re-installed the pulled original CPU 0 as CPU 1, and
    tried booting again. No luck at all, so I have a CPU which is so bad
    that it locks up the system bus. I find a block of six pins at the end
    away from the 501-6002 label, and I don't see it documented on the pages
    which I can find so far. J0902, which is currently jumpered as follows:

    J0902
    o o o
    o#o o --> to handle/panel.

    I guess that I'll have to pull the other CPU and check how it is
    jumpered -- and perhaps see if making this one like it makes it work. :)
    Thanks,
    DoN.
     
    DoN. Nichols, May 31, 2007
    #4
  5. DoN. Nichols

    DoN. Nichols Guest

    It did not work directly -- but it showed me that the things
    which I was trying *should* work, so I stripped the system down to one
    bank of RAM and one CPU. When I swapped the second CPU in place of the
    first (leaving the second slot empty) it worked, and when I put the
    original first CPU back into the second slot it stopped working, so I
    have a bum CPU. Well ... they aren't too expensive on eBay -- or I
    could perhaps take this opportunity to boost the system to faster CPUs,
    depending on prices, etc.

    Anyway -- the whole system only cost me $250.00 so I can live
    with having to get a new CPU. A pity that it can't accept mixed speeds,
    so I could get *one* faster CPU and leave the other in for airflow
    considerations. I've got to have two matched CPUs, since I don't have
    the dummy CPU to keep the airflow balanced.

    I haven't yet checked whether the system can be configured to
    boot from external SCSI drives (though I suspect that it can), because
    as I was reconnecting all the cords after reinstalling all the cards,
    the table I was using partially collapsed (the load of me leaning over
    the front of the system to reach the back and tighten screws did it), so
    I am bringing up some A1000s to serve as a table instead.

    (other view in my follow up to the other response so far.

    And thanks to anyone else who comes in late with more
    information before seeing my current replies.

    Thanks all,
    DoN.
     
    DoN. Nichols, May 31, 2007
    #5
  6. Hi DoN

    No reason why it can't boot from an external disk. Just do the
    normal probe-scsi-all at the ok prompt, and if you can see the
    external devices all you have to do is reference the right one
    on the boot command. It's probably worth making an alias for the
    external disk - then you can just do a 'boot alias', rather have
    to mess with the long device names.

    Cheers, Liam
     
    Liam Greenwood, May 31, 2007
    #6
  7. DoN. Nichols

    DoN. Nichols Guest

    Yep -- I would already have done this if I were not still
    recovering from the collapsed table in a tight space. That computer is
    *not* a feather to move around. :)
    Good idea -- and one I would probably have done if I did not
    find an alias already present in the OBP.

    Of course, I do plan to get some adequate FC drives for it now
    that I know that it works (aside from that one CPU module.)

    Thanks,
    DoN.
     
    DoN. Nichols, May 31, 2007
    #7
  8. DoN. Nichols

    DoN. Nichols Guest

    It did as expected, and found the external drives.
    And when I installed Solaris 10 U3 from the DVD, it did indeed
    create an alias in the "boot-device" OBP entry, thus making things
    simpler.
    And the rsc is now working nicely too -- other than the extreme
    time that the GUI takes to start on my Ultra-60. :) I do wish that it
    was available for some of the other (much older) systems which I am
    using as servers. At least it reassures me that even with a missing CPU
    module there is still sufficient airflow to keep the temperatures
    reasonable.

    Thanks to all,
    DoN.
     
    DoN. Nichols, Jun 1, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.