1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

SunOS Installation on SPARC1 PROM related?

Discussion in 'Sun Hardware' started by Dennis Grevenstein, Feb 16, 2004.

  1. Hi,

    I'm trying to install SunOS 4.1.4 on a very old SPARCstation 1
    with ROM Rev 1.0. It boots from the CD and I can restore
    the miniroot. However, it does not boot the miniroot correctly.
    After loading the kernel it asks for its IP Address via
    revarp adn sits there. I installed in rarpd on my network
    to give an answer to my SPARC, but the SS1 then looks for
    a bootparam server. That's really not what I would expect.
    I tried set-defaults etc., but still no luck.
    Does anybody here have any idea? I have personally never
    seen such an old OBP before. Could that be a PROM bug?

    mfg
    Dennis
     
    Dennis Grevenstein, Feb 16, 2004
    #1
    1. Advertisements

  2. So where is your rpc.bootparamd and what does it see?

    Casper
     
    Casper H.S. Dik, Feb 16, 2004
    #2
    1. Advertisements

  3. There is none. I'm not trying to boot from the network.
    This happens when I boot into the miniroot doing a cdrom
    installation. I have never seen such a problem before
    and I'm not installing SunOS for the first time. This
    box seems very strange to me.

    mfg
    Dennis
     
    Dennis Grevenstein, Feb 16, 2004
    #3
  4. Definitely wierd.

    Are you sure it is booting from the miniroot ?.
    Maybe it is trying to boot from a previous install on slice 0,
    the miniroot should be on slice 1 where swap normally lives.
    Try specifying the full device path with :b on the end of the
    boot line to force slice 1
    Also check for any strange devalias settings.
     
    Chris Newport, Feb 17, 2004
    #4
  5. The harddisk came directly out of an SGI, so I doubt
    that anything survived after repartitioning. :)
    I did a set-defaults and every PROM settings looks reasonable
    to me.

    mfg
    Dennis
     
    Dennis Grevenstein, Feb 17, 2004
    #5
  6. Hi,

    My problem with installing SunOS 4.1.4 on a SPARCstation 1
    with ROM Rev 1.0 was indeed PROM related. I have upgraded
    the PROM to 2.9 and now the SunOS installation works as
    expected. I've just finished installing from cdrom.

    mfg
    Dennis
     
    Dennis Grevenstein, Feb 25, 2004
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.