SY-KT600 Dragon Plus and SATA boot

Discussion in 'Soyo' started by Threader, Nov 14, 2003.

  1. Threader

    Threader Guest

    Not sure if this is a hrdware or software issue I am trying to load
    Windows XP on a Soyo SY-KT600 Dragon Plus... but I run into trouble if
    I want to use my SATA drive as my boot drive. As soon as WinXP install
    process prompts me for my drivers (VT8237 is SATA controller?)- then I
    receive the following message:

    "File \WINXP\VIASRAID.SYS caused an unexpected error (18) at line 2108
    in D: \XPCLIENT\BASE\BOOT\SETUP\OEMDISK.C"

    I mean- Im confused... this is long before the OS is even loaded or
    anything.

    I am going to try flashing my BIOS tonight, but this is really getting
    to be a pain in the neck trying to boot from a SATA drive...
    sheeeesh!!!

    Thank you, in advance, for your advice and suggestions

    David
     
    Threader, Nov 14, 2003
    #1
    1. Advertisements

  2. Threader

    Threader Guest


    OK, I found out that the drivers MUST be in the precise location as
    specified in the TXTSETUP.OEM file... for example, I copied all the
    driver files onto my A: drive- but they were NOT in A:\WINXP\ , which
    is exactly where the .OEM file said they needed to be :) So I got
    that fixed and it looked like it was going to load WINXP just fine. I
    was even able to format the SATA drive and it copied the needed files.
    But then it came to the point where it says "Starting Windows"... and
    Windows prompted me: "Insert disk labeled VIA Serial ATA Raid
    Controller Driver into drive A". I have to admit, this seemed odd,
    since I left that disk in the A drive. But sure enough, it wants
    something else that obviously is NOT on that drive any longer... and
    Im clueless as to what it is or how to get it :( Arrrrgh!
     
    Threader, Nov 14, 2003
    #2
    1. Advertisements

  3. Threader

    Threader Guest


    OK... figured out (after reading posts in other forums on similar
    issues)that my TXTSETUP.OEM file needed to mirror my directory layout
    of my A: drive...

    in other words, the driver files needed to be located in A:\WINXP, not
    in A:\ as they were

    So I thought I was safe - but fate slapped me back into reality. After
    I got the installation procedure to recognize my controller driver, I
    was able to format my drive and copy system files to it. As it said
    "Starting Windows", however, it prompted me for my "VIA Serial ATA
    Raid Controller Driver" again... and again pointed to "A" drive. This
    seemed odd, as I had never taken that disk out... so I hit <RETURN>-
    only to be asked for said disk again. So now Im really stumped... I
    can't for the life of me figure out how/why it would accept the driver
    the first time, but not the second.

    Any help would be GREATLY appreciated
     
    Threader, Nov 14, 2003
    #3
  4. Threader

    nervest

    Joined:
    Nov 1, 2007
    Messages:
    1
    Likes Received:
    0
    Unexpected error (18) at line 2108

    :eek: Well I got the same results that you guys got on the dragon board.

    (Unexpected error (18) at line 2108)
    I am using a Asus K8V-SE With the VIA K8T8 Chipset.
    I have tried about 15 differnet drivers today and I getthe same message.
    I must beg someone out there to please send me the proper drivers or precedure to get this Toshiba Sata drive Model number HDT725050VLA360.
    Thanks.
     
    nervest, Nov 1, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.