1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

tabletpc.cpl is missing - how to fix

Discussion in 'Tablet PC' started by kasnj, Jul 20, 2005.

  1. kasnj

    kasnj Guest

    Hi! Somewhere along the way, my m205 starting giving me this error when I try
    to get into the 'change tablet and pen settings' tool:

    Windows cannot find '%SystemRoor%\system32\tabletpc.cpl. Make sure you typed
    the name correctly, and then try again. To search for a file, click the Start
    btton, and then click Search.

    I tried that, cut can't find the file on the system. I also tried rolling
    back - but that didn't work. So then I tried reinstalling SP2, but still no
    luck.

    Can any point me in the right direction to fix this?

    TIA!
    Kathleen
     
    kasnj, Jul 20, 2005
    #1
    1. Advertisements

  2. kasnj

    Chris H. Guest

    Kathleen, I suspect you haven't changed the setting in Control Panel/Folder
    Options/View tab to "Show hidden files and folders" for the reason you can't
    find the tabletpc.cpl file in the C:\WINDOWS\system32 folder when searching.
    :cool:

    In Control Panel, if you're viewing in Classic View (separate icons), so
    should see the Tablet and Pen Settings. If you're not seeing that, the
    easiest way to recreate it is to go to
    http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx and
    download the Tweak UI program (free download), and then install it. It will
    appear on the All Programs menu as PowerToys for Windows XP/Tweak UI.

    Once installed, open Tweak UI and select the Control Panel listing in the
    left pane. Make sure the listing for tabletpc.cpl - Tablet PC Control Panel
    is shown, and put a check mark in the box to the left of the listing. Once
    you have done this, go to the Repair listing in the left pane.
    This will reveal a drop-down menu with Rebuild Icons as a selection. Now
    tap the Repair Now button.. The missing icon on Control Panel should now
    reappear.
     
    Chris H., Jul 21, 2005
    #2
    1. Advertisements

  3. kasnj

    kasnj Guest

    Sorry, I should have mentioned, I do have "show hidden..." turned on. The
    closest thing I can find is tabletpc.cat.

    Also, the icon isn't the problem, I do see that. I get the error when I
    click on the icon.

    But I like the way you think...any other ideas? ;-) Thx!
     
    kasnj, Jul 21, 2005
    #3
  4. kasnj

    Chris H. Guest

    Thinking . . . Drat! Are you running Windows XP SP2 and the Tablet PC
    Edition 2005?
     
    Chris H., Jul 21, 2005
    #4
  5. kasnj

    kasnj Guest

    yes and yes...

     
    kasnj, Jul 21, 2005
    #5
  6. Doesn't sound like a view setting though - the error she gets implies she can
    see the icon, and when she tries to launch it she gets the missing file error
    - that the file isn't there to be launched, which would happen regardless of
    view settings if the file existed.

    Kathleen, I also have an M205 running SP2.

    I looked through the CD's to see if the file might be somewhere that you
    could extract it from yourself, but don't see it anywhere - it could be
    buried in a CAB file and hence not extractable the way other files would be.

    You can drop me an email to and remove the spam
    to make the address valid. I can email you the file, should clear up the
    problem.

    John
     
    JDThree [MVP], Jul 21, 2005
    #6
  7. kasnj

    Chris H. Guest

    I have an idea. Would you email me please with a valid address? Just
    right-click one of my messages and then select Properties (I think the
    web-based interface allows that) to see the email address.
     
    Chris H., Jul 21, 2005
    #7
  8. kasnj

    kasnj Guest

    Done!

     
    kasnj, Jul 21, 2005
    #8
  9. kasnj

    Chris H. Guest

    Done, too. :cool:
     
    Chris H., Jul 21, 2005
    #9
  10. kasnj

    kasnj Guest

    It worked, it worked! Thank you gentlemen - I got the file, put it in it's
    proper 'home', rebooted and all was well!
     
    kasnj, Jul 22, 2005
    #10
  11. kasnj

    Chris H. Guest

    Good deal! Glad it all worked out for you. Thanks for posting back with
    the results.
     
    Chris H., Jul 22, 2005
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.