Terminal.app in console mode

Discussion in 'Apple' started by Antonio Maschio, May 28, 2006.

  1. Hi.

    For anyone of you who knows and has used Linux before, it's widely known
    that the console mode can be obtained pressing CTRL+ALT+F1 through F6,
    to gain access to tty1 through tty6 screens; the X-windows high
    resolution screen can be reset with CTRL+ALT+F7 or F9, depending on the
    distribution. The console mode is a fully text-only mode, with black
    background (similar to what you get on Mac OS X pressing Apple+V on
    starting) and white fixed-size characters.

    I wonder:

    a) is there a way to have the same console mode with Mac OS X, with at
    least one tty?

    b) if not, is there a way to run Terminal.app in full text mode? I take
    as model the GLTerminal for 10.4, which can simulate an old VT100
    terminal, with screen curves and old pixelized characters, and it can
    run at full screen mode in no-graphic screen. I could use this as a
    console, but I cannot save the preferences, and so it's rather annoying
    to set them anytime I start the program.

    Thanks anyone answering.

    -- Antonio
     
    Antonio Maschio, May 28, 2006
    #1
    1. Advertisements

  2. Antonio Maschio

    Warren Oates Guest

    I seem to remember that the early Terminal had a "full screen" switch,
    that used to crash. It's not there any more. Now you can "zoom" the
    srceen (Window/Zoom) so that the window fills all the available space on
    your monitor (and you can set a key to do it for you). I know this isn't
    what you're looking for, but I use it this way, and it's not so bad. As
    for no being able to save the GLTerminal prefs, I think that may be a
    permissions thing; you may have to keep an rc file in your home
    directory, or somewhere where you have write permission.
     
    Warren Oates, May 28, 2006
    #2
    1. Advertisements

  3. Antonio Maschio

    Dave Seaman Guest

    At the login window, type ">console" in the username field. This will
    get you into full-screen mode.
     
    Dave Seaman, May 29, 2006
    #3
  4. I tried, but all I get is a notice saying that /dev/console cannot be
    executed (or something). After that, the login crashes (I can digit, but
    the system is deaf), and I must return to the login window, and login as
    a common user. I heard that this is because I have a disabled root, but
    I tried to enable it giving it a password (and Netinfo confirmed that it
    was enabled), but this didn't work the same. So I disabled it again.

    -- Antonio
     
    Antonio Maschio, May 29, 2006
    #4
  5. Antonio Maschio

    Dave Seaman Guest

    My root has never been enabled, and it works fine for me. Are you sure you
    typed into the name field of the login window? Not the password field.
     
    Dave Seaman, May 29, 2006
    #5
  6. I'm sure, I'm not that dumb... ;-)

    Can you tell me the permissions and the owner (name and group) of the
    file /dev/console?

    You can do

    ls -la /dev/console

    from your terminal.

    Thanks
     
    Antonio Maschio, May 29, 2006
    #6
  7. I suppose ethant is the name of the admin superuser!

    -- Antonio
     
    Antonio Maschio, May 29, 2006
    #7
  8. Antonio Maschio

    Dave Seaman Guest

    Why in a terminal? The result is different in full-screen console mode.
    The device is owned by the user (a non-admin user, in the case I tried),
    and the group is "tty". The result in a Terminal window under my own
    login is different.

    Admin privileges are irrelevant, because you do not authenticate as a
    user (any user, admin or otherwise) until *after* you are already in
    full-screen mode. Any valid username and password is acceptable to
    continue in full-screen mode.

    And by the way, I don't think this will work with fast user switching.
    You can get to a login window that way, but I don't think the ">console"
    trick will work if any users are currently logged in.
     
    Dave Seaman, May 29, 2006
    #8
  9. I tried with logged in users and with no one logged in. The result is
    the same. As fast as I can (next night, that is twelve hours from now
    according to Central Europe zone) I will try again and report the exact
    message that the console at full screen reports. In the meantime, thanks
    to everyone of you.

    -- Antonio
     
    Antonio Maschio, May 30, 2006
    #9
  10. Antonio Maschio

    Warren Oates Guest

    I think you have to set the "Login Options" to "Name and Password"
    rather than just "List of Users" or else you won't see an input box.
     
    Warren Oates, May 30, 2006
    #10
  11. Antonio Maschio

    Dave Seaman Guest

     
    Dave Seaman, May 30, 2006
    #11
  12. To sum up the things I did:

    0) checked system: Mac OS X 10.4.6 on eMac Superdrive
    Processor G4 1.42 GHz PowerPC
    1 GB DDR SDRAM

    1) set up the "username & password" (prompting for username *and*
    password), and disabling the "list of users" option in the login windows
    (system preferences/accounts)

    2) logged out all users (of course, all users form the /Users dir, since
    I cannot logout service users...)

    3) checked for existence of /dev/console (that curiously, but not too
    much, is reported to belong to me); here's the answer on Terminal.app

    crw------- 1 tonibin tonibin 0, 0 Jun 2 13:29 /dev/console

    4) typed ">console" (without double quotes) in the username field of the
    login prompt and left the password field empty

    5) obtained the following message, in the upper line of the full black
    screen in text mode (I couldn't Copy & Paste it):
    -----
    Jun 2 13:32:06 eMac-G4 getty: /dev/console: Operation not supported by
    device
    -----

    6) This message is displayed for about 20 seconds, and then the login
    window reappear

    I guess there's a sort of wrong configuration or some wrong permissions
    for some system file.

    -- Antonio
     
    Antonio Maschio, Jun 2, 2006
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.