Terminal setting "Escape non-ASCII" as "Enable non-ASCII"?

Discussion in 'Apple' started by Jussi Piitulainen, Feb 18, 2005.

  1. I learnt that one of the Terminal window settings, under "emulation"
    and on by default in current Panther Terminal, sends outside-ASCII
    characters as combinations of ^V and some other character. In the
    ..plist file the <key> is something like UseCtrlVEscapes.

    The English label for the setting is accurate: "Escape non-ASCII ...".
    The Finnish confused me: it translates as "Enable non-ASCII ...", but
    between the computers that I use, it disables non-ASCII, making local
    and remote Bash and Emacs just beep at me; they don't seem to expect
    these ^V-escapes.

    Does "Enable non-ASCII ..." make sense to somebody? What programs,
    protocols, systems use ^V this way? Hm, actually, why is this option
    there at all, and why is it on by default?
     
    Jussi Piitulainen, Feb 18, 2005
    #1
    1. Advertisements

  2. I'm not sure why it's not working for you in bash, but in Emacs, the way
    to enter control characters literally is by preceding them with
    Control-q. Control-v is used in most other environments, including bash
    (unless you've customized this away).
    It's the default "lnext" (literal next) character in the terminal driver.
     
    Barry Margolin, Feb 18, 2005
    #2
    1. Advertisements

  3. I know how to use ^Q in Emacs and ^V in Bash this way. Mostly I use
    them to enter a literal TAB or NL. These are ASCII characters.

    I see now that I omitted important information. The characters that
    the setting broke here are letters in the upper side of Latin-1. Not
    control characters, and not ASCII. I have keys in the keyboard to
    produce them.

    Bash does not beep when the escape is on, I was wrong about that
    above, but it accepts these letters either way. With escapes off, when
    I press "^Vö", Bash receives the single letter "ö" literally; with
    escapes on, when I press "^Vö", it receives the two characters "^Vö",
    which is not what I meant.

    I see now why Emacs beeped at "^Vö": I was testing in an empty buffer,
    so it couldn't scroll. When the buffer has text, it first scrolls and
    then inserts the letter. Not what I meant, but now I see what's going
    on.

    The fact remains that my non-ASCII characters work when I do not
    "ebable" them and stop working when I do, which is funny.
    Is the terminal supposed to reject non-ASCII characters without this
    escape? I understand about control characters. I'm not quite sure what
    a terminal or a terminal driver is, as opposed to a shell like Bash.

    Thank you.
     
    Jussi Piitulainen, Feb 18, 2005
    #3
  4. The only characters that are normally accepted literally on a terminal
    are ASCII graphic characters. Some control characters have special
    meanings, either assigned by the operating system (you can see these
    with "stty -a") or by certain applications like bash. Anything else is
    rejected.
     
    Barry Margolin, Feb 19, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.