The Adaptec curse or why can't I boot from an SCSI cdrom

Discussion in 'Asus' started by Montana Pete, Apr 30, 2005.

  1. Montana Pete

    Montana Pete Guest

    Hello fellow Adaptec Users

    I have 10 computers that have Adaptec SCSI controllers installed. One
    uses a 39320 card, but most use 39160 cards. All the SCSI cdrom's are
    Plextor UltraPlex units also known as the PX-32CS. I have a boot CD I
    have created to run Norton ghost and copy disks, create images, and
    restore from images. On the older motherboards I have no problems, and
    I can boot from a cdrom just fine, but on the more recent motherboards
    I have a variety of problems that I have developed workarounds for,
    but it's still a PIA.

    I have two P4T-E motherboards.

    On the first one if I boot from the CD I get the message "A bootable
    disk has been detected. I has been assigned as drive A: and your A:
    diskette has been reassigned as drive B:". Not exactly the verbage,
    but you all have seen it and know what I am talking about. If I let
    the boot process continue normally the system will ignore the CD and
    boot from the first hard disk drive. If I put a diskette, any
    diskette, in drive A: then the system will boot from the cdrom drive.
    My workaround for this system is to keep an old recovery diskette in
    the drive and insert it any time I want to boot from the cdrom.

    On the second one if I boot from the CD I get the message "A bootable
    disk has been detected. I has been assigned as drive A: and your A:
    diskette has been reassigned as drive B:" . If I let the boot process
    continue normally the system will ignore the CD and boot from the
    first hard disk drive. If I put a non-bootable diskette in drive A: I
    get the normal "not a system disk. Insert a bootable disk and press
    any key". If I put a DOS boot disk in drive A: the system will boot
    from it. My workaround for this system is to keep a copy of the
    diskette I used to make the bootable image for the ghost CD and insert
    that when I want to boot from the cdrom. The diskette loads DOS and
    the cdrom drivers, then switches to the CD and loads ghost.

    I have two P4C800 motherboards.

    The first one works identically to the second P4T-E, so I keep a
    diskette with the CD boot image on it in that machine also.

    The second P4C800 is a little more complicated. On that machine I also
    have a Plextor DVD drive; A SATA PX716SA. I used to be able to boot
    from the SCSI cdrom drive by using the boot menu. Just hit F8 during
    the memory test and the pop-up boot menu appears at the end of the
    BIOS processing and gives me the option to boot from any of the
    detected devices. If I try that now the system looks in drive A: then
    it checks out the DVD drive which is empty of course, and finally
    gives me a little different "no system disk" type of message but the
    meaning is clear that it can't find the boot image it told me a few
    seconds ago it just read from the CD. If I put a CD in the DVD drive
    or a diskette in the A: drive it will attempt to boot from either one.
    However since I have the SATA drive set to enhanced mode in the BIOS
    for the benefit of Windows, the system will freeze up during the boot
    process. Yes, I could go into the BIOS and change the DVD settings to
    compatible, boot from the DVD drive, go in afterwards and change it
    back, but it's easier to put a floppy with the CD boot image on it in
    drive A: just as I did in the 2 previous machines..

    Now, what is going on here? All these machines used to be able to boot
    from the Plextor SCSI drive just fine and all with their current
    controller cards. I have tried the bootable CD in the older computers
    and it works fine so it's not the CD. Sure I have made changes to some
    of the BIOS settings over time, and I have upgraded the BIOS versions
    and as of now all computers are running the latest version. I have not
    changed the settings in the BIOS on the controller cards and the
    computers that work and those that fail have the exact same settings.
    I have no recollection of any changes around the time these problems
    started. It just seemed like the problem occurred with one of the
    P4T-E machines one day, then later on the other, and finally the
    P4C800's were cursed as well. All this happened over an extended
    period of time.

    Anyone have any ideas? Paul, if you read this I would welcome your
    opinion.
     
    Montana Pete, Apr 30, 2005
    #1
    1. Advertisements

  2. Montana Pete

    Mistoffolees Guest


    Maybe it is an Adaptec issue. Now that I think about it,
    I was never able to successfully boot a Windows installation
    cdrom from an Plextor SCSI CD drive/Adaptec 391XX or 2940
    combination in new P4C800 motherboards. For this reason, I
    install from an ATAPI-IDE CD drive and then re-configure
    for SCSI afterwards. Don't have time to fiddle with Ctrl-A
    and setting in the Adaptec bios settings.
     
    Mistoffolees, Apr 30, 2005
    #2
    1. Advertisements

  3. Montana Pete

    Rick Guest

    A few general comments:

    -- Non-hard disk SCSI components (including CDROMs)
    are going the way of the dinosaur, and system manufacturers
    are becoming more and more reticent to fix these kinds of
    boot problems in their system bioses (and that IS where
    most of these problems reside). Really the best long-term
    solution is to move to IDE CDROMs.

    -- Make sure your Adaptec controllers have the latest bios.

    -- Taking one machine as a test case, try different PCI slots
    for the SCSI controller and see if it makes any difference.
     
    Rick, Apr 30, 2005
    #3
  4. Montana Pete

    Paul Guest

    Well, I'm no "IT guy", and the solution you would use
    for one computer, won't scale well for 10 or 100 computers.
    As your post above indicates, it is a lot of work to record
    the foibles of each machine type individually.

    The motherboard boot order has been problematic since the
    introduction of AMI BIOS. I don't recollect the same kinds
    of issues with boot order for Award, but then again, I
    haven't been doing this stuff for that long.

    The AMI BIOS just doesn't seem to have a "strategy" when it
    comes to booting. If a piece of hardware goes missing since
    the last boot, the boot order will change, in unpredictable
    ways.

    In terms of the messages you are getting, I expect some of
    them are coming from the SCSI BIOS. The one about the
    substitution for the floppy, for example. Again, I have no
    detailed knowledge of how INT 0x13 services work, how the
    various BIOS modules register their services at boot time -
    it would seem that the SCSI BIOS is doing floppy emulation
    some how, and moving the real floppy out of the way.

    If I pretend for a moment, to be the "IT guy", I guess I would
    ask the question as to what common denominator will work on
    all computers. I think the answer is an IDE based CDROM drive.
    I get some damn fine drives at my local computer store for
    about $30 and haven't had problems with them. If the budget
    allows, I think I would equip all the machines with an
    ordinary old-fashioned CD drive.

    I'm a little surprised at your SATA DVD results, and that
    you actually needed to switch to "Compatible" mode. The
    purpose of "Compatible" is to make SATA devices appear like
    IDE devices, so that an older OS is unaware that a new hardware
    type is present. I guess I did not expect, when running
    "Enhanced", that there would be a difference in the way that
    boot operation would work with the SATA DVD. Live and learn.

    Since motherboard BIOS, at a minimum, will be tested to boot
    from a floppy, IDE CDROM, IDE hard drive, all of which are
    connected to the Southbridge, that is where I would want to
    install devices that "just have to work". For less demanding
    "data only" purposes, I would let the users have their SCSI
    chains, USB jump drives, whizzy this and that, Promise RAID
    arrays, but leave a vanilla CD for the "IT guy".

    In a bigger company, there would be some kind of network
    based deployment - just set it up during the day, then at
    night, deployment scripts fix all the machines. Without
    automation, administering machines rapidly gets out of hand.
    (I've administered about a dozen Unix machines in a
    departmental setting, and that is where I learned that
    scalable approaches are a must - and that I wasn't cut out
    to be the "IT guy" :) I was just the local "go-to" guy
    with zero budget.)

    HTH,
    Paul
     
    Paul, May 1, 2005
    #4
  5. Montana Pete

    P2B Guest

    This is all very disappointing, because you've determined that more
    recent Asus BIOSes simply don't support Adaptec's SCSI BIOS the way they
    used to - as evidenced by your systems booting from HDD or floppy after
    the Adaptec BIOS already pushed them aside.

    Unfortunately Rick is probably correct - Asus will have little interest
    in fixing the problem, which relegates you to using workarounds or IDE
    CDROMS - which have never had full el-torito support.

    P2B
     
    P2B, May 2, 2005
    #5
  6. Montana Pete

    deus maximus Guest

    snip

    I have the earlier 19160 Adaptec connecting a HDD and 2 CDD drives
    on the P4P800. No problemo--I would contact Adaptec support and
    also look for an Adaptec bios fix.
     
    deus maximus, May 2, 2005
    #6
  7. Montana Pete

    NSN Guest


    Pete, Paul and guys :

    I have been using Adaptec SCSI on ASUS boards for "ever". About 6
    months ago, much trouble started. My board is the P4C800E-Deluxe. My
    card is the Adaptec 29160N. The problem .. if I insert a CD into my
    Plextor SCSI internal CD reader all hell breaks loose. My HD slows
    down, files get corrupted, I crash periodically. Most of the problems
    can be eliminated by disabling auto-play. In any event, I finally
    gave up, dumped my Plextor SCSI CD and replaced it with a Lite-On IDE
    CD reader. I am still using my Maxtor 36 Gig SCSI 10K III drives and
    they are performing as they should.

    This was NOT the case when I first set the unit up. It happened
    about 6 months ago. I have no idea if it is related to XP-SP2 or the
    AMI BIOS (1017) that I am using but I feel certain that one of these
    is the culprit. (BTW .. I hate the AMI BIOS !!!!!)

    Norm
     
    NSN, May 2, 2005
    #7
  8. Montana Pete

    Montana Pete Guest

    Thanks Paul, and everyone else who responded.

    I have the latest BIOS on all the Adaptec cards and they still give
    the same messages (regarding the reassignment of the floppy to drive
    B:) that they always did; it just doesn't work. After reading all the
    responses and thinking about what has happened, I feel that the most
    likely candidate for blame is the ASUS bios. When I update the BIOS I
    usually take a Ghost image copy first, but if the update works I don't
    usually attempt another Ghost image, and therefore another boot from
    the CD, for quite a while. Since they all worked once, and I have had
    no major hardware changes since then, the BIOS is most likely the
    culprit.

    While I could go out and buy a box full of IDE cdrom's I think that
    cure would be worse than the disease. I will continue to use my
    work-around's and if ASUS comes out with another update for the P4C800
    I will put it on and see if that helps. I don't expect an update for
    the P4T-E any time soon if at all so I guess I am stuck there. Anyhow,
    it's not terrible, I just don't like it when things don't work
    properly - even if I do have a way to get around it.
     
    Montana Pete, May 3, 2005
    #8
  9. Montana Pete

    Pug Guest


    I've had an issue with the Asus A7N8X deluxe bios with scsi devices in the
    past.

    If I flash the motherboard bios to have the latest Silicon Image Sata bios
    installed it will not boot correctly, i.e. it will not see sata / scsi hdd's
    or scsi / ide cdrom drives as boot devices and just hangs. Changing the
    boot order or the sata / scsi bios order makes no difference, only disabling
    the sata bios allows me to boot the machine. Flash the bios back to the
    older version and no problems at all, installing the new sata bios into the
    old motherboard bios also hangs the machine leading me to believe some
    change in the sata bios has caused a problem. I reported this to Silicon
    Image - no response, I reported it to Adaptec - no response. If its old
    hardware then forget Adaptec they just don't care about bios problems if its
    older than 6 months and Silicon Image don't even register the 3112a sata
    interface as one of their products anymore.

    Steve
     
    Pug, May 17, 2005
    #9
  10. Montana Pete

    Rick Guest

    Which Adaptec controller are you using? Which bios version?
     
    Rick, May 17, 2005
    #10
  11. Montana Pete

    Pug Guest

    I should really remember to keep an eye on threads and reply slightly
    quicker.

    I'm using a scsi controller 19160 with v3.10 bios. The sata controller is
    currently on bios 4.2.27

    The MB is currently on 1007.

    Like I said, any updates to the sata bios 4.2.50 or 4.2.47 causes the
    problem.
     
    Pug, Jun 5, 2005
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.