1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Thinkpad 600x battery failing to charge

Discussion in 'Laptops' started by Emmett, Feb 17, 2005.

  1. Emmett

    Emmett Guest

    Hi,

    I have a Thinkpad 600x. The problem I'm having is that the battery is
    failing to charge. After hours of being left on charge the power still
    registers 0%. I've tried three different batteries all with the same
    problem.

    I'd really appreciate any advice or comments.

    Thanks in advance.

    Emmett
     
    Emmett, Feb 17, 2005
    #1
    1. Advertisements

  2. Buy a new battery. The 600 series battery is notorious for failing after a
    year or so
     
    Bruce Markowitz, Feb 17, 2005
    #2
    1. Advertisements

  3. Battery's bad, replace it.

    TJ
     
    Capt. 'Wild' Bill Kelso, USAAC, Feb 20, 2005
    #3
  4. Emmett

    cmdrdata Guest

    In the fall of 2004 I bought a new battery for my TP600E. It worked
    fine, and charged to 100%. Soon after it started to charge only to 98%.
    A couple of months ago, it will only go to 42%. Last week only 4% with
    the orange charging lite always stays lit, never got to green. The unit
    would shut off a few minutes after startup when running on batt alone
    (I set my limit to 1% just for test). I then covered the two center
    pins of the batt with paper, and started the system. It ran for 1 hour
    and 15 minutes on that darn battery! The system thinks it is connected
    to AC power. This says to me that the charging circuit is faulty. Care
    to comment?
     
    cmdrdata, Feb 20, 2005
    #4
  5. Emmett

    JHEM Guest

    The monitoring circuitry in the battery is faulty, not the laptop's charging
    circuitry.

    Regards,

    James
     
    JHEM, Feb 20, 2005
    #5
  6. Emmett

    larwe Guest

    I don't remember fersure but I think the 600E had five battery
    contacts, right? Two power, one temp sense, two I2C? You were probably
    disabling I2C.

    Anyway, the micro in the battery is confused, or has corrupted EEPROM
    contents. The power management controller in the laptop is seeing this
    and shutting the unit down to prevent over-discharge.

    In SOME cases it is possible to reset the micro (and fix problems of
    this nature) by opening the battery pack and disconnecting the cells,
    then shorting the terminals on the PCB where the cells used to connect,
    but this is a last resort that usually won't work (except on the Compaq
    Armada M300 batteries, which go crazy once a week and practically need
    to be reset every time you charge them). The EEPROM has a finite write
    life and it's usually written at least twice during each
    charge/discharge cycle.

    A re-calibration will fix the unit (if fixable) without you needing to
    open anything, but I'm not sure if IBM provides a utility to do this on
    the 600E. Basically what the utility does is to force the power
    management controller to ignore what the battery is saying about
    remaining energy capacity and simply run the unit down to death. That
    way the battery's gas gauge IC can integrate I over t all the way down
    to the "real" empty point of the cells.
     
    larwe, Feb 20, 2005
    #6
  7. Emmett

    Emmett Guest

    Guys,

    Thanks for the comments. Getting back to the 600x As I've tried three
    different batteries all with the same result I still wonder if there is
    scope for the charging circuitry in the laptop to be faulty? Is there
    any way of testing this or testing the batteries?

    Thanks for your help.

    Regards

    Emmett
     
    Emmett, Feb 20, 2005
    #7
  8. Emmett

    cmdrdata Guest

    Emmet, try running your laptop with just the battery, but cover up the
    two center connector with a piece of tape. Doing this will allow the
    computer to receive the 10.8 V from the two outer contacts(if the batt
    is somewhat working). Let it run and see if you get good enough run
    time. If ok, then at least we'll know that the Li-Ion is somewhat ok. I
    think that since they are wired in prallel internally ('i've rebuilt a
    couple myself), the main problem is that they are not matched pair, so
    one will die before the other, hence the typical drop from 90-100
    percent to around 50 when it started to act up.
     
    cmdrdata, Feb 20, 2005
    #8
  9. The only way to check the 600X pack is to try a known good one.
    The test pack does not need to be new; it only needs to charge and
    discharge in a TP600X. IBM had a TP600X utility called
    batcheck.exe that basically verifies the condition of the pack
    electronics -- working or not and if so -- the cells' approximate
    condition i.e., capacity normal or not for whatever criteria IBM
    has programmed in That doesn't seem to be age per se but
    probably counts cycles in some way along with voltage under load..

    One of the two center pack pins is for a thermistor. IBM also had
    a resistance (ohm meter) check method for that on their site. The
    other center pin is the pack electronics data line.

    Disabling (covering) either will stop any charging at all and may
    result in flashing LEDs but will still leave the pack connected so
    it can be drained until the internal safety circuits cut off. But
    more likely the PC will cut off first at about 10V under load..

    Be advised doing this with borderline cells (condition) can
    result in an unchargeable pack if the pack electronics sense a
    possible dangerous cell imbalance or condition. New cells may
    not fix this.

    New cells won't restore the electronics/batcheck reading to new.
    They may result in a perfectly usable full capacity pack but with
    very inaccurate fuel gauge reading after about 60-70% is reached.
    This is the infamous TP600X pack anomaly-trait.

    There seems to be no way to easily reset the pack electronics
    short of possibly reprogramming them to new and that would mean a
    lot of effort and knowledge of the exact ICs used, circuit,
    electronics, equipment and chip programming.

    Good luck.
     
    H. Dziardziel, Feb 21, 2005
    #9
  10. Emmett

    Emmett Guest

    Cmdrdata,

    Thanks for the suggestion. I've tried covering the middle two
    connectors as suggested but there is still no charge getting to the
    batteries. All three are registering as empty and not charging.

    Regards

    Emmett
     
    Emmett, Feb 22, 2005
    #10
  11. Emmett

    PlaidAvenger Guest

    Emmett,

    Did you ever find a resolution to this problem?

    It sounds like I'm having the exact same problem. I too assumed that
    it was a battery problem - battery says it's charging but will always
    show 0% charged, if unplugged for even a second the power instantly
    shuts off. It had been working fine for the last year, but then one
    day, it went from working fine, to not working at all, there was no
    'gradual dropoff'.

    A friend of mine has the exact same model of laptop I have (IBM
    Thinkpad 600E). His battery will last about half an hour in his
    machine, while mine was lasting about an hour in my machine. After
    swapping batteries, my battery worked in his machine, but I was still
    having the same problem with mine (0% charge).

    So then we thought, maybe it's the cable/power supply, so we swapped
    those, still no change.

    Through process of elimination, I'm now thinking it's something built
    into the laptop, and not a simple battery problem. :(

    I was just wondering if you had any success with getting yours fixed,
    if you did, please let me know what it was, and how much it ended up
    costing you.

    So far, I'm in $200.00 (CDN) for a new battery. :(
     
    PlaidAvenger, Mar 2, 2005
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.