TIP: S2466 and Gigabit Ethernet Adapters

Discussion in 'Tyan' started by Scott, Aug 1, 2003.

  1. Scott

    Scott Guest

    Over the last 6 months I've been going back and forth on a couple of
    issues related to using Gigabit Ethernet adapters in a Tyan S2466 based
    system.

    I thought I'd share my results, but first of let me say I feel the
    problems are related to the S2466 itself and not the adapters.

    These adapters worked great and without problems in two other systems.

    Another thing to note is that two different Gigabit Ethernet hubs were
    used, all PCI slots were tried, the onboard Ethernet was disabled, and
    BIOS 4.03 and 4.05 were tried.


    -----------

    Tip #1 - Don't use National Semiconductor chipset based adapters (I.e.
    D-Link, Netgear, and Linksys) in a Tyan S2466.

    You can experience a random problem where the adapter will not
    initialize during post.

    No Link Light will show up on your hub after the system is powered on
    and Windows won't even show the adapter as being installed.

    Only a full power down and startup can correct the situation and even
    then, you might have to do that a couple of times.

    For the most part, these adapters worked fine, but this problem is
    really annoying when it happens.



    Tip #2 - Disable ROM Scan when using an Intel Pro1000 in a Tyan S2466
    System

    This adapter has been very stable, but had one problem in installing it.

    The S2466 would hang during post.

    I believe this is related to the PXE Remote Boot feature in the adapter,
    but can't be sure. Other PXE Enabled adapters (that I've used) take no
    more than 15 seconds to go through and determine there isn't a server to
    use and I let this sit for a good 5 minutes.

    This adapter booted up fine in two other systems and I didn't see the
    normal PXE message either, so again, can't be sure.

    To get it to work, you need to take the adapter out, boot the system and
    go into the BIOS to make a change.

    Go to:

    PCI Configuration
    PCI Device Slot # (where # is the slot you want to put the adapter)
    Option ROM Scan - Disable


    ---------------

    That's my 2 cents worth, Your mileage may vary.

    But I hope it helps someone.

    I'm sorry to say Tyan was no help at all.
    If and when I did get a response, they kept the blame on the adapters.

    -Scott
     
    Scott, Aug 1, 2003
    #1
    1. Advertisements

  2. Hello Scott,

    Great to see someone share their experiences so others do not have to
    stumble in the same places.
    I have to disagree with your assertion that one should not use Netgear
    Gigabit adapters. I have two systems configured to use Netgear's GA622T
    in a 64 bit slot with astonishing results, one with a S2466, another
    with the dreaded bug infested 2466-4M. The OS I am using is Redhat 7.3
    utilizing the NS83820 driver to enable the adapter. Transfer rates are
    very fast indeed.


    Best Regards,

    Christopher Cox
     
    Christopher Cox, Aug 2, 2003
    #2
    1. Advertisements

  3. Scott

    Scott Guest

    Thanks Christopher,

    I shuould have specified model numbers and the fact that these were all
    32-bit PCI adapters.

    And YES!! I shouldn't have listed Netgear as it looks like they don't
    use the NS Chipset in question.

    My apologies. DOH!!!

    The National Semiconductor chipset I'm refering to consists of a DP83861
    and DP83821 chip combination.

    The Adapters that I'm aware of that use these are:

    SMC 9452TX
    D-Link DGE-500T
    Linksys EG1032, EG1064

    Again, the problem I'm having with these occurs at random and they
    average out to 1 in 5 power ups. Normally, the hub would show a link
    light come on during post and before the OS loads. There are times where
    this doesn't happen.

    If the Link Light doesn't show up, the OS (WinXP in this case) wouldn't
    even show the adapter as being an installed device. It would act like
    the adapter was removed from the system.

    All of these worked flawlessly in other systems, so I don't blame the
    adapters one bit.

    Thanks again and sorry for listing Netgear in this.
    -Scott
     
    Scott, Aug 2, 2003
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.