Transfer file from older Mac Nubus machine to a MacOS-X 10.4 machine: how?

Discussion in 'Apple' started by S P Arif Sahari Wibowo, Jul 22, 2007.

  1. Hi!

    How I can transfer my Mac files from older Mac Nubus machine (PowerMac
    7100 80AV) to an Intel iMac running MacOS-X 10.4 Tiger? There are
    hundreds of files totalling more than a GB.

    I tried AppleShare TCP/IP connection from the older Mac, but when
    copying, the connection always dropped out after the 1st file.

    I can use FTP, but that's mean the resource fork won't be copied. The
    old Mac disk is really full, there is no space to Hexbin or Stuffit
    the file first before copying.

    Is it possible to hack the MacOS-X 10.4 Tiger to allow AppleTalk? Will
    it work better through AppleTalk?

    Other thing I may try is to run SheepShaver in the Intel iMac;s MacOS-
    X, install MacOS from my CD there, then copy file through AppleTalk
    into there. However, this will be quite an endeavour, while I still
    don't know whether it will work and how to move from the SheepShaver
    virtual machine to the host machine.

    Any idea / suggestion?


    S P Arif Sahari Wibowo, Jul 22, 2007
    1. Advertisements

  2. My experience is that it works with a PPC Mac on the server side, but
    not with an Intel Mac. The other way around works find a long as the old
    Mac has Mac OS 9 - or you install Shareway IP. I think it runs for a
    limited time without a license <>.
    Anders Eklöf, Jul 22, 2007
    1. Advertisements

  3. If you have an external SCSI drive, why not transfer everything to the
    SCSI drive, and then get a FireWire-to-SCSI adapter and attach the SCSI
    drive to your Intel iMac and copy the files. To me, that seems simpler.

    Remove blown from email address to reply.
    Thomas R. Kettler, Jul 22, 2007
  4. S P Arif Sahari Wibowo

    The Mac Dude Guest

    A few ways come to mind:

    If you run OS 9 on the 7100 you should be able to have it serve
    AppleTalk over IP and mount that on the OS-X Mac.

    If you run OS 8.6 or newer on the 7100 you should be able to connect to
    the OS-X Mac by using the Chooser's ability to connect to an
    Atalk-over-IP server. This is the way I routinely pull files from G5
    Macs to an 8500 in my office, & it works like a charm (at least for my
    maybe 10...20 MB at-a-time needs).

    If you run 7.5 or newer on the 7100 you can install NetPresenz---an ftp
    server---on the 7100 and use Fetch on the OS X Mac. NetPresenz and Fetch
    will communicate using MacBinary and thus preserve the Resource forks. I
    am using that route routinely as well. You might even be able to use
    the Finder's ftp capability; I haven't tried that. I do not know whether
    NetPresenz is still around on the various sites on the net, it is an old
    Peter Lewis program. There may also be other ftp servers for System 7.5
    & up. Check, the Classic pages.

    You may also enable the OS X ftp server and use Fetch on the 7100 to
    push the files. I do not know whether Resource forks get preserved doing
    it this way, though.

    Fetch is $25 but I think the evaluation version is enough for what you
    want to do.

    Beyond that it'd get more interesting & expensive, but I can't imagine
    why one or more of the above wouldn't work.

    Can you elaborate on what System you are running on the 7100 and what
    exactly happens when you try to transfer a file using Atalk over IP?

    Mac Dude
    The Mac Dude, Jul 23, 2007
  5. File larger than about 1.5 MB may not successfully copy from a Mac OS
    9.2.2 client to Mac OS X Server 10.4.9 via AFP. The copy may stop and
    this alert may appear:
    "The file server's connection has unexpectedly closed down."


    Uwe Schliephake, Jul 23, 2007
  6. Sorry I missed this details. The MacOS-X is 10.4.9. The PowerMac 7100
    has one partition with 8.1 and another one running 9.0.4. Both have
    the same issue.

    I think I also has MacOS 8.5 CD somewhere in my garage sale stash,
    which I can find and install if it can make a difference.


    S P Arif Sahari Wibowo, Jul 23, 2007
  7. The link that was posted here earlier

    resonated with me as there have been similar weirdnesses with the latest
    LINUX kernel releases.

    I can't say that the following is an exact description of the issues,
    but its right in general terms.

    Essentially the rise in everyones bandwidth has led to usage of some
    slightly arcane areas of the TCP/IP specification, mostly around the
    area of the window size..the amount of data in packets that will be sent
    before the sending machine expects an acknowledgement.

    This is supposed to be negotiated by the sending and receiving machine,
    but machines in between (typically routers) also can interject and
    request smaller sizes.

    It seems that many older implementations on older machines and routers
    do not work correctly with the modern kernels: The workaround is to
    reconfigure the TCP/IP packet sizes to limit their size..whilst this
    results in a performance hit on gigabit Ethernet and the like, it
    normally has little impact on normal usage.

    The symptoms are generically timed out connections during large sized

    Use of the netstat and ifconfig tools will normally show unusually high
    packet loss.

    The posted link shows that by adjusting the apple file protocol tunings,
    some gains are to be had..this is NOT the same was what I have been
    describing, but its very similar.
    In practice depending on what you are connecting to, if any data
    overruns a buffer, you will get strange effects like those noted..and
    experience shows that even a different hub or switch may make things
    work better.
    The Natural Philosopher, Jul 23, 2007
  8. S P Arif Sahari Wibowo

    David Stone Guest

    With reference to the article elsewhere in this thread:

    The 1.5 MB limit for AFP file transfer to work kicked in with the
    10.4.9 system update on my G5 iMac, so it isn't just a problem
    with OS X Server.

    Since I had a USB card in the classic Mac, I ended up just using
    a USB key to transfer the files I wanted, so I haven't tried the
    fix suggested. I don't suppose you have an external burner, and
    a suitable version of Toast on the classic Mac?
    In Fetch, you can get it to get/put the files as .hqx, but you may have
    to tweak the preference settings to get it to apply that to all files.
    It's been a while since I had to transfer files between OS 8/9 and OS X
    boxen that way, so unfortunately I don't remember the precise details.
    David Stone, Jul 23, 2007
  9. Interestingly, cannot find the original article with that link in this
    thread, but this is really right on the money! The file transfer works
    well now!

    Note that since the "serveradmin" command is apparently not included
    in non-server MacOS X, the changes was made by stopping Personal File
    Sharing in Sharing control panel, using the "default" command to
    change the TCPQuantum parameter, then re-start the Personal File


    S P Arif Sahari Wibowo, Aug 3, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.