1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Two IBM/Lenovo ThinkPads over a wireless network

Discussion in 'IBM Thinkpad' started by Alan, Feb 9, 2007.

  1. Alan

    Alan Guest

    Hi, I have been struggling for some time trying to get my two IBM/
    Lenovo ThinkPads to work over our wireless network (see http://
    groups.google.com/group/comp.sys.laptops.thinkpad/browse_thread/thread/
    27ab28434e118e0f/6f6779b235421b1d?
    lnk=st&q=Garny&rnum=5#6f6779b235421b1d). One of them is a T42p and the
    other a X41.

    The X41 was recently bought to replace an old laptop, which used to
    work fine with the T42p over our wireless network. Since we have
    replaced that old laptop with the X41, things have just stopped
    working: we lose our wireless connection on both the T42p and X41
    within a few minutes of being connected.

    Tonight, I thought I would shut down the X41 and start the old laptop,
    and see how it behaves together with the T42p and, unsurprisingly,
    everything is working as it should: no wireless connection being lost.

    So, that really tells me that there is a problem between my T42p and
    X41. They just don't seem to be willing to live together on the same
    wireless network. Why though?

    Alan.
     
    Alan, Feb 9, 2007
    #1
    1. Advertisements

  2. Alan

    John Navas Guest

    [cross-posted to alt.internet.wireless]

    What _exactly_ does lose the connection mean? Red X on icon is system
    tray? Just can't surf? What?
    What controls the wireless network? Exact make, model, version, and
    firmware of wireless router or access point please.
     
    John Navas, Feb 9, 2007
    #2
    1. Advertisements

  3. Alan

    Alan Guest

    What _exactly_ does lose the connection mean? Red X on icon is system
    It means that I cannot access my modem/router anymore and therefore
    cannot do anything that involves my network and, as a consequence, the
    internet (i.e. impossible to browse, receive email, etc.).
    I use a D-Link DSL-G624T with the V3.00B01T02.UK-A.20060621 firmware.

    Note that I have tried other firmwares (cannot recall which though)
    and got exactly the same problem. Also, note that using the above
    modem/router with the above firmware, I have NO problem whatsoever
    when using my T42p with *another* laptop (Hi-Grade Notino W6700).

    Things that I have tried include (in no particular order): access list
    (i.e. with and without access limited by MAC address), various
    encryptions (i.e. no encryption, WEP and WPA/PSK), DHCP (i.e. no DHCP,
    DHCP without static IP assignment, and DHCP with static IP
    assignment), and maybe other things that I cannot recall for having
    tried so many things!

    I would, somehow, be surprised if the problem was with my modem/
    router, unless ThinkPads don't like that particular make (who knows?).

    Anyway, this is extremely frustrating and would appreciate any help...

    Alan.
     
    Alan, Feb 10, 2007
    #3
  4. Alan

    John Navas Guest

    Again, what _exactly_ does "cannot access" mean?
    What does the network icon look like and say?
    What it should look like: http://i5.tinypic.com/40e4oea.png
    Have you tried the ThinkPad in a public Wi-Fi hotspot?
    What matters is the make and model of the Wi-Fi adapter and the software
    used to control it -- there's nothing special about the ThinkPad. My
    own T41 uses an Atheros mini PCI card with Windows XP WZC.
     
    John Navas, Feb 11, 2007
    #4
  5. Alan

    Alan Guest

    I know how it should look like and it doesn't look like that at all.
    Sorry, but I am not willing to get the two ThinkPads online if I can
    avoid it. The whole situation is really pissing my partner off as she
    needs an internet connection for her work (in other words: we are only
    ever running one of the ThinkPads and her old laptop, since that's the
    *only* combination that works). Anyway, independent of how the icon
    actually looks like, it clearly tells me that the laptop is NOT
    connected to my modem/router and therefore to the internet, as
    mentioned above when I say that I cannot browse the internet, receive
    emails, etc. Sorry, if I am being a bit impatient, but I am really
    getting annoyed with it all. I have spent, not to say wasted, hours
    (which probably add up to days by now) trying lots of different
    settings and all I can tell you is that to have two ThinkPads running
    means that the icon changes from 'connected' to 'disconnected' within
    a minute or a few minutes at best. If, on the other hand, I have only
    one laptop running, then everything is fine. In both cases, it doesn't
    matter whether my partner's old laptop is running or not.
    I have never tried the X41 anywhere but at my place, while I have
    tried the T42p all over the world (literally) and have never had any
    problem with it when trying to connect it to a wireless network.
    Ok, fine, so how do I go about determining whether there is or not a
    conflict between my X41's wireless adapter and software and that of my
    T42p? Are there known issues of the sort?

    Alan.
     
    Alan, Feb 11, 2007
    #5
  6. Alan

    John Navas Guest

    What's that supposed to mean? I can't help you if you don't provide the
    information.
    So what does it look like?
    Sorry, but I can't help you if you going to be impatient like that.
    No. You're making things up and thrashing around. Calm down, answer my
    questions, and I may be able to help you.
     
    John Navas, Feb 11, 2007
    #6
  7. Alan

    Alan Guest

    It means that I cannot access my modem/router anymore and therefore
    I believe to have provided you with the information, but I am
    obviously wrong...
    Ok, I have googled around for a picture that looks like what I get:
    http://www.itap.purdue.edu/airlink/images/vpnpc1a.jpg
    The only question I hadn't properly answered is how the icon looks
    like. You now know how it looks like and, as you can tell (unless I am
    completely mistaken), it does correspond to what I have described in
    words rather than through a picture. So, what does the picture tell
    you that you didn't know before?

    Otherwise, I am still of the view that there is an issue with the two
    ThinkPads. Maybe it's hardware, maybe it's software, or maybe it's a
    combination of the two (through their respective settings)?

    Anyway, I cannot test anything anymore, it would seem that my T42p's
    screen just died on me. It just went completely black for no apparent
    reason. If I restart my T42p, its screen may or not work and if it
    does, it will freeze after a while, while the rest of the system seems
    to boot up, etc. Having no external screen, I cannot determine for
    sure what the cause of the problem is.

    Anyway #2, I do appreciate your help, but there indeed seems to be a
    problem of communication. Maybe we should just give up... not a good
    day for me it would seem...
     
    Alan, Feb 11, 2007
    #7
  8. Alan

    John Navas Guest

    "?!?!?!?!" is information? Were you trying to be funny?

    Again, what _exactly_ does "cannot access" mean? I can't read your mind
    or see what's on your computer display. I need _exact_ symptoms.
    That helps a bit, but is just a start. Your wireless icon says "not
    connected". What do you see in "view available wireless networks"?
    What happens _exactly_ whey you select your wireless network (if you
    can) and click Connect? If it tries for a time and then eventually
    can't connect, have you turned off _all_ wireless security? To be sure,
    reset the wireless router or access point to hardware defaults, and
    start over without enabling any security. What happens with a wired
    instead of wireless connection to either computer?
    On the contrary -- I've asked more than once "what _exactly_ does
    'cannot access' mean?" It would help greatly if you took the time and
    effort to _exactly_ describe what is happening, instead of just saying
    "cannot access", which could be a great many different things. I'm not
    interested in guessing / taking stabs in the dark.
    I think that view is almost certainly wrong. One wireless client won't
    kill another wireless client (assuming it didn't kill the wireless
    router or access point).
    That's very serious, might well be related to other problems, and should
    be fixed first.
    Fair enough.
     
    John Navas, Feb 11, 2007
    #8
  9. Alan

    Alan Guest

    ?!?!?!?!
    No, I was not. Otherwise, I was not referring to the "?!?!?!?!", but
    to the other things I have mentioned in my other messages. Huge
    problem of communication indeed. Must be me, I am French after all.
    If you were to tell me the kind of answer you are expecting from me,
    then maybe I could tell you exactly what is going on? In the same way
    you cannot read my mind, I surely cannot read yours.
    Most ofthen than not, my modem/router won't show up. I have to stop it
    and restart it to see it listed again. Other times, it will show up,
    but I won't be able to connect to it. Again, by stopping it and
    restarting it, it shows up and I will be able to connect to it. But,
    as I have said several times, this will only be temporary if I have
    both ThinkPads running.
    I have done all those things before (see my very second message). The
    only thing I didn't mention (but did in the *other* thread I refer to
    in my first message in *this* thread) is that everything works fine
    when I use a wired connection. It is only when I try to connect
    wirelessly that things start playing up.
    I am only basing my 'conclusion' on what I am experiencing. Two
    ThinkPads (T42p and X41) together trying to wirelessly connect to my D-
    Link DSL-G624T modem/router results in both of them losing their
    connection. If only one of them is connected, then everything's fine.
    If I knew exactly what the problem is, I surely wouldn't be here
    trying to get an answer for what has been bugging me for quite some
    time.

    Alan.
     
    Alan, Feb 11, 2007
    #9
  10. Alan

    Alan Guest

    Again, what _exactly_ does "cannot access" mean?
    At least all of that, yes.
    I am not familiar with WZC (Wireless Zero Configuration it would
    seem), so what is that exactly? Otherwise, I have indeed seen "limited
    connection" and that was when I 'lost my connection' (i.e. all of the
    above). From there, I had to stop and restart my modem/router to get
    my wireless connection back (for a short period of time that is, if I
    have both ThinkPads running).
    I have checked that and they don't. I have also, at some point,
    configured my modem/router so that it doesn't use DHCP and the two
    ThinkPads so that they use fixed IP addresses, all of that to no
    avail.
    I cannot explain it to myself either, hence my asking here... All I
    can tell you is that to run both ThinkPads on the same wireless
    network results in both of them losing their connection, while either
    one works very well on its own.

    Alan.
     
    Alan, Feb 11, 2007
    #10
  11. Alan

    John Navas Guest

    Fair enough. Carefully note everything that is or isn't happening, step
    by step, and report it fully here. See Mark's response for some of the
    more obvious things you're leaving out.

    You also seem to have a problem with your newsreader deleting spaces
    from quoted replies.
    Your "modem" won't ever show up.

    Your router will show up if (a) it's broadcasting and (b) the wireless
    client is working. If it doesn't show up, then you have one and/or the
    other of those two problems.
    That suggests your router is failing.
    Different issue. Possible problems: interference, security gone wrong.
    Again, points to a router problem. You may want to try a different
    router.
    Not surprising -- routers can have problems triggered by different types
    of loads. For example, many routers will fall over and die because of
    the huge number of connections opened by default settings in
    peer-to-peer filesharing apps.
    Sorry, but I'm _not_ going to chase down other threads. If you want my
    help, post the information in _this_ thread.
    You are actually leaping to conclusions. What I wrote is far more
    likely.

    You would waste far less time if you just posted the requested
    information, instead of arguing about it.
     
    John Navas, Feb 11, 2007
    #11
  12. Alan

    John Navas Guest

    Windows XP wireless control. Are you using that, or IBM/Lenovo Access
    Connections?
    That means DHCP has failed. It would have been very helpful if you had
    provided that information back in the beginning.
    Again, sounds like a router (not modem, not ThinkPad) problem.
     
    John Navas, Feb 11, 2007
    #12
  13. Alan

    Alan Guest

    Fair enough. Carefully note everything that is or isn't happening, step
    Will do that once I get my T42p's screen to work again: cannot do
    anything right now.
    Using Google to post my messages from my partner's old laptop, since
    mine has been rendered useless (screen issue mentioned above).
    I know. My D-Link DSL-G624T is a modem/router, hence my referring to
    it in that way.
    Yes, I gathered that much, but what I don't understand is why it only
    seems to be failing when I use both ThinkPads, but not when I use
    either ThinkPad with my partner's old non-ThinkPad laptop?
    I have tried all sorts of settings, including no security at all, but
    to no avail.
    I have only the aforementioned modem/router. Also, as mentioned
    before, it works fine with in some cases, namely one ThinkPad at a
    time.
    We are not using any P2P softwares. We merely want to browse the
    internet and check emails, both of which should require very little
    load. Also, we do lose the connection when running both ThinkPads
    *and* doing *nothing*, i.e. we just switch the laptops on, log on,
    wait and... after a couple of minutes or so, we lose our internet
    connection.
    Which I have just done...
    Which is?
    I believe to have done so to the best of my ability, which I accept
    may not be sufficient...
     
    Alan, Feb 11, 2007
    #13
  14. Alan

    Alan Guest

    WZC says connected but some/all of the above?
    I have tried to use both Windows XP wireless control and Access
    Connections. In both cases, I got the same result: loss of connection.
    Ok, now we know that this is a helpful piece of information. How do I
    go about fixing that now?
    I am more than happy to accept that, no problem. Now, however, how do
    you explain that my router only fails when both ThinkPads are running,
    but not when only either of them is running?

    Alan.
     
    Alan, Feb 11, 2007
    #14
  15. Alan

    John Navas Guest

    Sorry, but I have no idea what "loss of connection" _exactly_ means.
    Please stick to specific things, as Mark and I have suggested.
    If you get your computer working again, what happens _exactly_ when you
    click Repair in WZC?
    Both together add enough load of a given kind that the router falls over
    and dies. I think your best bet is to try a different router.

    If you get your computer working again, try the FixDHCP script at
    <http://wireless.wikia.com/wiki/Fast_Fixes_to_Wi-Fi_Problems#DHCP_isn.27t_working>
    and post the _exact_ output here.
     
    John Navas, Feb 12, 2007
    #15
  16. Alan

    Alan Guest

    I have tried to use both Windows XPwirelesscontrol and Access
    Can't you accept that by 'loss of connection' I mean that the icon has
    a red cross, that I have more often than not 'limited connection',
    that I cannot browse the internet, cannot receive/send emails, cannot
    ping anything, etc.? Do I have to spell it out every single time?
    I cannot recall the exact message I get, but that basically fails and
    the only thing that works is for me to stop and restart my modem/
    router.
    You are not answering my question. I have both of my ThinkPads
    running, none of them being used for any internet traffic at all, yet
    within a couple of minutes or so, they will both lose their connection
    (see my definition of that above). Now, if I have one ThinkPad running
    only, I can do whatever I want with my internet connection, no problem
    things will be working just fine, but as soon as I start using my
    other ThinkPad, then both ThinkPads will lose their connection (again,
    see my definition of that expression above). So, what kind of non-
    Internet related load could get my two ThinkPads to lose their
    connection?
    Will do that as soon as I can get my screen sorted out.
     
    Alan, Feb 12, 2007
    #16
  17. I agree with John and Mark. You descriptions are somewhat difficult
    to decode. However, you finally described the problem clearly in the
    next paragraph.
    Kinda sounds like a duplicated IP address. Let's do some diagnostics
    and see what happens. On *BOTH* laptops, run:
    Start -> run -> cmd <enter>
    ipconfig /all | find "Address"
    You should get something like:
    C:> ipconfig /all | find "Address"
    Physical Address. . . . . . . . . : 00-02-B3-1E-43-17
    IP Address. . . . . . . . . . . . : 192.168.1.11
    Both lines should be different on the two laptops.

    If the Physical Address (MAC address) is the same, the two computers
    were setup by cloning and have the same MAC address in the registry.
    That won't work, but is also improbable as the T42p and X41 laptops
    are quite different. Worth checking anyway as there are some
    utilities that do the same thing.

    If the MAC addresses are different, but the IP Address is the same,
    then you have a static IP address setup on one or both machines which
    will need to either change, or be converted to a more usable DHCP
    assigned IP address.

    That fact that a 3rd laptop works just fine (probably because it is
    properly configured) leads me to suspect that the problem is in the
    DSL-G624T and not in the laptops. Any chance you have more MAC
    addresses configured in the filter than you have DHCP assigned IP
    addresses available in the IP address pool?

    Are you using a RADIUS server for authentication? Probably not as
    you're using MAC filtering which is largely a waste of effort.
    However, if you are using a RADIUS server, any chance that it has some
    manner of authentication user limit?

    It's also possible that the router is configured to only allow a
    limited number of wireless connections, or some other form of
    misconfigured security.

    Can you plug the two laptops into the network using ethernet CAT5
    cables instead of wireless? If so, do they co-exist?

    There are some other obscure misconfigurations and combinations
    possible, but let's check the easy stuff first.
     
    Jeff Liebermann, Feb 12, 2007
    #17
  18. Alan

    John Navas Guest

    Maybe, but then error messages should pop up. Alan?
     
    John Navas, Feb 12, 2007
    #18
  19. Alan

    jpd Guest

    Begin <>
    I have, on occasion, noticed that it is possible for some cheap consumer
    excuses for routers like the one mentioned above to give out the same IP
    twice to two very different machines[1], for no apparent reason and with
    plenty of free addresses in the pool. Releasing and re-getting a lease
    fixed that particular problem. (eg on windows: ipconfig /renew)


    [snip: more possible causes of the problem]
    And gather more information, of course. :)


    [1] With at least OS, cpu, board chipset, and network card manufacturers
    being all different.
     
    jpd, Feb 12, 2007
    #19
  20. Alan

    John Navas Guest

    You do have to spell it out every single time, and do so precisely --
    stuff like "more often than not" is not helpful -- red X (no connection)
    and yellow exclamation mark (limited connection) cannot occur at the
    same time! It's either one or the other, and different problems have
    different symptoms, so I need to know the _exact_ symptoms.
    Again, not helpful -- I need to know the exact message.
    Sorry, I'm doing my best with the limited information you're providing.
     
    John Navas, Feb 12, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.