TYAN S2676 Thunder i7525, SMP and network

Discussion in 'Tyan' started by Przemek, Aug 10, 2005.

  1. Przemek

    Przemek Guest

    Hello

    I have to setup a linux system on a new computer with the (i7525) S2676
    motherboard and 2 Intel XEON's. I decided to setup Slackware 10.1. I
    have
    done it and everything was ok. But the default kernel 2.4.x have not got
    the
    multiprocessor (SMP) switch on. So I decided to build a new kernel with
    SMP.
    I have just switch on SMP (and Real Time Enhanced ... which is required
    but
    SMP). Now, when I run linux with the new SMP kernel I do not have access
    to
    the network. The controller is correctly detected (using tg3 or bcm5700
    driver) but I can't setup an internet connection. I can't get an IP from
    DHCP server. When I looked into dmesg I saw something like:
    eth0: NIC link is down
    I tried many different kernel configuration and asked many people, but
    noone
    could help me. I even build a 2.6.12.4 kernel but the problem is the
    same.
    Network runs on a non-SMP kernel very well, but don't want to run on a
    SMP-kernel!!!! It is the same with tg3 or bcm5700 drivers (in case of
    2.6
    kernel I have problems to compile bcm5700 drivers on 2.6.12 kernel. I
    get
    some error messages that I can't remember now).

    What is the reason? What can I do??? HELP :) Anybody could help me!?!

    Przemek
    zipi @ chello . pl
     
    Przemek, Aug 10, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.