Tyan Tiger MB S2460 rev 1.03 - Floppy error.

Discussion in 'Tyan' started by Simon, Nov 11, 2003.

  1. Simon

    Simon Guest

    Hi all,

    I have a Tyan Tiger mb S2460 rev 1.03, which refuses to recognise the floppy
    drive. After doing a bit of googling, it is apparent that it might be some
    sort of power problem to the floppy, so following the suggestion, I
    connected the floppy to a different power supply, but got the same response:

    ERROR

    02B0: Diskette drive error

    Well, I have the diskette primed/bootable with the 1.05 upgrade, but don't
    seem to be able to get any further. Out of desperation, I setup a bootable
    ZIP 100Mb cartridge, but the 1.03 bios doesn't recognise it. I have a hard
    disk inside which I primed up with Redhat Linux 7.2 on another system, does
    that give me any possibilities? What if I formatted a small HD with dos 6.2
    and dropped that in with the upgrade? Any ideas out there in tech land?

    All the best

    Simon from Oz. (I refuse to give up!!!)

    PS. I have shot off an email to Tyan tech, but no response yet.
     
    Simon, Nov 11, 2003
    #1
    1. Advertisements

  2. Simon

    Simon Guest

    Well, I seem to have answered part of my problem. I have ripped out another
    hard disk from another system running Windows 98. I copied all the bios
    upgrade to the disk (before taking it out!), then attached that to the Tyan
    system and rebooted in DOS mode without any drivers. Ran the upgrade from
    DOS, which worked ok. System now at 1.5 BIOS rev, but still no floppy
    access :(

    Simon
     
    Simon, Nov 11, 2003
    #2
    1. Advertisements

  3. Simon

    Ray Setzer Guest

    Check and see if your floppy cable is on the backwards.
     
    Ray Setzer, Nov 11, 2003
    #3
  4. Simon

    Paul Murphy Guest

    And also if you have a floppy cable suitable for 2 drives, make sure if this
    is the only floppy drive, that it connects at the end, not the middle.

    What pre-empted the "floppy failure" - was it working fine prior to any
    changes or is it newly set up?

    Paul
     
    Paul Murphy, Nov 11, 2003
    #4
  5. Simon

    Simon Guest

    No, the cable is on the correct way, and works for another of the systems I
    have here. The floppy unit is brand new, and I have tried another one.
    Here is the article I found on google.

    http://groups.google.com.au/groups?...3%24M21.6664265%40typhoon.nyroc.rr.com&rnum=1

    I have tried resetting the cmos several times with no luck.
     
    Simon, Nov 12, 2003
    #5
  6. Simon

    Paul Murphy Guest

    So it's a new build then (ie you've assembled the system from new components
    and its had a non working floppy from scratch)? If you've double checked ALL
    the floppy cable connections and the BIOS settings to make sure its enabled
    correctly (as a 1.4 MB drive - may not be the defaiult?) and you've also
    tested the floppy and cable in another machine, that only leaves the
    motherboard or PSU as a suspect.

    What made you suspect "it is apparent that it might be some sort of power
    problem to the floppy"?

    Paul
     
    Paul Murphy, Nov 12, 2003
    #6
  7. Simon

    Simon Guest

    The third post in the link I supplied in my last post alludes to this
    possibility.. Might have to try a newer casing & power supply, because they
    are the only 'old' bits in the build.

    Regards
    Simon
     
    Simon, Nov 13, 2003
    #7
  8. Simon

    Simon Guest

    Simon, Nov 13, 2003
    #8
  9. Simon

    Paul Murphy Guest

    Thanks for the link. That PSU stuff is certainly news to me. I've worked as
    a computer tech and never encountered that with other makes of boards, as
    for my S2460, the floppy worked fine from new with my "old" Enermax 431 Watt
    but I had the connector meltdown problem after about 9 months (ATX PSU
    Connector welded itself to the motherboard). That one I fixed with a new PSU
    of a better brand - Enhance 460 Watt, which was recommended to me by the
    Tyan reseller I bought the board from. The new combination has been working
    fine for over 2 years now with no hint of a recurrence (no burning
    appearance on connector and rock solid +5 Volt rail voltages). Shanes mod
    that the 2CPU link refers to would only be of benefit if using a PSU with a
    poor quality connection/connector plug - my machine is proof its not needed
    and its loaded up with cards. If you're going to get a new PSU this would be
    one to look out for when using with an S2460.

    Paul
     
    Paul Murphy, Nov 13, 2003
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.