UDMA CD-ROM compatability on legacy Via MVP3 based Tyan S1590

Discussion in 'Tyan' started by Phil Lee, Oct 23, 2003.

  1. Phil Lee

    Phil Lee Guest

    Faced issues upgrading components on a legacy VIA MVP3 chipset mobo
    (1). Installed a UDMA66 capable CD-ROM (2) and it will almost always
    hang when trying to install software from CD. Worked OK initially on a
    new install of Win98SE.

    Then installed VIA's 4in1 drivers updates (3) and the trouble started.
    Must do a hard reboot of the system. Initially tried the following in
    attempt to solve the conflict:

    1) Mobo BIOS Periph Setup changed so that UDMA is disabled and PIO to
    Mode4 instead of Auto. Device Mgr for CD-ROM and Disk drives changed
    UNcheck all options; DMA, Disconnect, Sync data transfer, and Auto
    insert notification. Exchanged with another known good, short 10"
    single port 80-pin high speed IDE cable, no change.

    2) WD 40GB hard drive's UDMA100 interface downgraded to UDMA33 (4).

    As a workaround, I can put software on another computer's HD and
    transfer it to the local HD with the LAN. Installs SW fine this way,
    but it's an obvious pain. So the hardware concerning the HD is fine.
    Plays music CDs fine.

    This issue appears to be a compatiblilty issue of the Bus Mastering
    DMA EIDE controller driver on the secondary port, probably related to
    the VIA Southbridge chip. VIA docs claim that chipset has a good
    UDMA33 controller, although FIC says only the 586B works right.

    Working to a solution took several steps, due in part to the lack of
    clear organization of VIA's and Tyan's websites on legacy products.
    Then found additional clues on other NG posts, especially by Robert
    Akins (5):

    A) De-installed the VIA 4in1 ATAPI driver update. Use the OEM
    Microsoft Win98SE VIA Bus Mastering driver (vmm32.vxd (configmg.vxd)).
    Only works on small installs; still hangs on large installs, eg Office
    Suite.

    B) Installed an updated VIA Bus Master IDE PCI driver v3.01.04 . The
    driver download is hidden in VIA's web site. It is in the IDE FAQ
    area. It is incongruously labelled for solving ZIP drive issues. The
    driver's Installer banner says EIDE (Ultra), and the download file is
    currently IDE_MPD3014.zip . The driver set (incl NT, 2K, XP) also
    contains a good IDE Tool to setup the fastest mode supported for each
    device. The chosen setups are enabled when using the File | Commit Chg
    command. Also remember to make sure your mobo BIOS IDE setups are
    appropriate; all "Auto" and UDMA is enabled.

    The pertinent files installed in Win98SE\System\Iosubsys\ are:

    Viaide.vxd v4.0.950.205
    Viadsk.mpd v2.0.950.3014

    My HD in Device Mgr changed from a "Generic Drive Type 47" to "WDC
    WD40 0BB-00DEA0". The IDETool verified that the driver was manually
    set to "Ultra-DMA Mode 1 (ATA 33)" for both the HD and CD-ROM drive
    (6). It was set this way because the 586B Southbridge chipset can only
    support up to UDMA33 speeds; although the HD and CD-ROM itself are
    rated higher to UDMA100 and UDMA66 max, respectively. The IDETool also
    included an Enhancement tab which enables a 4MB cache out of main
    memory. After this CD-ROM hanging became sporatic.

    C) Finally I installed the latest (8/18/03) VIA EIDE drivers,
    Via_Ide_MPD_V320b.zip . The Release Notes for the driver say that it
    is for the 686A and up Southbridge chips, but it also appears to work
    for MVP3's 586B too (error in Apollo MVP3 listing in Via Chipsets
    listing). The install also included the IDETool v1.0.

    Changes are:
    Viadsk.vxd n/a 12,876B 6/19/03
    Viadsk.mpd v2.0.950.3020 67,633B 6/19/03

    The even less sporatic hanging issues can now be circumvented, using a
    Ctrl+Alt+Del plus EndTask which logically disconnects the CD-ROM.
    Could recommend going to this latest EIDE driver right off; seems like
    VIA has been working on this issue for a long time (my 586B is d/c 98
    = 5 yrs; probably fixed in MVP4 chipset, with its 686 southbridge).

    Best of luck on your configuration issues, the latest driver is still
    not perfect for the MVP3 Southbridge chip. Please post any of your
    trials on this thread and email me directly.

    Moral of the story is DON'T use the general VIA 4in1 driver update for
    ATAPI EIDE for the Super Socket 7 mobos that have the VIA Apollo MVP3
    chipset when using the newer UDMA devices on the secondary port,
    including the popular FIC VA-503+ mobo.


    Regards, Phil

    -----------

    1. Tyan S1590 Super Socket 7 Trinity 100AT has a VIA VT82C586B rel
    S7-SB southbridge chip (UDMA33) with AMD K6-III/400MHz, 384MB PC-100
    SDRAM, Western Digital 40GB WD400BB HD. Using high speed 18" 80pin IDE
    ribbon cables to HD (primary master) and CD-ROM (2ndary master). Mobo
    BIOS v1.16c (last) 3/18/99, which enables K6-III, ATAPI ZIP boot, and
    large 32GB hard drives. Vcore is 2.4v (as marked on CPU). Not
    overclocked and CPU temp is about 45C.

    Other HW probably not involved: Iomega Zip 100 ATAPI drive 2ndary
    slave; ATI Xpert 2K Pro AGP (Rage Pro 128 chipset) with
    W98r1284126277.exe drivers for VIA chipset AGP; Compaq/Adaptec 2940UW
    PCI SCSI, Plextor PX-R820T 8/20 CD-R 50-pin SCSI; Connor CTT8000-S
    TR-4 4/8GB 50-pin SCSI tape drive; Soundblaster 16 ISA PnP (CT2970);
    Asante EtherPac 2000+ PnP ISA combo NIC; enabled integrated USB. Used
    ISA devices so that there are no PnP IRQ conflicts, especially since
    using Adaptec SCSI. Installed in a 6 bay full tower case with a Star
    250w AT power supply. Saving last IRQ9 for a PCI video card for dual
    monitor.

    2. I/O Magic / Hi-Val 52X CD-ROM, UltraDMA66 interface, RegID =
    CMD5X11, fw v1.06, OEM BestMax D3340, D/C 03/02.

    3. VIA_4in1_443v.zip , Via chipset v4.43 drivers (9/02) for ATAPI bus
    mastering, AGP, IRQ routing, and INF updates. Vatapi.vxd v2.0.950.120

    4. Western Digital utility, UDMA Mgr setup, dlgudma10.exe , chg from
    UDMA100 (default) to UDMA33.

    5. Robert Akins (rsakins at gte.net), Sj: VA503++, ATA-100 drives,
    JE4333 BIOS, alt.comp.perphs.mainboard.fic , 2001-10-26

    6. The IDETool also listed 3 settings for ATA-33, including Mode 0 and
    2. I found best compatiblity with the CD-ROM using Mode 1, and could
    not reset the driver to Mode 0.
     
    Phil Lee, Oct 23, 2003
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.