1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

UK TIP layout during startup and US TIP layout during normal use

Discussion in 'Tablet PC' started by stan, Jul 27, 2005.

  1. stan

    stan Guest

    When I startup the Tablet PC edition 2005 I get the UK keyboard layout due
    to an install mistake I made by specifying UK rathar than US. Within Windows
    I have been able to correct this with language settings and specifying a US
    keyboard. However when I type Ctrl-alt-del or when I restart I get again the
    UK layout. Where can I fix this?
     
    stan, Jul 27, 2005
    #1
    1. Advertisements

  2. Make sure you change both the keyboard language AND layout. They are
    independent settings. Do it when logged in at the machine Administrator -
    some settings require that rather than being a member of Admin group.
     
    Mike Williams, Jul 28, 2005
    #2
    1. Advertisements

  3. stan

    Peter R Cook Guest

    Stan

    Make a quick check in the registry. I think the registry key that
    controls the keyboard layout is

    HKEY_USERS\XXXXXXX\Control Panel\International\locale

    where XXXXXXX is the identity of the user. There is one key for each
    user identity on the system.

    It sounds as if the .DEFAULT user (which Windows seems to use before
    anyone logs in) has its locale set to 00000809 which is the UK keyboard
    layout.

    Compare this with your own user whose locale is probably set to
    00000409 which is the US code.

    I have no idea how to change the .DEFAULT user settings other than by
    editing the registry. I have done so in the past to change the
    appearance of the desktop during startup.

    YOU DO THIS AT YOUR OWN RISK - as always.

    Regards
     
    Peter R Cook, Jul 28, 2005
    #3
  4. stan

    Stan Smits Guest

    Peter,

    Many thanks. Your registry edit solved the problem!

    Regards, Stan
     
    Stan Smits, Jul 29, 2005
    #4
  5. I think this is done by being logged on as machine Administrator as
    suggested in my post.
     
    Mike Williams, Aug 4, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.