1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Ultra 2 woes (tried to replace NVRAM, now won't boot)

Discussion in 'Sun Hardware' started by christopher.tidy, Jan 18, 2006.

  1. Hi all,

    I just thought I'd post a message here before I buy a new motherboard
    for my Sun Ultra 2. I've already asked this question at
    comp.unix.solaris, but I thought that perhaps different people read
    this group.

    A few weeks ago my Ultra 2's clock started losing time. I reset it a
    few times. Sometimes it kept time while the machine was switched off,
    but other times it didn't. After searching the web and asking a
    question at comp.unix.solaris, I bought a new NVRAM chip from
    www.farnell.co.uk. The new chip is from the same manufacturer and
    carries the same model number as the original. After I fitted the chip
    I couldn't get any output on the monitor, but I now suspect this could
    have been due to a loose chip or monitor cable. I made quite sure I
    inserted the chip the correct way round. After exchanging the chips
    again I got an output on the monitor, but couldn't get the machine to
    boot. Now it won't boot with either the new or old chip. I get the
    message "Can't open deblocker package" if I try to boot from disk, or
    "Can't open boot device" if I try to boot from CD-Rom. There are no
    sounds indicating that the machine is attempting to read from the disk
    or CD-Rom, but I have heard some extremely faint beeps from the
    speaker. I'm not sure if the beeps mean anything. I wondered if perhaps
    the PROM had got corrupted, but I can't easily flash it because I can't
    boot from CD-Rom.

    Anyone got an idea what might be wrong? I've tried a different power
    supply and I'm starting to suspect the motherboard, but I wouldn't want
    to replace it unnecessarily.

    Any suggestions would be much appreciated.

    Best wishes,

    Chris Tidy
     
    christopher.tidy, Jan 18, 2006
    #1
    1. Advertisements

  2. christopher.tidy

    CJT Guest

    I think I read an earlier thread that indicated you had already tried
    Stop-N; if not, that would be worth a try.

    I guess it might also be worth trying a net boot before giving up.
    If you could do that, you might be able to do some additional diagnosis.

    The weird thing to me is that error sounds like an OBP problem rather
    than a problem with the NVRAM ; as I recall, there's a backup copy of
    the OBP on the Ultra 2 -- perhaps you could try that?
     
    CJT, Jan 18, 2006
    #2
    1. Advertisements

  3. Thanks for the suggestion. I've already tried <Stop-N>. Do you know
    where I can find literature about using the backup copy of the OBP?

    I just tried running "probe-scsi-all" at the "ok" prompt
    systematically. The results are really making me concerned about the
    motherboard. It's behaving quite erratically. First time I got this:

    /[email protected],0/SUNW,[email protected],8800000

    Target 0
    Target 1
    Target 2

    unexpected message in 13

    Next time target 2 was replaced by target 6, the unexpected message bit
    was gone and the machine hung, and the third time it didn't find any
    devices at all. The fourth time it did the same as the first. There
    should actually be targets 0,1,2,5 and 6 on this controller, and they
    all have unique IDs. My SBus SCSI controller performs consistently.

    Best wishes,

    Chris
     
    christopher.tidy, Jan 18, 2006
    #3
  4. christopher.tidy

    Invalid Guest

    Try checking scsi cable and terminator. Is system stable when disk and
    cd-rom are disconnected? How about with disk only? And cd-rom only?

    Does net boot function?
    Does test-all print any clues?
    Does enabling diag mode show any post failures?
     
    Invalid, Jan 18, 2006
    #4
  5. christopher.tidy

    CJT Guest

    docs.sun.com

    If you have trouble finding it, let me know and I'll dig through
    my stack of papers and see if I can find the doc name/number. It
    involves changing a jumper on the motherboard (which might help you
    construct a search to find the doc, BTW).
     
    CJT, Jan 18, 2006
    #5
  6. christopher.tidy

    CJT Guest

    CJT, Jan 18, 2006
    #6
  7. I checked all the cables and removed the external devices. I put a
    terminator on the back of the machine. The output of "probe-scsi-all"
    is still erratic. Sometimes it shows nothing, and other times it shows
    the devices, but just as "Target 0", "Target 1" etc., then hangs. It
    seems to do these alternately. Removing the CD-Rom just removes it from
    the list of devices found. The behaviour is a bit like what happened
    when I put a differential SCSI terminator on the back once and it hung
    the SCSI bus. But I've checked the cables and it's been working fine
    with these devices for over a year.

    "test-all" gives the following message for the SCSI controller. It
    isn't explicitly a failure message. I'm not sure what it means:

    /[email protected],0/SUNW,[email protected],8800000
    CE DMA fill from address ffeea000 for 80 bytes

    Thanks for the help,

    Chris
     
    christopher.tidy, Jan 18, 2006
    #7
  8. christopher.tidy

    Invalid Guest

    Also check the internal scsi cables and try removing (then later
    reattaching) the internal devices too. If there's a sbus scsi card,
    remove that too.
     
    Invalid, Jan 18, 2006
    #8
  9. Tried all that now - no luck!

    Will continue sometime tomorrow...

    Chris
     
    christopher.tidy, Jan 18, 2006
    #9
  10. christopher.tidy

    Invalid Guest

    In the thread you posted on comp.unix.solaris, you mentioned
    probe-scsi-all still doesn't respond correctly with the hard drive
    connected to the controller. The next steps I would suggest are to see
    if probe-scsi-all responds correctly with nothing connected, then see if
    the response is correct with only the cd-rom drive connected.

    As already suggested, it's best to try and isolate the problem by
    testing with a as few components as possible. Namely, remove as much
    hardware as possible.

    The symptoms, aside from the NVram issues, appear to be trouble with
    scsi controller, cable, terminator, or device (it can be any device and
    the hard drive is one suspect). One bad device can affect the entire
    scsi bus.
     
    Invalid, Jan 18, 2006
    #10
  11. I removed all the SCSI devices except the CD-Rom in an attempt to
    isolate the problem, but now the machine appears to have died
    completely. No output on the monitor, and no exchange of graphics
    cards, hard drives or power supplies will resurrect it.

    I could try connecting to the serial port or flashing the PROM over the
    network, but this involves borrowing my father's PC. I might not be
    able to do this, and I also wouldn't want to do anything which could
    mess up his system. The U2 seems to be getting steadily worse so I'm
    inclined to think flashing the PROM won't fix it.

    Looks like I have a few options. Get a second hand U2 motherboard,
    although I'd probably get better value buying a whole U2 for spares.
    Get an Ultra 60 and populate it with the components from my Ultra 2
    (I've always fancied one, and I need SCSI). Or build a PC with SCSI,
    some variant of UNIX and possibly Windoze too. My immediate inclination
    is to buy another U2 for spares. Any thoughts?

    Best wishes,

    Chris
     
    christopher.tidy, Jan 18, 2006
    #11
  12. More complications...

    Turns out it was taking an extremely long time to do POST and
    eventually returned with the error "Power On Self Test Failed. Cause:
    SysIO U1001". I'm not sure what to think now, but I've included more
    details in my post at comp.unix.solaris.

    Best wishes,

    Chris
     
    christopher.tidy, Jan 19, 2006
    #12
  13. christopher.tidy

    Andrew Tyson Guest

    haven't fired up my U2 in a long time, but isn't that a problem with one
    of the DIMMs?
     
    Andrew Tyson, Jan 22, 2006
    #13
  14. I don't think so. Or at least U1001 isn't a DIMM - it's a large, square
    IC on the motherboard. I've removed most of the memory and it doesn't
    seem to cure the problem.

    Best wishes,

    Chris
     
    christopher.tidy, Jan 22, 2006
    #14
  15. christopher.tidy

    anonymous Guest

    It doesn't look good. There's more information about the SysIO ASIC in the Ultra 2 service manual appendix C. It's downloadable from the related documentation section for the Ultra 2 in the system handbook at sunsolve.sun.com

    The U1001 chip probably failed. It's connected to both CPUs in the block diagram, so if by chance the error was induced by a faulty CPU (rather than U1001), you could try running the Ultra 2 on 1 CPU, and maybe try swapping that CPU, to see if the error goes away... Good Luck.
     
    anonymous, Jan 22, 2006
    #15
  16. I've tried running on one CPU already. It didn't work, but thanks for
    the suggestion. Time to get a new motherboard/machine I think. I now
    wish I'd saved that manual to CD rather than on my hard drive! Now that
    Sun charge for support I can't download it any more :-(.

    Chris
     
    christopher.tidy, Jan 23, 2006
    #16
  17. There is sunshack.org for such predicaments..
     
    [email protected], Jan 23, 2006
    #17
  18. christopher.tidy

    anonymous Guest

    Yes you can... The Ultra 2 service manual is
    downloadable from the related documentation section for the Ultra 2 in
    the system handbook at sunsolve.sun.com (public access).
     
    anonymous, Jan 23, 2006
    #18
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.