Unable to automount NTFS volume or read UTF-8 filenames

Discussion in 'Apple' started by Guest, Mar 26, 2005.

  1. Guest

    Guest Guest

    I recently tried mounting my first NTFS FireWire drive under OS X, and
    have been less than thrilled with the results. Two problems have come
    up, the second one being more critical:

    1. The single volume on the 160 GB drive does not automatically mount
    on my desktop when I plug in the drive. Disk Utility sees the
    volume, although it only identifies it by its device name (e.g.
    "disk3s1"), and refuses to mount it. I can get around this problem
    with "mount -r -t ntfs /dev/disk3s1 /Volumes/NTFS_Volume" to
    manually mount it on /Volumes/NTFS_Volume. (Restarting the Finder
    seems necessary to get it to pick up on the new volume.) But it
    bothers me that friends seem able to automatically mount their NTFS
    volumes without any problems. Makes me wonder if this drive might
    be set up a little strangely. (It was originally formatted under
    either Windows 2000 or Windows XP.)

    2. After mounting the volume, UTF-8 (Unicode) filenames aren't
    displaying correctly. It appears that the default translation is
    for ISO 8859-1 (Latin-1). I'm quite certain that the Windows system
    that created this volume to begin with was using Unicode. For
    example, a file named "Leo_Jardim_Botânico.jpg" shows up in "ls" this
    way in a Terminal.app window that's using UTF-8 character display:

    $ ls -B Leo_*
    Leo_Jardim_Bot\342nico.jpg

    Octal 0342 is 0xE2, or "â" ("a" with a circumflex, if you're doing
    ASCII-only) in ISO 8859-1. But it wouldn't be a proper UTF-8
    sequence the way the Finder wants it. In fact, if I open up the
    containing folder in the Finder, here's what the same filename
    appears as:

    Leo_Jardim_Bot?

    That's not a substitution for a non-printable character. It's a
    literal question mark. And it's the last character in the filename.
    And no application can open it that way.

    I'd be okay with manual mounting, as I've never needed to work with an
    NTFS disk before. But the Unicode filename thing is a show-stopper for
    me. The mount_ntfs command has a "-W" option which, according to the
    manual page, might fix the problem. But instead of explaining how to
    use the arguments to -W, it simply refers the reader to the man page for
    mount_msdosfs(8), which doesn't exist.

    Any suggestions? I'd rather not have to re-attach this hard drive to a
    Windows box and zip the files -- I already feel so dirty... :)
     
    Guest, Mar 26, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.