Update from 10.9.2 to 10.9.3 stopped my Time Machine backups from working

Discussion in 'Apple' started by Mirsky, May 16, 2014.

  1. Mirsky

    Mirsky Guest

    Hi. Just now I upgraded my Mac from 10.9.2 to 10.9.3.

    I also use Time Machine to back up my Mac to an external drive and I've
    been using it for years.

    One result of the update from 10.9.2 to 10.9.3 is that I'm now unable
    to back up to my Time Machine drive. I successfully backed up to it
    earlier this afternoon at 3:17PM (it's now 4:32PM), but I'm now getting
    this error message:


    "Time Machine couldn't complete the backup to 'Time Machine Backup.'

    Files can't be copied onto the backup disk because it is read-only. You
    may need to repair or erase the disk using Disk Utility. If the disk
    can't be repaired, select a different disk for backups.

    Last successful backup: Today, 3:17PM"

    I shut down my Mac and restarted it, thinking maybe the error would go
    away, but it hasn't.

    Did 10.9.3 somehow make my Time Machine backup drive read-only? Is
    there a way to change it back so that it also has write permissions? I
    can't figure out how to do it. Or am I going to have to erase the drive?

    Thanks.

    M
     
    Mirsky, May 16, 2014
    #1
    1. Advertisements

  2. Mirsky

    Chris Schram Guest

    I have not found the time or bandwidth to get the OS X update but...

    I've had that same Time machine problem a couple of times in the past.
    It may be just a coincidence you experienced the problem just after the
    update. Erasing the disk was the only fix that worked for me.
     
    Chris Schram, May 16, 2014
    #2
    1. Advertisements

  3. Mirsky

    David Empson Guest

    It isn't a general issue with 10.9.3: I've just gone from 10.9.2 and
    10.9.3 and have successfully done the first subsequent Time Machine
    backup.

    Something may have gone wrong with your backup drive.

    Have a look in Console at system.log to see if there are any relevant
    messages there which might provide more details. Find "backupd" for
    messages relating to Time Machine, and also look at messages around the
    time the drive was mounted.

    I'd also suggest having a look at what Disk Utility reports for the
    status of the drive to see if anything there looks out of the ordinary.
     
    David Empson, May 16, 2014
    #3
  4. Mirsky

    David Ritz Guest

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    You should be able to determine whether the drive is, indeed, read
    only, from the Finder. Select the volume icon in Finder. If it's not
    displayed on the Desktop, open a Finder window, locate the volume icon
    and select it. Use Get Info from the File menu or by using ⌘I.
    Permissions for the volume should be displayed. Various users, and
    their permissions, should be displayed. If necessary, they can be
    edited. If edited, you may want to use the "Apply to enclosed items"
    option, from the settings (sprocket) menu.

    This is where I would begin the troubleshooting process..

    - --
    David Ritz <>
    Be kind to animals; kiss a shark.

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.22 (Darwin)

    iEYEARECAAYFAlN2N0QACgkQUrwpmRoS3uskIACfQm+ogFmLc9WxD/atuc/z50xD
    MgsAnR8HF1Bxtg8h9qbJgJ/cV7Iy9g9N
    =j2gB
    -----END PGP SIGNATURE-----
     
    David Ritz, May 16, 2014
    #4
  5. Mirsky

    Paul Sture Guest

    This is a long shot and I can't remember which update it happened with,
    but at either the tail end of Mountain Lion or early on with Mavericks, TM
    backup started to give "searching for backup volume" messages, and then
    one day couldn't see it.

    I resolved that problem by moving the cable from the USB hub to a port
    on my Mac mini, and haven't seen the problem since.
     
    Paul Sture, May 16, 2014
    #5
  6. Mirsky

    Alan Browne Guest

    No issues here.
    (OTOH, just because they're "happening" doesn't mean they're "working").

    What does "Get Info" on the drive say about permissions?

    Are you Steve "Antigravity" Mirsky?
     
    Alan Browne, May 17, 2014
    #6
  7. Mirsky

    Mirsky Guest

    Thanks everyone for the responses.

    I ran Disk Utility and Disk Warror and they both gave errors, so I
    erased the disk and the errors are gone.

    But I had to start Time Machine from scratch (it's taking about 24
    hours to finish the first back up).

    Next time I upgrade my system software I'll disconnect my external hard
    drives first.
     
    Mirsky, May 17, 2014
    #7
  8. Mirsky

    Mirsky Guest

    Is he the science writer? I'm not him, but we are probably related somehow.
     
    Mirsky, May 17, 2014
    #8
  9. It's not related directly to the upgrade. Apple's filesystem has
    corruption issues that commonly appear in Time Machine's complex tangle
    of hardlinks. Certain triggers, like system upgrades, will force a
    verification to see if the volume has become corrupted. The actual
    corruption may have happened some time ago.
     
    Kevin McMurtrie, May 17, 2014
    #9
  10. Mirsky

    Alan Browne Guest

    Fun writer.
     
    Alan Browne, May 17, 2014
    #10
  11. Mirsky

    Fred Moore Guest

    Which is why it's IMPERATIVE that you try a test recovery of a few
    documents every now and then. Make sure they are ones which have in fact
    been changed between when they were backed up and the current version. I
    have seen too many instances of Time Machine appearing to do its job,
    only for it to bork when you try to resurrect an earlier document.
     
    Fred Moore, May 19, 2014
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.