1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Upgraded to AMD XP processor, now windows slower!

Discussion in 'AMD Thunderbird' started by dbd, Dec 9, 2003.

  1. dbd

    dbd Guest

    Hi,
    I have an Abit Kt7a mobo and just upgraded my 1.33 GHz processor to a
    1800XP (happily running at 2GHz). The strang thing is that in Windows
    (2000 Pro) when I ran the UT2k3 benchmark the FPS dropped by 5,
    instead of going up because I now have a faster proccessor.
    Currently windows sees it as an unknown proccessor (but maybe because
    my mobo don't officially support it, but the abit newsgroup ppl say it
    shoud be ok).
    Do you think I need to re-install windows, or is something strange
    going on.
    Also, I would run tests in Linux, but I can't remember my old results,
    so can't compare. (It says 3984 bogomips if that helps.)

    thanks

    dbd
     
    dbd, Dec 9, 2003
    #1
    1. Advertisements

  2. dbd

    IC Guest

    What video card are you using? It may be the card was running as fast
    as possible with the other CPU and a faster one won't necessarily give
    you more FPS.
     
    IC, Dec 9, 2003
    #2
    1. Advertisements

  3. dbd

    Edster Guest

    I also run a 1800+ @ 2Ghz on a KT7-Raid with Win2K Pro and everything runs
    faster on the system regardless if the BIOS says unknown processor type!
    Perhaps something has changed or has degraded on the OS itself!
     
    Edster, Dec 9, 2003
    #3
  4. dbd

    dbd Guest

    An Nivida GeForce 4 Ti4200 128MB, but the fps went from 35 down to 30,
    and I
    expect at least 45-50 with this new processor.
    Also, windows says it is an unknow processor (not just the bios saying
    that) when I right click on my computer. Is that normal?
     
    dbd, Dec 10, 2003
    #4
  5. dbd

    IC Guest

    That's normal. Since the BIOS doesn't have the exact model stored, it
    says "unkown" CPU. It's not important. All that's important is that
    the CPU is running at the speed you want.

    Now, to the video card. The TI 4200 is an "older" card on the same
    scale as the ATI R8500 and they are DX8 cards; not DX9 capable. I'm not
    surprised there's little difference with a faster CPU.
    Why the 5 FPS difference? Got me. Maybe try re-installing the drivers
    (or updating them) and/or reinstall Wondows. It's not hardware related
    (except for the limitation of the video card).
     
    IC, Dec 10, 2003
    #5
  6. dbd

    Wes Newell Guest

    I'm not a windows person, but I'm pretty sure you have to let windows know
    about the cpu change. You went from a cpu that doesn't support SSE to one
    that does. You might be able to do a repair install, like with WinXP, or
    maybe with 2000 you do it some other way. Check system properties or
    reinstall.
     
    Wes Newell, Dec 10, 2003
    #6
  7. dbd

    - HAL9000 Guest

    Did the bios reset itself, or require you to reset it, when you
    switched cpus? If so is it possible that one of the bios settings has
    changed?

    Forrest

    Motherboard Help By HAL web site:
    http://home.comcast.net/~hal-9000/
     
    - HAL9000, Dec 11, 2003
    #7
  8. dbd

    Locutus Guest

     
    Locutus, Dec 11, 2003
    #8
  9. dbd

    Locutus Guest

    i had the same problems as you
    when i went from a tbird to an xp
    read this and the link




    When upgrading an existing system with a new Duron (Morgan) or Athlon XP (Palomino) processor, 2 changes need to be made.
    1 - Upgrade the BIOS to fully support all the new capabilities of the new processor including SSE instructions

    2 - Reload the Operating System to properly recognize that the processor is now capable of supporting SSE

    This procedure applies to Win95/98, WinME, Win2000, WinNT, WinXP

    Changing processor from AMD Athlon(T-Bird)/Duron to AMD Palomino/Morgan (or vice-versa).




    http://www.duxcw.com/dcforum/DCForumID5/534.html
     
    Locutus, Dec 11, 2003
    #9
  10. dbd

    dbd Guest

    I'm pritty sire I got the latest bios, but my mobo don't official
    support the XP processors, but then again, ppl say it works fine in
    almost every set up.
    Yep, reinstalled windows, same problem.
     
    dbd, Dec 11, 2003
    #10
  11. dbd

    dbd Guest

    Reinstalled, same problem.
     
    dbd, Dec 11, 2003
    #11
  12. dbd

    dbd Guest

    What about windows saying unknown?
    Also, direct X says unknown, 3dnow, sse, ~1.8GHz (I've nocked it back
    down to default clock speed).
    Yeah, but UT2k3 is a directX 8 game, so having a directX 8 card
    (admittedly one of the slower ones) shouldn't bottle neck it that
    much, and a faster CPU should not slow it down.
     
    dbd, Dec 11, 2003
    #12
  13. dbd

    dbd Guest

    Sorry to post again (stupid 8 hour google groups delay) but what bios
    should I be running. I have a Kt7a 1.2 mobo, but will the 1.3 bios
    work (with proper XP processor support)?
     
    dbd, Dec 11, 2003
    #13
  14. dbd

    Wes Newell Guest

    A9 is the latest bios for pre 1.3 KT7A's. I've heard that you can use the
    1.3 bios's from someone, but do so at your own risk. Yopu might end up
    with a dead board.
     
    Wes Newell, Dec 11, 2003
    #14
  15. dbd

    SilverBack Guest

    I've seen this before.
    The problem is that the XP cpu uses SSE instructions.
    When you originally installed your operating system SSE wasn't used. AMD's
    own 3DNow was.
    You wouldn't think that this would make a difference in performance in a
    system already installed but it does.
    I had a similar problem when I moved to a 1700+ some months ago.
    If you redo your system ( fdisk, repartition and reformat) you'll notice
    something right away.
    The SSE will be used for the install and the time to install the OS will go
    down by almost half.
    Standard install using 3DNow is about 35 minutes.
    Using SSE it's about 17.

    How does the above effect your fps in games? I have no idea, although I
    have witnessed it and I know it does happen.
    SB
     
    SilverBack, Dec 12, 2003
    #15
  16. dbd

    Skid Guest

    There is absolutely no reason to take the risk. A9 works fine with the XP.
    I'm not sure what the OP's problem is, but it won't be solved by a bios
    flash.

    It might be solved by a bios setting, however. Flashing often sets
    everything back to less-than-optimal defaults.

    See http://www.sudhian.com/showfaqs.cfm?fid=2 and www.rojakpot.com for bios
    tweaking tips.
     
    Skid, Dec 12, 2003
    #16
  17. dbd

    dbd Guest

    I have reinstalled windows, and reformatted my C partition, and that
    didn't help.
    I don't see how completely repartitioning my hard disk will help,
    surely it is the OS that has all the SSE instructions stuff?
    Also dxdiag says the processor is Unknonw, SSE, 3dnow, ~1.8GHz
    That says to me that the SSE stuff is cool, just the unknown thing is
    v strange.
    I think that the chip is unlocked (got off ebay, I think it had pencil
    marks on it), but that's odd too because it's a T-bred B, and all old
    (and it's old enough) T-bred Bs come at least kinda unlocked I
    thought.
    Cheers for the reply anyway, just seems strange.
     
    dbd, Dec 12, 2003
    #17
  18. dbd

    SilverBack Guest

    Does the Kt7a have a newer BIOS to flash?
    That would at least identify your cpu correctly.
     
    SilverBack, Dec 12, 2003
    #18
  19. dbd

    chuck Guest

    Sorry for the top post, but it's real simple to fix, just save anything you
    need to cd of a second hard drive, then do an fdisk and reinstall windows
     
    chuck, Dec 13, 2003
    #19
  20. dbd

    dbd Guest

     
    dbd, Dec 14, 2003
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.