USB ports not working w/ Asus P5AD2 premium

Discussion in 'Asus' started by Wes, Dec 5, 2004.

  1. Wes

    Wes Guest

    I have the following: P5AD2 premium motherboard w/Intel Pentium4 3.2
    ghz running Windows XP Home Editon SP2. No matter what I've tried I
    can't get the USB ports to work. I have done the updating drivers bit
    in device manager and it says it could not find a better driver than
    what I have. I did this on all of my USB host controllers and USB root
    hub. I have five of each.
    The host controllers are Intel(R) 82801FB/FBM USB Universal Host
    Controller
    2658, 2659, 265A, 265B and the last one says USB2 Universal Host
    Controller - 265C. All seem to be working fine. The BIOS has USB 2.0
    controller enabled. It seems I've tried everything, but obviously I
    haven't. I even sent the board back and was told there wasn't a
    problem detected. Any ideas? Any sure way to tell that the ports are
    getting any power to them? I've tried an optical mouse and a flashcard
    reader and neither lights up at all. Windows doesn't detect either of
    them. Please help, I'm desparate. Everything works great except for
    the USBs. I would love to hear from someone who has this mobo and has
    the usb ports working. Thanks.
     
    Wes, Dec 5, 2004
    #1
    1. Advertisements

  2. Wes

    andyw Guest

    Hi,

    I had the same problems and found that uninstalling Service pack 2
    pretty much solved everything.

    HTH.

    Andy.
     
    andyw, Dec 6, 2004
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.