User root access denied (Panther Server)

Discussion in 'Apple' started by miniapple, Oct 12, 2005.

  1. miniapple

    miniapple Guest

    I tried to login to FTP of MacOSX Panther Server by root.
    However, it has been as follows.

    USER rootUser root access denied
    Although I deleted root of /etc/ftpusers, login by root is not
    permitted too.
    How can I login by root?
    Please help me!

    * posted via http://www.mymac.ws
    * please report abuse to http://xinbox.com/mymac
     
    miniapple, Oct 12, 2005
    #1
    1. Advertisements

  2. miniapple

    clvrmnky Guest

    "root" is disabled by default on OS X. You are encouraged to use
    "sudo", and discouraged from passing root's password in the clear over ftp.

    If you really want to enable the root account, search for "enable root"
    on Apple support.
     
    clvrmnky, Oct 12, 2005
    #2
    1. Advertisements

  3. miniapple

    miniapple Guest

    "root" is disabled by default on OS X. You are encouraged to use
    Thank you for advice.

    But, on Mac OS X Server, the root user is enabled by default.
    I just want to FTP server by "root".
    I found settig files in "/Library/FTPServer/Configuration".
    What should I do with a setup? Please give me advice.
    :(

    * posted via http://www.mymac.ws
    * please report abuse to http://xinbox.com/mymac
     
    miniapple, Oct 13, 2005
    #3
  4. miniapple

    clvrmnky Guest

    Oops. Didn't see the Server part. Obviously, restricting root from ftp
    by default is a good security move. I will reiterate that allowing root
    to login remotely is a bad habit. Use or create a user that does what
    you need it to, and use sftp.

    This sounds like an advance setting. Search for "ftp root" in Apple
    Support. There is an article that talks about the fancy GUI settings
    for ftpd on OS X Server, and refers to "serveradmin" from the
    command-line. I'm sure it's in there somewhere.

    You are going to have to do some homework.
     
    clvrmnky, Oct 13, 2005
    #4
  5. Usually, with ftp, root access is denied by default. Removing the user
    root from the file /etc/ftpusers usually allows ftp to access root. But
    you're going to use sftp and do all this securely, right?
     
    Michael Vilain, Oct 13, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.