1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Using laptop HD on desktop, no power felt.

Discussion in 'PC Hardware' started by XYLOPHONE, Jul 16, 2009.

  1. XYLOPHONE

    Rod Speed Guest

    Nope, you just put in a replacement drive with the recovery partition on it.

    And thats completely trivial to do if you did a full image of the physical drive before
    it died. You just put that back on the replacement drive in a desktop system etc.

    Not a shred of rocket science whatever required.
    Wrong. I've done that repeatedly.
    No need if its a decent brand of laptop that got a lot of battery
    support and which uses the same battery in a lot of its models.

    Just did it with a Compaq.
     
    Rod Speed, Jul 18, 2009
    #21
    1. Advertisements

  2. XYLOPHONE

    Trent Guest

    Wasn't commenting on the OP problem, just your assertion. If #reset is
    being asserted due to a faulty PATA interface, the drive will not spin up.
     
    Trent, Jul 20, 2009
    #22
    1. Advertisements

  3. XYLOPHONE

    Fred Guest

    Trent wrote
    More fool you. I was clearly commenting on the OP's situation.
    Wrong, as always.

    If the PC controller is completely dead, it wont be asserting #reset, stupid.
     
    Fred, Jul 20, 2009
    #23
  4. XYLOPHONE

    XYLOPHONE Guest

    Hello,

    Here are even more details on my issue, and other experiments I did.

    LAPTOP HD ON PC W/ADAPTOR:
    - I have tried removing the data cable, and leaving only the power on.
    Still no spin or motor sound or even vibrations (My ears are good, can
    make difference between music on vinyl and CD). Furthermore, the
    desktop BIOS detects no IDE drive. I borrow the cable end from the HD
    which is normally in that PC.

    ON THE LAPTOP:
    - The laptop is a Compaq EVO N800c (Series PP2130 written on back)
    using Pentium 4.
    - The key sequence is CTRL-F10 (I think, because I quickly press many
    keys), and when the BIOS is supposed to arrive, a small blue box
    appears asking for a password. It gives 3 chances and everything
    freezes on 3rd fail.
    - There is 1 drive slot, I tried sliding both a Floppy and DVD drive.
    In all cases, no boot, but the drive whirr once (floppy) or the CD in
    drive spins up to full speed for a while, then slows down to low speed
    and finally stops. This lets me think the drive (DVD or Floppy) is
    tested in POST, but is not attempting to boot.
    - I found 2 USB floppy drives. I tried both, and same thing. It's
    POSTed, but apparently not trying to boot.
    - While doing all these tests, I try the laptop with NO HD to see what
    happens, and I get a strange message "Non-system disk or disk error,
    replace and strike any key". This is strange, because it doesn't
    attempt to boot from anything (afaik) but the message is exactly the
    one of the boot sector of typical DOS/WINdows non-bootable disk. In
    reality, it would somehow boot even if only to write that message. Or
    it is an EXACT replica of that message in some kind of ROM or flash
    memory. Now I just tried it with no floppy, no CD, no HD, and still
    same message. If I press a key, it quickly disappears and reappears,
    but nothing whirrs or light up even if there is a floppy or CD.
    - And if I put the original XP HD it boots to that password no matter
    boot option chosen, and the HD from other laptop just freezes with
    cursor on top left, as I said in earlier post.

    Any ideas?
    Knowing the model, if anyone knows how to access CMOS battery or
    jumper on motherboard, I could go that way, but I still keep this as
    the last solution.

    Thanks, again...


    ---------- Forwarded message ----------
    From: "Fred" <>
    Date: Jul 17, 8:50 pm
    Subject: Using laptop HD on desktop, no power felt.
    To: comp.sys.ibm.pc.hardware.storage, comp.sys.ibm.pc.hardware.misc

    No you didnt until much later.
    He's only posted twice so far.- Hide quoted text -

    - Show quoted text -
     
    XYLOPHONE, Jul 20, 2009
    #24
  5. XYLOPHONE

    Rod Speed Guest

    XYLOPHONE wrote
    Feeling the drive with your hand is the best test for a spinup.

    If it doesnt spinup in that config, there is some fundamental
    problem with the adapter powering the drive.
    That doesnt say anything useful about how well you can hear very quiet sounds.
    Thats because it never spins up.
    That can set an ATA password in the drive.
    The maintenance manual calls it a DriveLock password.

    That means that the drive cant be used even if its removed from the laptop.
    F10 actually.
    It may not be set to boot either.
    Nothing strange about that.
    It clearly does and that is why you get that
    message when there is no hard drive present.
    Its the classic bios error message with no hard
    drive present and nothing else to boot from.
    What ?
    Yes, its what most bios report with nothing that can be booted.
    Because there is nothing it can boot from.
    It may not have them in the boot list.
    Thats normal with a bios password set. It wont
    do anything until you enter the correct password.
    http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c01134170/c01134170.pdf
    Section 1.3 tells you how to clear the cmos and reset the passwords.

    http://h20000.www2.hp.com/bizsuppor...kId=101&prodTypeId=321957&prodSeriesId=316692
    has all the manuals.
     
    Rod Speed, Jul 20, 2009
    #25
  6. XYLOPHONE

    Arno Guest

    Hmm. It seems very likely the disk does not get power. Maybe your
    adapter is broken.

    That may be a BIOS setup password.
    Likely correct.
    Likely not it the BOOT sequence in the BIOS setup.
    That is the standard message, if none of the configured boot
    devices are detected. It your case it looks as if the machine
    is set to only boot from HDD. Generally this does not allow
    diagnostics in case of problems, as you are finding out. The
    typical fix is to go into the BIOS setup (which does not
    require the HDD or anything, just possibly the BIOS setup
    password) and configure an additionsl boot device.
    Not strange, but likely nothing but the HDD is configured to be
    bootable.
    You could try to copy the XP installation to a different disk
    in order to determine whether the laptop BIOS is expecting
    this particular disk or just the system on it.
    Here are some references that may describe your issue:

    http://forums13.itrc.hp.com/service...47627+1248121832472+28353475&threadId=1056906

    http://answers.yahoo.com/question/index?qid=20080320220803AAJzJNM

    http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c01134170/c01134170.pdf

    It seems this thing can be locked and that others went the way
    of disconnecting the CMOS battery. The third link is the
    "Maintenance and Service guide", that seems to be what
    you are looking for, see Section 5.17.

    Arno



     
    Arno, Jul 20, 2009
    #26
  7. XYLOPHONE

    Trent Guest

    Don't give a **** about the OP problem, just your idiotic incorrect
    assertion, dick-less.
    Nope. Go ahead and try it, shitlips. Short #reset to GND and power up the
    motherboard; the drive will *not* spin up.
    Now and again one has to apply the Ruler of Reason to the Knuckles of
    Stupidity. If the PATA port is completely dead, #reset could be driven or
    not. No one can say, you numb, flatulent ****.
     
    Trent, Jul 21, 2009
    #27
  8. XYLOPHONE

    Fred Guest

    Wota stunningly rational line of argument you have there, child.
    That wont happen even if the PC controller is completely dead, fuckwit child.
    Pity that wont happen even if the PC controller is completely dead, fuckwit child.
    Never ever could bullshit its way out of a wet paper bag.
    Wrong, as always.
    Wota stunningly rational line of argument you have there, fuckwit child.
     
    Fred, Jul 21, 2009
    #28
  9. XYLOPHONE

    Trent Guest

    Ever hear of topic drift, Pinhead?
    Absolutely, positively, not.
    It can, but you're much too ignorant to understand why. Shorting it to GND
    would simulate a controller that is dead in such a way as to be asserting
    #reset.
    See above, Chim-Chim.
    The true Rod comes out. When will you begin your snip-n-run tactics?
    Completely correct, Mongo.
    Starting to repeat yourself just like you did when I kicked your flabby
    ass over this exact same issue in 2007. Heh.
     
    Trent, Jul 21, 2009
    #29
  10. XYLOPHONE

    Fred Guest

    Wota stunningly rational line of argument you have there, child.
    Wrong, as always.
    Wota stunningly rational line of argument you have there, child.
    Wrong, as always. No dead controller would short that, fuckwit child.
    Completely useless, as always with your shit, fuckwit.
    Never ever could bullshit its way out of a wet paper bag.
    Wrong, as always.
    Only in your pathetic little drug crazed fantasyland, fuckwit child.
     
    Fred, Jul 21, 2009
    #30
  11. XYLOPHONE

    Trent Guest

    Indeed. And you'd do well to remember that, Rain Man.
    It's an easy experiment to do. Instead of making a fool of yourself on
    Usenet (again) why don't you power up a drive with it's #reset signal
    connected to GND?
    That goes without saying. A pity you're unable to keep up.
    You have no way of knowing *how* a piece of silicon will behave when it
    fails, Rain Man. In fact, when a chip fails internally, one of the most
    common faults is that one or more of it's outputs will be driven low.
    Like #reset, for example. Heh.
    It's a good thing you aren't wearing cleats, as often as you step
    on your crank.
    I've noticed. That's usually when you start churning out weak comebacks
    like that.
    How fucking persistent you are. I admire a captain that goes down with his
    ship, though.
    Would you like a re-post?
     
    Trent, Jul 23, 2009
    #31
  12. XYLOPHONE

    Rod Speed Guest

    Some gutless fuckwit desperately cowering behind
    Trent desperately attempted to bullshit its way out of its
    predicament and fooled absolutely no one at all, as always.
     
    Rod Speed, Jul 23, 2009
    #32
  13. XYLOPHONE

    XYLOPHONE Guest

    Thanks Arno, for the links. I know how to unmount everything...

    Meanwhile, I have been able to get another adapter, and format the
    HDD.
    No password anymore! I made it a bootable disk (making a Ghost copy of
    the desktop partition).
    I put the drive back in the laptop, and surprise! Nothing happens,
    just a blank screen with cursor at top left!!! So it's just the same
    symptoms as the other drive that came from the other laptop.
    I discovered the original laptop drive is a 60GB drive. The one from
    the other laptop is a 20GB drive.
    I know this is the Windows from another machine, but I expected it to
    boot to some point, freeze, or crash... If I only could get to a DOS
    prompt, I could try and reset battery using DEBUG. How would I do
    this, now that the original drive is erased, and made bootable again.

    Thanks.
     
    XYLOPHONE, Jul 23, 2009
    #33
  14. XYLOPHONE

    Rod Speed Guest

    Its actually the classic result you get if the Win install was on a system
    with the chipset different enough to the one you are getting that effect with.
    The manual link I gave you tells ou how to reset the laptop
    at a variety of levels, reset the password, reset the cmos etc.
    Normally you could fix that blank screen with a cursor at top left
    by booting from the Win CD and doing a repair install. But you said
    cant boot the Win CD. Maybe you can now that the password is gone.

    If that doesnt work, reset the cmos as the manual says and boot
    the Win CD once you can tell the laptop to boot off the CD.
     
    Rod Speed, Jul 24, 2009
    #34
  15. XYLOPHONE

    Trent Guest

    <>:

    I noticed that I didn't get a response to my last post in this subject, so
    I google groped this thread to see if you had replied. Sure enough, like
    Pavlov's dog, you did. But, understandably, your "Rod Speed" persona is
    kill-filed.

    [All my valid assertions go MIA.]

    But, I'll summarize again. Take *any* PATA hard drive and short pin 1 to
    pin 2, (#RESET to GND) then apply power to the drive. The motor will *not*
    spin up. This will not hurt the drive whatsoever, in case anybody might
    not know this - you could even use a flat blade screwdriver to short the
    two pins. Rod is probably unable to find these two pins on a PATA drive,
    so is unable to perform this simple test.

    Anyway, on to Rod's copy-n-paste canned response:
    Three days ago I posted:
    Heh. SPANK, you fucking weak-kneed pussy.

    Don't bother "cowering behind" your kill-filed "Rod Speed" nym if you want
    me to see your response, fucknuts. I won't bother taking the time to
    Google group search this thread again.

    Buh-bye!
     
    Trent, Jul 24, 2009
    #35
  16. XYLOPHONE

    Rod Speed Guest

    Some gutless fuckwit desperately cowering behind
    Trent desperately attempted to bullshit its way out of its
    predicament and fooled absolutely no one at all, as always.
     
    Rod Speed, Jul 24, 2009
    #36
  17. XYLOPHONE

    Arno Guest

    Ok, first step accomplished, the disk works and has what you want on it.
    If they implemented the password protection right, then you cannot.

    You should have a look at the battery removal instructions, form
    a quick glance they did not seem to problematic.

    Arno
     
    Arno, Jul 24, 2009
    #37
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.