1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

V240 w/ Qlogic (qus) and tape drives

Discussion in 'Sun Hardware' started by Daryl Clevenger, Jun 3, 2004.

  1. I have a SunFire V240 running Solaris 9 containing 2 Qlogic SCSI cards.
    I can not get the kernel to recognize an attached Quantum DLT8000
    tape drive. Disks attached to the Qlogic card work fine. The
    tape drive works fine attached to the external glm SCSI port.

    I will provide the details below of what I have installed. Is there
    a trick involved with getting a DLT8000 to work on the qus cards?

    -R#- uname -srvmpi
    SunOS 5.9 Generic_112233-10 sun4u sparc SUNW,Sun-Fire-V240

    -R#- pkginfo | fgrep qus
    system SUNWqus QLogic Ultra3 Scsi, (Root)
    system SUNWqusu QLogic Ultra3 Scsi, (Usr)
    system SUNWqusux QLogic Ultra3 Scsi, (Usr) (64-bit)
    system SUNWqusx QLogic Ultra3 Scsi, (Root) (64-bit)

    -R#- showrev -p | fgrep qus
    Patch: 112706-02 Obsoletes: Requires: Incompatibles: Packages: SUNWqus, SUNWqusx

    I believe there is a -03 version of the patch, but I have not tried it.

    The qus driver and patch are installed. The information from the
    kernel probe of the qus device:

    unix: PCI-device: [email protected], qus0
    unix: qus0 is /[email protected],600000/[email protected]/[email protected]
    unix: /[email protected],600000/[email protected]/[email protected] (qus0):
    Firmware Version: v10.04.38, Customer: 0

    "probe-scsi-all" finds and displays the vendor id for the DLT8000.

    However, a "boot -rv" does not find the tape drive. Running devfsadm
    the same. I also tried "cfgadm" without any success. In fact,
    "cfgadm -v -c configure c6" hung and was unkillable.

    The tape drive is the only device on the SCSI chain and has proper
    termination. The cable is fine.

    Possibly related information. I moved an external RAID array from
    the glm port to a qus port. The array is working fine, but during
    the "boot -rv", the following errors were logged:

    unix: WARNING: /[email protected],700000/[email protected]/[email protected]/[email protected],0 (sd321):
    Request Sense couldn't get sense data
    unix: sd321 at qus3: target 0 lun 0
    unix: sd321 is /[email protected],700000/[email protected]/[email protected]/[email protected],0
    unix: WARNING: /[email protected],700000/[email protected]/[email protected]/[email protected],0 (sd321):
    Request Sense couldn't get sense data

    Despite this, the RAID array set (sd321) is working fine. Of course,
    SCSI is robust enough that it may be working, but suboptimally.

    I may be able to replace the qus with glm cards (which are fine for
    driving tape drives), but I prefer an LVD interface. Is the glm
    interface SE only (the stamp on the PCI slot plate only has "SE")?
     
    Daryl Clevenger, Jun 3, 2004
    #1
    1. Advertisements

  2. What's in your sd.conf file? Are you using a SCSI target for that
    controller outside the range that's defined in the file?
     
    Michael Vilain, Jun 3, 2004
    #2
    1. Advertisements

  3. I realize that it is bad form to reply to ones own post, but I finally
    figured out an explanation for my difficulties.

    Googling for

    qlogic ISP10160 solaris

    led me to

    http://docs.sun.com/db/doc/816-5177/6mbbc4g8l?a=view

    This is the Solaris 10 qus(7D) man page.
    I believe this and the inability to recognize the tape drive are related.
    I used the Solaris 9 (not patched with the "qus" packages)
    /usr/include/sys/scsi/conf/autoconf.h as a guide for the flags.

    The problem(s) were solved by creating a "qus.conf" file containing:

    scsi-options=0xfe8

    This has the effect of

    Disabling linked commands (not supported according to qus(7D)
    Disabling FAST80

    Despite the fact the qus(7D) indicates that the controller supports
    FAST80, this flag appears to be what resulted in

    Request Sense couldn't get sense data

    and the DLT8000 tape drive not being recognized as attached by either
    the kernel or devfsadm. The external RAID array is an AC&NC
    JetStor III IDE.

    I initially used the first example (0x78) in the above document. This
    caused the DLT8000 to be recognized and attached and the "Request Sense"
    warnings to go away. But, the I/O to the RAID array was pathetic.
    More trial and error led me to what appears to actually have caused
    the warning message and how to make the I/O more reasonable.

    Thanks to Michael Villain for providing a suggestion, even though it
    proved to be unrelated.
     
    Daryl Clevenger, Jun 4, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.