Verify volume failed with error Could not unmount disk

Discussion in 'Apple' started by trpublicaddress, Sep 8, 2006.

  1. I have an external firewire drive that is acting up. Disk Utility
    reports:

    Verify volume failed with error Could not unmount disk

    I also can't erase it (same error).

    Can anyone suggest some fsck magic or another approach?

    Thanks.
     
    trpublicaddress, Sep 8, 2006
    #1
    1. Advertisements

  2. trpublicaddress

    Guest Guest

    (2 things)
    Hopefully some unix knowledgeable person will, but if not, and if the
    data on it is really important, you could download DiskWarrior and try
    to salvage it with that. It costs about 70 dollars now, I think, but
    it's one of the very few I think has more than paid for itself as far as
    I am concerned.

    Before that, you could try disk utility to see if your disk is SMART
    (self-diagnostics to anticipate a failure). launch Disk Utility, click
    on the top-level indicator for your drive. See 'smart status' in the
    bottom of the window. If it's not there, then the disk doesn't support
    it, if it is there it should say 'verified'. If it doesn't then the disk
    is likely to fail soon. So if it is ok, get DiskWarrior. No guarantee of
    course, but it has never been unable to recover a disk for me so far,
    and is a good thing to have anyway. When you purchase it a boot disk is
    posted to you as well, so you can use it on any internal drive.

    HTH

    Andy
     
    Guest, Sep 8, 2006
    #2
    1. Advertisements

  3. I'd add that if a process is running on the external disk, you'll get
    that message. So it'd be worth it to make absolutely sure nothing is
    running on that disk. What happens when you try to dismount the disk by
    dragging it to the trash or hitting eject?
     
    John McWilliams, Sep 8, 2006
    #3
  4. trpublicaddress

    Daniel Cohen Guest

    Had you tried restarting and running Disk Utility again.

    I ask because I had that error once. I shut down my Mac, and ran Disk
    Warrior to cure any problems.

    And some time later it happened again, but I had a thought which I think
    was correct. There was nothing running on the disk, as far as I recall,
    but I had just been reading from it using a Classic program. It seems
    that, even after quitting that program and stopping Classic, the disk
    was still treated as being in use. So a restart cured the issue.
     
    Daniel Cohen, Sep 9, 2006
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.