W200 Multiport modification?

Discussion in 'Compaq' started by Josh Schneider, Feb 24, 2005.

  1. Hello. Has any owner of an Evo or Presario with a Multiport module on the
    lid ever modified it to accept a standard USB 2.0 device (i.e., a standard
    USB plug)? I've just been thinking that it might not be so hard to replace
    the W200 802.11b card with a newer 802.11g USB 2.0 key card and then just
    replace the cover. Of course, I might be horribly wrong!


    Josh Schneider, Feb 24, 2005
    1. Advertisements

  2. Hi Josh,

    I have the W200 802;11b multiport card you are refering to. To the best of
    my knowledge, HP Compaq never released a faster G or A speed via Multiport.

    I have an EVO 800V 2.0Ghz P4 and its consumer Presario 2878CL 2.0Ghz
    equivalent - both use the Multiport devices. I use a Bluetooth on the
    Presario, and I had purchase a stripped Compaq EVO D510U Ultra Smal Form
    factor which uses the Multiport for its optical drive and you can mount the
    W200 multiport on its side, too.

    Pretty nifty not to mention that the D510U has a 2GB RAM capacity and I run
    the 2 1GB memory upgrades in it. It's FAST.

    I would love to get a GPRS Multiport for GPRS wireless, they were marketed
    in Europe according to what I read on the HP website.

    My experience and 2 cents!
    Mary B. Winfield, Feb 24, 2005
    1. Advertisements

  3. Thanks for the input, Mary

    I realize HP/Compaq never released anything other than the W200 (802.11b)
    and Bluetooth module in the US. If there's really another option in
    Europe for GPRS and even a drive, maybe there's something else floating
    around out there.

    Really, though, I was thinking that the multiport connection on the
    Presario/Evo models that have it use a proprietary USB connection, and
    that if it could be modified to create a standard USB socket, any
    miniature USB device, including 802.11g, could sit underneath that lid.
    The connection on the laptop lid is basically an array of 8 contacts, I
    think, with which the multiport modules mate and keep tight contact using
    a small spring load. If this isn't just a modified USB connector, please
    correct me.


    Josh Schneider, Feb 26, 2005
  4. Josh Schneider

    XStylus Guest

    I decided to tinker a bit in the hopes that I could gut the innards of a
    W200 and put in a more Linux friendly USB adapter (perhaps an 802.11g
    adapter even). The Linux drivers for the Orinoco based W200 seem to only
    work when they want to.

    Here's the pinout that I've discovered so far. I haven't tested this port
    for standard USB functionality yet, but they seem USB standard. I have a
    hunch that there may even be two USB ports here, but I don't know for
    certain just yet.

    Pin 1: Ground (Black)
    Pin 2: vcc +5 volt (Red)
    Pin 3 and 4: Data - (White)
    Pin 5 and 6: Data + (Green)
    Pin 7: Unknown (Perhaps this sends the Fn-F2 signal?)
    Pin 8: Ground (Black)
    XStylus, Aug 9, 2005
  5. Josh Schneider

    XStylus Guest

    My previous data was incorrect, however I do have updated info. I managed
    to get a USB mouse working via the Multiport using this pinout

    Pin 1 or 8: Ground
    Pin 2: vcc +5 volt (Red)
    Pin 5: Data + (Green)
    Pin 6: Data - (White)

    I have no idea what pin 3, 4, and 7 do.

    Now it's time for me to go run to Best Buy and buy me a USB WiFi adapter.
    XStylus, Aug 9, 2005
  6. Josh Schneider

    mrjoshua Guest

    can you give some details and/or pictures on how you did this? i wan
    to do the same but i'm having trouble with the nuts and bolts..

    mrjoshua, Aug 13, 2005
  7. Josh Schneider

    viglactin Guest


    Hi, I am also very interested as to the possiblity of changing the
    compaq W200 from 802.11b to g.
    viglactin, Aug 25, 2005
  8. Josh Schneider

    viglactin Guest


    Hi, Can you kindly post a picture of which is red, black etc.

    Thanks in advance
    viglactin, Aug 27, 2005
  9. Josh Schneider

    XStylus Guest

    Can't provide pictures, sorry, but the pins on the multiport are
    numbered and I can tell you which does what. I have wired up a
    working netgear MA111 WiFi adapter to replace my dying multiport
    card, and it works fine.

    With the laptop facing you, the pins are numbered as such:


    Pins 1 and 5 are even marked to help you, in case the above diagram
    isn't good enough.

    If you were to chop up a USB cable, you'll find four cables - Red,
    Green, White, and Black. You may also have an outer wirey mesh or
    sheath, which serves as interferance shielding and also doubles as
    ground (which is also the black wire's job too).

    Pin 2 = Red
    Pin 5 = Green
    Pin 6 = White
    Pin 1 or 8 (either one is fine) = Black/Ground

    As for the other pins, I have no idea what they're for, nor do I need
    to care. The above pins give a normal USB port, and that's all I need
    to know. However, note that the Fn-F2 button you used to use to switch
    the multiport on or off will no longer do squat.

    I bear no responsibility if you blow things up, so use at your own
    risk. It works for me though.

    For people who own a Presario 900 or an older Compaq with Multiport
    capability, this still only gives you a USB 1.1 port. So, if you're
    looking to replace your 802.11b W200 with a fancy 802.11g card,
    you're wasting your time and money. Grabbing an 802.11g card will do
    you no good what-so-ever because the port can't go any faster than
    11mbps, unless you want it strictly for bragging rites.

    If you own a Presario 1500 or newer, I think those units are equipped
    with USB 2.0 chipsets so you might get some love there if you want
    802.11g, but I'm not 100% on that. Your milage may vary.
    XStylus, Nov 4, 2005
  10. Josh Schneider

    stancatau Guest

    Hi everyone

    My frd got a Presario 280

    soldered with a normal usb socket to the multport
    tested with a mouse, mobile hdd, usb memory ke
    all work

    expect a Dlink 122G usb wireless,
    if plug into the motherboard, it work
    but whenever plug into the multiport, window reckon as Unknow Devic

    and one more funny thing, all ports on motherboard are 2.
    but the multiport is 1.1 with usb hdd pluged as windows described...

    and ideas why the wireless usb is not working? thank
    stancatau, Nov 30, 2005
  11. Josh Schneider

    LANCEB1B Guest

    LANCEB1B, Dec 1, 2005
  12. Josh Schneider

    MrGogo Guest


    guys ok I tried it.
    Seems to work ony my Compaq evo N410c unfortunatly it only works as a
    USB 1.1 port even though the rest of the ports are 2.0

    I guess this is why they never released a 802.11g usb2.0 adaptor.
    Either all the older models only have a 1.1 port or they all do.
    MrGogo, Dec 2, 2005
  13. Josh Schneider

    stancatau Guest


    wot hv u plug into the multiport for testing
    since i tried an ASUS wireless USB and windows rekcon as Unknow
    stancatau, Dec 2, 2005
  14. Josh Schneider

    ralf Guest


    I just modified a N600C as described by XStylus and soldered a shor
    USB cable to the Multiport connector
    It works perfectly using a "Hama Wireless LAN USB 2.0 Stic
    Hama was the cheapest 54Mbps Stick I could get (the driver say
    "ZD1211"). The stick is thin enough to place the W200 cove
    over it .
    Yes, Multiport is only USB 1 but even though the Hama stick its faste
    than the original W200. The config tool provided by hama reports
    transfer rate usually around 48Mbps depending on the signal quality
    I did not prove these numbers yet but the connection feel
    signifficantly faster

    Thanks Xstylus
    ralf, Jan 28, 2006
  15. Josh Schneider

    djmels Guest

    Thanks so much for the pinout, XStylus! I managed to hook up my
    LevelOne WNC-0301USB 802.11g dongle to the multiport of my Evo n410c
    and it even seems to take USB 2.0. I see nothing complaining as I have
    seen before when I've got a USB2.0 device on a USB1.3 port; "this
    device could run faster" or whatever it would be in the English
    version of windows. Nothing of the sort, and it connects to the wifi
    in a perfectly normal fashion. I'll test it to see if anything more
    than 11mbps is coming through in a moment, lunch first :p.
    djmels, Mar 2, 2007
  16. Josh Schneider

    djmels Guest

    Update: Testing with AIDA32 network benchmark shows it only transfers
    at rates of about 1500KB/s back and forth a.k.a. 11mbps a.k.a. USB
    1.3. Not having tried this yet I hooked the same dongle up to a
    "regular" USB port on the laptop and that TOO gave me only
    However not all is lost as the USB Root Hub it's connected to (in both
    cases) in the device manager has loads and loads of "USB20"
    mentionings in its Properties>Details tab. I reckon some driver
    updates etc. are all that's needed to give it a nice little USB2.0
    speed boost. Let's see.
    djmels, Mar 2, 2007
  17. Josh Schneider

    estefan20 Guest

    My previous data was incorrect, however I do have updated info. I
    yea this is and old thread, here is more info on multiport pins

    Pin 1: Ground
    Pin 2: vcc +5 volt (Red)
    pin 3: f2 3.3v=on off=0v
    pin 4: f2 3.3v=0n off=0v
    Pin 5: Data + (Green)
    Pin 6: Data - (White)
    pin 7: unknown
    pin 8: Ground

    one possable use for pin3,4
    using a npn transistor with the base on 3, +device on pin2, -device
    on emitter, collector to pin 1 or 8, you should be able to turn your
    device on/off with the fn+2
    estefan20, Mar 12, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.