Western Digital WD800 Not Detected in WinXP

Discussion in 'Abit' started by Damaeus, Nov 11, 2003.

  1. Damaeus

    Damaeus Guest

    I can't get the Abit KT7A-RAID BIOS to detect the WD800 hard drive I have
    connected to IDE3. Everything is connected properly and during the boot, I
    can see that the Highpoint lists the drive as filling one of the four
    available spaces, but Windows doesn't see it, but I don't know if the BIOS is
    supposed to detect it somehow or not. If it is supposed to, it isn't. And
    neither is Windows.

    Any ideas what's going on?


    =======================================================================
    System Credentials - Software
    =======================================================================

    Internet : Cox High Speed Internet - 3Mbps Connection
    OS : Windows XP Home - Version 2002 SP-1
    WWW Browser : Internet Explorer 6.0.2800.1106.xpsp1.020828-1920
    Cipher Strength: 128-bit

    WWW Editor : Dreamweaver 4 / Fireworks 4 Studio / Homesite 5
    E-Mail : Forte Agent 1.93/32.576 w/ Classic Hamster 2.0.0.0
    Usenet : Forte Agent 1.93/32.576 w/ Classic Hamster 2.0.0.0
    Firewall : Kerio Personal Firewall 2.1.4
    AntiVirus : None
    Misc :

    Multimedia : Winamp 2.80
    : Windows Media Player 8.00.00.4487

    Chat : Trillian Pro 2

    Word Proc : MS Office 97
    : MS Works 4.5a
    :



    =======================================================================
    System Credentials - Hardware
    =======================================================================
    Motherboard : Abit KT7A-RAID - BIOS 3R
    AMD Athlon Thunderbird 1200 MHz (Not Overclocked)
    CoolerMaster DP5-6H51 (Recommended by AMD)
    512 MB Infineon PC-133 CAS-2 SD-RAM
    VIA 4.40 4in1 Drivers
    AGP : CL 3-D Annihilator 2 Ultra (GeForce 2 Ultra)(64MB DDR-RAM)
    Running Detonator 44.03 nVidia Reference Drivers (Win98)
    MicronPC 900Mx Trinitron 19" .24mm 1600x1200 @ 88Hz
    Running at 1280x1024 @ 85Hz refresh (no rolling lines)
    PCI 1 : Empty
    PCI 2 : Hauppauge WinTV 404 TV Tuner/Video Capture
    PCI 3 : DSI DI3635 v.90 Fax/Voice WinModem 56k
    PCI 4 : SoundBlaster Live Platinum 5.1
    Front Speaker Output: Monitor Mounted Speakers
    Rear Speaker Output: Temporarily Empty :-(
    Gameport: Gravis xTerminator Digital Gamepad
    Mic: Packard Bell Microphone
    PCI 5 : Empty
    PCI 6 : Linksys Network Everywhere Fast Ethernet NC100 2.1
    ISA : Empty

    Serial 1 : (COM1) Empty ;Creative ModemBlaster DE5625 56k External
    Serial 2 : (COM2) Empty

    Parallel : Mustek 600 III EP Plus Scanner

    USB 1 : Empty
    USB 2 : Empty

    PS/2 1 : Logitech Optical MouseMan Wheel
    PS/2 2 : Microsoft Natural Keyboard Elite
    CueCat Barcode Scanner

    Case: Antec SX1030B (Black)
    Power Supply: 400 Watts
    5.25 #1 ex: Toshiba SD-R1002 CD-RW/DVD-ROM Combination Drive
    CD Digital Out to SB Live Platinum 5.1 in PCI #4
    CD Analog Out to SB Live Platinum 5.1 in PCI #4
    5.25 #2 ex: Empty
    5.25 #3 ex: Empty
    5.25 #4 ex: Creative Soundblaster Platinum 5.1 Live Drive II/IR
    3.5 #1 ex: A:\ TEAC 3.5: Floppy Model FD-235-HF
    3.5 #2 ex: Empty
    3.5 #3 in: Empty
    3.5 #4 in: Western Digital WD800JBRTL 80GB ATA-100 7200RPM HardDrive
    3.5 #5 in: Maxtor 30GB ATA-66 7200RPM Hard Drive Model 53076U6
    3.5 #6 in: TriGem 4.3GB ATA-33 5400RPM Hard Drive
    Cooling :
    CPU: Heatsink : CoolerMaster DP5-6H51 (Recommended by AMD)
    Rear:
    P/S Cooling Fan : Antec DF1208SL - 0.20 amp - 12 volt
    Rear Cooling Fan 1 : Antec DF1208SL - 0.20 amp - 12 volt
    Rear Cooling Fan 2 : Manhattan 700894 Ball Bearing
    Front :
    Front Cooling Fan 1 : Silencer Mod. 802812 - 0.075 amp
    Front Cooling Fan 2 : Generic Fan
     
    Damaeus, Nov 11, 2003
    #1
    1. Advertisements

  2. Damaeus

    TomG Guest

    you have a Highpoint driver set loaded that matches the bios version for the
    Highpoint controller? the controller bios should detect the drive (and it
    sounds like it is since you say you see the drive during boot) but the
    mainboard bios will not see the drive.

    assuming you have Highpoint drivers loaded in the OS and that the Highpoint
    controller shows in the device manager without any problems, then I'd look
    in Computer Management under Control Panel and then in Disk Management and
    see if you don't see the drive there. if you do, then remember that you
    need to partition and format the drive to be able to use it.

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 118,000 FTP users served!
    ^^^^^^^
     
    TomG, Nov 11, 2003
    #2
    1. Advertisements

  3. Damaeus

    Peter Friend Guest

    You will need the WD special cable. I got one the next day from WD direct.
    You can actually make one - one of the leads is cut but Im buggered if i
    can remember which one.

    Hope this helps

    Peter
     
    Peter Friend, Nov 11, 2003
    #3
  4. Damaeus

    TomG Guest

    "special cable"?? what kind of special cable... please elaborate.

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 118,000 FTP users served!
    ^^^^^^^
     
    TomG, Nov 11, 2003
    #4
  5. Damaeus

    Damaeus Guest

    I thought that was just for the 40-gig drive.

    Damaeus
     
    Damaeus, Nov 11, 2003
    #5
  6. Damaeus

    Damaeus Guest

    You know, I'm not really sure. I was going to flash my BIOS, but my floppy
    drive is messed up. It's used so infrequently that I guess the air pulled
    through the system by the fans has sucked dust or something into the floppy
    drive. I put it in there new, it's rarely been used, and now it does spin,
    but no matter what disk I put in there, the drive says the disk hasn't been
    formatted.

    I wonder if it's possible to flash a BIOS using a CD-R.
    I guess I'll see if I can figure out which Highpoint BIOS I have. How does
    one tell?

    In the device manager, under SCSI and RAID controllers, I see Mass Storage
    Controller and it has a problem (one of the yellow/black exclamation points is
    over the icon).

    Under IDE ATA/ATAPI controllers, I see:
    Primary IDE Channel
    Secondary IDE Channel
    VIA Bus Master IDE Controller

    I went to http://www.highpoint-tech.com/usaindex.htm and looked at the
    available drivers, but I'm not sure which one I need. I'm running the 3R BIOS
    on my KT7A-RAID, so it's an older one -- the one that fixed the crackling
    problem that this chipset had with Soundblaster Live cards. The only driver
    set I see available for XP is the one titled Win2k_XP_v2.0.0919_370.zip.

    I'll try that one since it's the only XP version available, and I'll see if
    it'll work.
     
    Damaeus, Nov 11, 2003
    #6
  7. Damaeus

    Damaeus Guest

    Where should I be looking in the Device Manager for the Highpoint controller?
    I can't really tell if it's installed or not. Apparently it isn't if the
    system isn't seeing it. Is it part of the Via 4-in-1 setup?
    The drive is not showing up in Disk Management.
     
    Damaeus, Nov 11, 2003
    #7
  8. Damaeus

    Damaeus Guest

    When I first installed the drive, I got this message upon booting windows for
    the first time after physically installing it:

    http://www.web-recon.com/img/mass-storage-controller.png

    That is the message I get when Windows tries to install the controller
    automatically, and it's also the message I get when I try to download the
    latest drivers from www.abit-usa.com or Highpoint Tech.

    I hit CTRL+H during the boot process and entered the Highpoint BIOS. It
    definitely sees the drive and shows it to have around 78,500 megabytes, which
    sounds about right for 80 gigs.

    Why Windows doesn't see it is anybody's guess. No, it hasn't been formatted
    yet, but I can't really format it until it's assigned a drive letter. And I
    can't run the Data Lifeguard Tools because even it can't see the new drive
    from within Windows. And I can't run the floppy because my floppy drive is
    messed up, presumably because it's full of dust, I guess.

    Damaeus
     
    Damaeus, Nov 11, 2003
    #8
  9. Damaeus

    TomG Guest

    you can flash using Flashmenu now which is pretty foolproof. I would go
    that route. DL Flashmenu from the Abit site or my site at the address below
    and you can then flash using that tool.
    the Highpoint bios version is visible on the Highpoint bios screen, usually
    in the upper right corner if I recall but I might be in error on that.
    Highpoint controller will show under SCSI controllers.
    Again, you need to match the Highpoint bios and driver revisions. see what
    the Highpoint bios is and then go after the correct driver.
    there are XP versions of just about every Highpoint driver out there. I
    carry many of them on my site as well.




    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 118,000 FTP users served!
    ^^^^^^^
     
    TomG, Nov 11, 2003
    #9
  10. Damaeus

    TomG Guest

    look under SCSI controllers.
    then the disk is not being seen by the OS at all. are you *sure* that the
    Highpoint bios screen declares the drive?


    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 118,000 FTP users served!
    ^^^^^^^
     
    TomG, Nov 11, 2003
    #10
  11. Damaeus

    TomG Guest

    if the Highpoint controller declares the drive as you say but the OS does
    not see the drive at all, then I am suspicious that the Highpoint controller
    is not correctly installed at the OS level. Check under SCSI controllers
    and see if you see it there...

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 118,000 FTP users served!
    ^^^^^^^
     
    TomG, Nov 11, 2003
    #11
  12. Damaeus

    TomG Guest

    ah, that special cable... all the special cable is is an 80 conductor cable
    and the "cut lead" that he referred to is to make the cable a "Cable Select"
    capable cable. in other words, to use the drive with the Master/Slave
    jumper in the Cable Select (CS or CSEL) position, you would need an 80
    conductor cable with a notch cut into the cable on one conductor.

    you also need an 80 conductor cable to enable ATA66 or higher (ATA66,
    ATA100, ATA133) so be sure you have that in place. I didn't trip to what
    special cable the other poster was talking about just because I never use
    anything *but* the 80 conductor cable on a non SATA drive so I think of them
    as a "regular" cable nowadays...

    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 118,000 FTP users served!
    ^^^^^^^
     
    TomG, Nov 11, 2003
    #12
  13. Damaeus

    Damaeus Guest

    I have a cable that came with my mobo with a notch cut out of one of the
    little tiny wires. I pulled out the cable that came with the drive and
    replaced it with the one that came with the board. I'm now going to reboot
    and check that Highpoint BIOS version.

    Damaeus
     
    Damaeus, Nov 12, 2003
    #13
  14. Damaeus

    Damaeus Guest

    The Abit site says that the Flashmenu program is available for certain models.
    Mine is not listed. The KT7A v1.3 is listed, but I have KT7A-RAID and I think
    it's the older version on top of that.

    I haven't yet found controller files for BIOS 1.11.0402. I was going to try
    to flash the Highpoint BIOS from DOS, but I don't think it's really possible
    to have a pure DOS session in WinXP, even in safe mode with command prompt. I
    guess I could with a boot disk. Maybe I'll run out tonight and see if I can
    find a floppy drive someplace. I'll just get the latest BIOS for the
    motherboard, and flash everything. I have found the proper controller files
    for the latest BIOS, but not for the one I actually have right now, which is
    3R.
    It's displayed during the boot, I noticed, on the top right corner.
    Yeah... Mass Storage Controller is there now, but it has a problem.
    Trying, but the only thing I've found for my version 1.11.0402 is a GUI
    interface for maintaining the RAID array, and the 1.11.0402 BIOS itself. I
    have not found any controllers. :-(
    I've only found XP versions within Win2k_XP_v2.0.0919_370.zip and that's it.
    And that was from the highpoint-tech site. None of their other ZIPs mention
    anything about containing XP versions.
     
    Damaeus, Nov 12, 2003
    #14
  15. Damaeus

    Damaeus Guest

    Okay, that's where I was looking before because it's the first place that has
    shown "trouble" since I installed XP.
    Definitely.

    I also tried disconnecting the two drives not on the Highpoint connectors. I
    booted with the WinXP installation disc in the CD-ROM to try to see if the
    Windows Installation could find the drive. It could not. It said no hard
    drive was installed so installation could not continue.

    Why this thing is not being found is beyond my understanding. I'm about ready
    to just forget about the Highpoint controllers and I'll just use the darned
    thing on the regular IDE chains. As I work on this, I'm also backing up files
    from the old 4-gig drive which I'll replace with the new 80-gig if we can't
    figure this thing out. But I'd sure like to keep all three in there
    because...well, it's just cool, IMHO, to have three hard drives in the
    computer, and I'd really like to use the Highpoint controllers for the
    increased performance.

    If I have to, I'll go out and buy yet another floppy drive so I'll have some
    way to update the BIOS since Flashmenu is not compatible with the KT7A-RAID.

    Damaeus
     
    Damaeus, Nov 12, 2003
    #15
  16. Damaeus

    Damaeus Guest

    The entry is there, but it's not installed correctly. It has a yellow
    exclamation icon on it. But no matter which drivers I install, it never
    works. It always has the same message:

    ,-------------- [ Found New Hardware Wizard ] --------------.
    | Cannot Install this Hardware |
    | |
    | |
    | |
    | There was a problem installing this hardare: |
    | |
    | Mass Storage Controller |
    | |
    | |
    | An error occured during the installation of the device. |
    | |
    | The driver installation file for this device is missing a |
    | necessary entry. This may be because the INF was written |
    | for Windows95 or later. Contact your hardware vendor. |
    | |
    `-----------------------------------------------------------ยด

    Nothing Western Digital suggested worked... which basically consisted of
    changing IDE cables and removing the jumper completely from the drive.

    She may be clueless because she said their hard drives don't need drivers.
    No, they don't. But controller drivers are needed.

    Damaeus
     
    Damaeus, Nov 12, 2003
    #16
  17. Damaeus

    Damaeus Guest

    BIOS Version is 1.11.0402.
     
    Damaeus, Nov 12, 2003
    #17
  18. Damaeus

    Damaeus Guest

    Strangely enough, information from Highpoint was right on target. The
    stranger part is that the controller version and the BIOS version I'm using do
    not match. Yet I've been able to format a 20-gig partition on the new drive,
    and write files to it. Maybe the mismatched controller/BIOS will come back to
    bite me on the boo-hiney one of these days, but right now, it works!

    Here's what they sent to me:


    Thanks for your contacting us!
    You can download the v2.34 software from
    http://www.highpoint-tech.com/driver_v234_370_372.zip


    You can install the Windows XP driver as following steps:

    1) Open the Device Manager.

    2) Open the HighPoint controller property dialog(Mass
    Storage Controller)

    3) switch to "drivers" tab page.

    4) click the "update driver" button.

    5) select install from a list or specific (advanced)

    6) select don't search i will choose the driver to
    install

    7) select scsi and RAID controllers

    8) click have disk...

    9) select the folder include the driver(for example
    :a:\win_xp)

    10) install driver

    11) reboot system

    If you want to update the HPT RAID controller BIOS, you can contact
    motherboard manufacture to tell you how to merge it to your
    motherboard BIOS.

    Regards,
    HighPoint Technologies Inc.


    Well, what works, works.

    Damaeus
     
    Damaeus, Nov 12, 2003
    #18
  19. Damaeus

    TomG Guest

    keep in mind that you *cannot* flash the Highpoint bios directly. you can
    only flash the mainboard bios so you would need to flash the mainboard bios
    with a bios version that contains the Highpoint bios version you are after.
    the Highpoint bios is "embedded" into the mainboard bios.
    drivers not loaded correctly. you'll need to fix that.
    1.11.0402 is a very old version of Highpoint bios. you need to look at the
    mainboard bios version and see if you are running the most current mainboard
    bios version. if not, the Highpoint bios version will get updated with the
    mainboard bios version, up to a point. Abit stopped updating the mainboard
    bios after a time if the only reason to update the bios was to update the
    Highpoint bios version. that is when folks out in the user arena took over
    and started updating the Highpoint bios ourselves. I carry many "custom"
    bios version on my FTP site that are regular released Abit mainboard bios
    with an updated version of Highpoint bios.

    my favorite Highpoint bios was for that flavor of controller was 2.0.1203
    but certainly going all the way to 2.32 or higher (2.34 is tops I believe)
    would be fine as long as you load the matching drivers. See what you can
    find from the mainboard bios (as far as the Highpoint bios version goes...)
    and if you are interested, check out my site under /beta (only called "beta"
    to distinguish from regular Abit released bios sets).
    then you are looking in the wrong place. there is an XP version of driver
    for all of the 370/372 and above Highpoint controllers.




    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 118,000 FTP users served!
    ^^^^^^^
     
    TomG, Nov 12, 2003
    #19
  20. Damaeus

    TomG Guest

    this is because you probably needed to hit F6 to signal to XP that you had a
    SCSI or raid driver to load which would have enabled XP to use the Highpoint
    controller. keep in mind that an OS does not necessarily have native
    support for every controller out there.
    the Highpoint controller is not so hard to use if you do your research and
    learn what there is to know about implementing it before running into all
    kinds of trouble. now, there is a frustration factor in the mix that is
    beginning to dog you...
    if Flashmenu does not work for your board, somehow you have to be able to
    boot to a pure DOS environment to be able to flash. I guess a bootable CD-R
    or CD-RW with the flash files and bios file would work...




    --

    Thomas Geery
    Network+ certified

    ftp://geerynet.d2g.com
    ftp://68.98.180.8 Abit Mirror <----- Cable modem IP
    This IP is dynamic so it *could* change!...
    over 118,000 FTP users served!
    ^^^^^^^
     
    TomG, Nov 12, 2003
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.