Whats up with the Aopen website?

Discussion in 'AOpen' started by John, Sep 7, 2003.

  1. John

    John Guest

    Tried to get on to aopen site ... seems all download links are broken
    (Internal server error), can anyone actually get a bios update at the
    moment?

    And while on the subject of Aopen website ... (jumps on soapbox) there are
    browsers out there OTHER THAN MicroShaft Internet Exploder (jumps off
    soapbox - spleen vented)
     
    John, Sep 7, 2003
    #1
    1. Advertisements

  2. John

    Nystagmus Guest

    Hi John,

    You're not alone. Last night, not for the first time either, I had the same
    experience as you - none of links for BIOS-Drivers-Manual worked. This is
    happening all too often with AOpen's web site for my liking.

    Nystagmus
     
    Nystagmus, Sep 7, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.