Win xp drive letters

Discussion in 'Asus' started by Anon, Mar 2, 2004.

  1. Anon

    Anon Guest

    I completed the assembly of my new P4C800-E system last night. Everything
    went fine, the only h/w mistakes was the panel LEDs didn't work because they
    were backwards.

    The system has 4 hard drives, 1 DVD-RW and 1 DVD rom. The drives are
    configured as follows:

    South Bridge controller:
    74GB WDRaptor: SATA1 (unformatted)
    250GB Hitachi: SATA2 (unformatted)
    160GB Maxtor: Primary IDE, Master (contains data)
    80GB IBM: Primary IDE, Slave (contains data on 2 partitions)
    DVDRW: Secondary IDE, Master
    DVD: Secondary IDE, Slave

    When I installed Windows xp on the WD Raptor, it resulted in these drive
    assignments:

    c: Maxtor
    d: IBM partition 1
    e: IBM partition 2
    f: DVD-RW
    g: DVD rom
    h: WD Raptor (boot drive)

    I like my boot drive to be the c: drive, so I tried to reassign the drive
    letters with Win xp Drive Manager, it would not let me change the drive
    letter of the boot drive. I'm ready to reload Win xp to get the WD Raptor
    boot drive to be the c: drive. Any suggestions on how to do it?

    Al
     
    Anon, Mar 2, 2004
    #1
    1. Advertisements

  2. Anon

    Nanga Parbat Guest

    Disconnect the other drives, format the Raptor and install WinXP on
    it. After that reconnect the other drives. If your BIOS allows it you
    can also just disable the other drives.

    Nanga
     
    Nanga Parbat, Mar 2, 2004
    #2
    1. Advertisements

  3. Anon

    Darkfalz Guest

    c: Maxtor
    In BIOS, make the drive you want to be C: be your first drive. Then create
    the partition in the XP setup on your C: drive and format it in NTFS
    (quick), then reboot. After that, it should be designated the C: drive on
    startup. Then you can install XP on it.
     
    Darkfalz, Mar 2, 2004
    #3
  4. Anon

    Anonymous Guest

    I don't understand - where do I enter this contest?
     
    Anonymous, Mar 3, 2004
    #4
  5. Anon

    Anon Guest

    I disabled them in the bios, then reformatted and reinstalled Windows. It
    worked fine.

    I guess it didn't matter, but it just didn't feel right having the Root
    drive the H: drive.

    Thanks,
    Al

    c: drive. Any suggestions on how to do it?
     
    Anon, Mar 3, 2004
    #5
  6. I had a similar problem with a zip disk on IDE

    Pushed the boot drive to F:

    As the other posters indicated the quickest and safest way is to do a strip
    and reinstall.
     
    David McDonald, Mar 4, 2004
    #6
  7. Anon

    KJ Guest

    not to mention it's a PITA when it seems every windows program in the world
    wants to default to c:\ no matter what the %system drive really is.
     
    KJ, Mar 4, 2004
    #7
  8. Anon

    mmiserus Guest

    Hello,

    This I don't quite understand because -under Win'98se at least- one
    can make use of the settings of the iomega driver to change drive
    letters in an easy way?
    Max M.
    ==================
     
    mmiserus, Mar 4, 2004
    #8
  9. Anon

    Hoonose Guest

    I would just restart the system using just the Raptor boot drive.
    Disconnect all other drives. That should make it C:. Then start adding
    the other drives in whatever order you'd like them to end up....

    Gene
     
    Hoonose, Mar 4, 2004
    #9
  10. Anon

    Tim Guest

    If its WinXP there is a way to edit the registry to reassign the drive
    letters.

    However, you really must have a full system backup in case your system
    becomes unbootable.
    Make sure you have installed and enabled all / full Recovery Console
    functionality otherwise if you get this wrong you will not be able to affect
    anything that is not on what the OS thinks is the boot disk and windows
    directory - it won't let you. IE you end up with a stuffed system & have to
    do a reinstall / restore.

    I had this happen after 2 drives in a raid 1 failed. The second drive only
    partially failed and I got the system back from the maker with the drive
    letters swappped & could do nothing with it 'cos recovery console was not
    installed completely.

    So - three options:

    1. Locate the MS KB article on how to edit / reassign the drive letters.
    Backup everything and then follow the instructions.
    2. Ghost the drives and then ghost them back in the right place.
    3. reinstall windows.

    If you go with 1. double check that the current c: is / is not the boot
    volume - enable viewing of system and hidden files (including OS hidden
    files) then look in c: drive and if you see files: ntldr, boot.ini,
    ntbootdd.sys (optional) etc. then this is a boot volume. You will need to
    copy these files to your 'real' system drive and mark the boot partition
    active.

    One of the fix methods is to use the Win98's fdisk /mbr with the correct
    drive in as C and all other drives out of the picture. This can fail for
    several reasons, effectively stuffing your C: drive partition. I tried this
    and it turned the partition table into custard, but it is supposed to work.

    Recommend method 2 or 3 - less hassle, less technical, and if you stuff up
    1. (which is likely) you will do it that way anyway.

    - Tim
     
    Tim, Mar 5, 2004
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.