Win XP not detecting USB ports.

Discussion in 'Compaq' started by Quavel, Jun 24, 2004.

  1. Quavel

    Quavel Guest

    I have a Presario 5600s
    I had Win 98 installed and the USB ports worked fine under that OS.
    I wiped and installed XP home and now the USB ports will not work.
    Any idea how to fix this or work around it?
    The weird thing is that the Root hub shows in Device manager but
    nothing else. I have uninstalled everything and let XP redetect it and
    also have updated the drivers from VIA Compaq/HP and even some third
    party driver sites. Help please.
     
    Quavel, Jun 24, 2004
    #1
    1. Advertisements

  2. Quavel

    HH Guest

    Hmmm. The Root Hub shows, but the USB Host Controller does not?
    HH
     
    HH, Jun 24, 2004
    #2
    1. Advertisements

  3. Quavel

    Quavel Guest

    OOPS sorry (tired last night when I posted) the "VIA Rev 2 USB
    Universial Host controler" does show. This morning I have tried to
    update the drivers and also force a Rev 4 host drivers and still not
    detecting any thing that is pluged into the ports. The weiredest thing
    is that I get power off the USB Ports my portable HDD lights up for
    power.
     
    Quavel, Jun 24, 2004
    #3
  4. Quavel

    HH Guest

    Dunno.Maybe this is one of those rare instances where an OS upgrade, rather
    than a clean install, is called for. I believe Tom Scales, a regular poster
    on this NG, has a 5600 series PC, anfd I'm almost certain he installed XP on
    it. Maybe he will see the thread and offer a tip.
    HH
     
    HH, Jun 24, 2004
    #4
  5. Quavel

    Tom Scales Guest

    Is the 5600i and the 5600s the same basic machine? I have a pair of 5600i
    machines (one P3-450 and one P3-500) and they both had clean XP Pro
    installs. USB works just fine.

    Tom
     
    Tom Scales, Jun 25, 2004
    #5
  6. Quavel

    HH Guest

    Don't think so, Tom. The 5600s series were VIA chipset boxes with K6/III
    processors.
    HH
     
    HH, Jun 25, 2004
    #6
  7. Quavel

    Tom Scales Guest

    Yeah, the Via threw me. None of my Compaqs had the Via chipset. I seem to
    recall they were very flaky

    Tom
     
    Tom Scales, Jun 25, 2004
    #7
  8. Quavel

    HH Guest

    Tom, They could be. The strange thing is the VIA chipset Celeron and PIII
    5700s were reasonably stable. I used a 5716 PIII/450 as a production unit
    for more than a year with zero issues, first with Win 98SE and later with
    W2K.
    HH
     
    HH, Jun 25, 2004
    #8
  9. Quavel

    Quaoar Guest

    A couple of things to try: In BIOS setup, if there is a setting for
    Legacy USB, try enabling that. Make sure that Plug and Play Operating
    System is enabled, if that is in there. Also, have you installed XP SP1
    and the USB update? Neither should be required for low speed USB, but
    one never knows just what is in these updates.

    As a last resort, remove *everything* USB from Device Manager, reboot,
    and see if now that you have the VIA drivers, that everything gets
    properly enumerated and installed.

    Q
     
    Quaoar, Jun 25, 2004
    #9
  10. Quavel

    Quavel Guest

    Thank you all for your input on this system. I final got so fed up
    with it and put a USB PCI card in it and disabled the onboard USB and
    sent it back to the customer. He was happy since he got a faster USB
    card than was orignaly installed. Again I realy apritiate the input.
    Please let me know if I can help in the future.
     
    Quavel, Jun 26, 2004
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.